Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
marauder

Lighttpd

Question

Mir scheints das alles was in den Ordner "/etc/lighttpd/conf-enabled" geschrieben wird, nockt den lighttps aus... Vielleicht wisst ihr einen Rat...

 

rootmail

Duplicate config variable in conditional 2 global/SERVERsocket==xx.xxx.xx.xx:80/HTTPhost=~^(?:www\.|)mydomain\.de$: server.document-root

2010-03-08 23:10:02: (configfile.c.855) source: cat /etc/lighttpd/conf-enabled/*.conf line: 8 pos: 15 parser failed somehow near here: (EOL)

2010-03-08 23:10:02: (configfile.c.855) source: /etc/lighttpd/lighttpd.conf line: 200 pos: 14 parser failed somehow near here: (EOL)

rndc: 'reload' failed: failure

# Debian lighttpd configuration file
#

###############################################################################
# Default lighttpd.conf for Froxlor.
###############################################################################
var.basedir  = "/var/www"
var.logdir   = "/var/log/lighttpd"
var.statedir = "/var/lib/lighttpd"

############ Options you really have to take care of ####################

## modules to load
# mod_access, mod_accesslog and mod_alias are loaded by default
# all other module should only be loaded if neccesary
# - saves some time
# - saves memory

server.modules              = (
           "mod_access",
           "mod_alias",
           "mod_accesslog",
           "mod_compress",
           "mod_rewrite",
           "mod_redirect",
#           "mod_evhost",
#           "mod_usertrack",
#           "mod_rrdtool",
#           "mod_webdav",
#           "mod_expire",
#           "mod_flv_streaming",
           "mod_evasive",
           "mod_auth",
           "mod_fastcgi"
)

## a static document-root, for virtual-hosting take look at the
## server.virtual-* options
server.document-root       = var.basedir

## where to upload files to, purged daily.
server.upload-dirs = ( "/var/cache/lighttpd/uploads" )

## where to send error-messages to
server.errorlog            = var.logdir  + "/error.log"

## files to check for if .../ is requested
index-file.names           = ( "index.php", "index.html",
                              "index.htm", "default.htm" )


## Use the "Content-Type" extended attribute to obtain mime type if possible
# mimetype.use-xattr = "enable"

#### accesslog module
accesslog.filename         = var.logdir + "/access.log"

## deny access the file-extensions
#
# ~    is for backupfiles from vi, emacs, joe, ...
# .inc is often used for code includes which should in general not be part
#      of the document-root
url.access-deny            = ( "~", ".inc" )

##
# which extensions should not be handle via static-file transfer
#
# .php, .pl, .fcgi are most often handled by mod_fastcgi or mod_cgi
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi", ".cgi", ".py" )

fastcgi.server = (
".php" => (
	"localhost" => (
		"socket" => "/var/customers/tmp/lighttpd-fcgi-sock-lighttpd",
		"broken-scriptfilename" => "enable",
		"bin-path" => "/usr/bin/php5-cgi",
		"min-procs" => 1,
		"max-procs" => 1,
		"max-load-per-proc" => 4,
		"idle-timeout" => 60,
		"bin-environment" => (
			"UID" => "www-data",
			"GID" => "www-data",
			"PHP_FCGI_CHILDREN" => "0",
			"PHP_FCGI_MAX_REQUESTS" => "10000"
		),
		"bin-copy-environment" => ( "" )
	)
)
)


######### Options that are good to be but not neccesary to be changed #######

## Use ipv6 only if available.
#include_shell "/usr/share/lighttpd/use-ipv6.pl"

## bind to port (default: 80)
#server.port               = 80

## bind to localhost only (default: all interfaces)
server.bind                = "xx.xxx.xx.xx"

## error-handler for status 404
#server.error-handler-404  = "/error-handler.html"
#server.error-handler-404  = "/error-handler.php"

## to help the rc.scripts
server.pid-file            = "/var/run/lighttpd.pid"

##
## Format: <errorfile-prefix><status>.html
## -> ..../status-404.html for 'File not found'
#server.errorfile-prefix    = "/var/www/"

## virtual directory listings
dir-listing.encoding        = "utf-8"
server.dir-listing          = "enable"

## send unhandled HTTP-header headers to error-log
#debug.dump-unknown-headers  = "enable"

### only root can use these options
#
# chroot() to directory (default: no chroot() )
#server.chroot            = "/"

## change uid to <uid> (default: don't care)
server.username            = "www-data"

## change uid to <uid> (default: don't care)
server.groupname           = "www-data"

#### compress module
compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ("text/plain", "text/html", "application/x-javascript", "text/css")


#### url handling modules (rewrite, redirect, access)
# url.rewrite                 = ( "^/$"             => "/server-status" )
# url.redirect                = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )

#
# define a pattern for the host url finding
# %% => % sign
# %0 => domain name + tld
# %1 => tld
# %2 => domain name without tld
# %3 => subdomain 1 name
# %4 => subdomain 2 name
#
# evhost.path-pattern = "/home/storage/dev/www/%3/htdocs/"

#### expire module
# expire.url                  = ( "/buggy/" => "access 2 hours", "/asdhas/" => "access plus 1 seconds 2 minutes")

#### rrdtool
# rrdtool.binary = "/usr/bin/rrdtool"
# rrdtool.db-name = "/var/www/lighttpd.rrd"

#### variable usage:
## variable name without "." is auto prefixed by "var." and becomes "var.bar"
#bar = 1
#var.mystring = "foo"

## integer add
#bar += 1
## string concat, with integer cast as string, result: "www.foo1.com"
server.name = "sXXXXXXXX.onlinehome-server.info"
## array merge
#index-file.names = (foo + ".php") + index-file.names
#index-file.names += (foo + ".php")


#### external configuration files
## mimetype mapping
include_shell "/usr/share/lighttpd/create-mime.assign.pl"

## load enabled configuration files,
## read /etc/lighttpd/conf-available/README first
include_shell "/usr/share/lighttpd/include-conf-enabled.pl"

#### handle Debian Policy Manual, Section 11.5. urls
## by default allow them only from localhost
## (This must come last due to #445459)
## Note: =~ "127.0.0.1" works with ipv6 enabled, whereas == "127.0.0.1" doesn't
$HTTP["remoteip"] =~ "127.0.0.1" {
alias.url += (
	"/doc/" => "/usr/share/doc/",
	"/images/" => "/usr/share/images/"
)
$HTTP["url"] =~ "^/doc/|^/images/" {
	dir-listing.activate = "enable"
}
}


include_shell "cat /etc/lighttpd/conf-enabled/*.conf"

include_shell "cat /etc/lighttpd/froxlor-diroptions/*.conf"

# /etc/lighttpd/conf-enabled/10_froxlor_ipandport_XX.XXX.XX.XX.80.conf
# Created 08.03.2010 23:10
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

$SERVER["socket"] == "XX.XXX.XX.XX:80" {
$HTTP["host"] =~ "^(?:www\.|)mydomain\.de$" {
 server.document-root = "/var/customers/webs/mydomain/"
 auth.backend = "htpasswd"
 auth.backend.htpasswd.userfile = "/etc/lighttpd/froxlor-htpasswd/XXXXXXXXXXXXXXXXX.htpasswd"
 auth.require = ( 
   "/webalizer/" =>
   (
      "method"  => "basic",
      "realm"   => "Restricted Area",
      "require" => "user=mydomain"
   )
 )
 accesslog.filename	= "/var/customers/logs/mydomain-access.log"
}

}

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

you're including conf-enabled/* twice

 

1. include_shell "/usr/share/lighttpd/include-conf-enabled.pl"
2. include_shell "cat /etc/lighttpd/conf-enabled/*.conf"

try removing one of the lines

Share this post


Link to post
Share on other sites





×
×
  • Create New...