Jump to content
Froxlor Forum
  • 0

Fehlermeldung aus froxlor_master_cronjob.php


darthvader

Question

Hallo Gemeinschaft,

 

ich habe seit kurzem folgende Fehlermeldung aus dem Master_Cronjob, mit der ich nicht weiss, was ich anfangen soll.

 

Hat Jemand im Forum Hilfestellung zur L?sung f?r mich?

 

Schon mal vielen Dank im Voraus!

 

 

Hier die Fehlermeldung:

PHP Notice: Undefined index: 3 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

PHP Notice: Undefined index: 10 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

PHP Notice: Undefined index: 12 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

PHP Notice: Undefined index: 13 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

PHP Notice: Undefined index: 16 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

PHP Notice: Undefined index: 24 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

PHP Notice: Undefined index: 27 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

PHP Notice: Undefined index: 48 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

PHP Notice: Undefined index: 59 in /var/www/froxlor/scripts/jobs/cron_traffic.php on line 127

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Warning: Perl versions before 5.6 cannot handle nested includes

Link to post
Share on other sites

14 answers to this question

Recommended Posts

Perl aktualisieren, webalizer oder awstats (welches von beidem weiss ich jetzt nicht, aber wohl das, dass du nutzt) mag wohl keine alten Perl-versionen.

 

arbeite mit awstats auf ubuntu 10.04 , apache 2.2.14, mysql 5.1.47, PHP 5.3.2, Kernel 2.6.32-22

 

lt. apt-get update & apt-get install ist perl die aktuelle Version!

 

Gibt es noch eine Idee, was ich machen k?nnte?

Link to post
Share on other sites

 

Vielen Dank! Ich habe jetzt erstmal den Workaround mit der Versionsnummernabfrage eingearbeitet. Mal sehen, was der n?chste Cron-Lauf mit sich bringt.

Link to post
Share on other sites

Muss das Thema mal aufgreifen:

 

perl -pi -e 's/\Qif (\E\$\Qlevel > 1) {\E/if (( \$] < 5.006
) && (\$level > 1)) {/' /usr/lib/cgi-bin/awstats.pl

 

Habe damit aus dem Link versucht das Problem zu patchen, brachte aber keinen erfolg?

 

Kann ich sinst noch irgendwas tun?

Link to post
Share on other sites

Nein habe mch wohl falsch ausgedr?ckt.

 

Per link bin ich auf den Patch gekommen, diesen:

perl -pi -e 's/\Qif (\E\$\Qlevel > 1) {\E/if (( \$] < 5.006
) && (\$level > 1)) {/' /usr/lib/cgi-bin/awstats.pl

 

Brachte aber keinen erfolg. Ich bekomme immer noch diese Fehlermeldung von /var/www/froxlor/scripts/froxlor_master_cronjob.php

 

Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes
Warning: Perl versions before 5.6 cannot handle nested includes

Link to post
Share on other sites

Moin zusammen!

 

In die diesem Zusammenhang: Mein logfile bekommt bei jedem Aufruf von Froxlor einen solchen "undefined index"-Eintrag:

 

PHP Notice: Undefined index: multiserver in /var/www/froxlor/lib/navigation/30.multiserver.php on line 27, referer: http://server/froxlor/index.php?

 

Das scheint dann ja doch eher was Internes zu sein, oder?! Der referer wechselt dabei, kommt sowohl bei index.php, customer_email.php, admin_customers.php etc.

 

Vielleicht weiss hier ja jemand, wie ich die Eintr?ge rausbekomme.. F?r 'ne Spezi vermutlich 'ne Kleinigkeit?!

 

Danke & Gru?,

 

Mike

Link to post
Share on other sites

In die diesem Zusammenhang: Mein logfile bekommt bei jedem Aufruf von Froxlor einen solchen "undefined index"-Eintrag:

 

PHP Notice: Undefined index: multiserver in /var/www/froxlor/lib/navigation/30.multiserver.php on line 27, referer: http://server/froxlor/index.php?

 

Das scheint dann ja doch eher was Internes zu sein, oder?! Der referer wechselt dabei, kommt sowohl bei index.php, customer_email.php, admin_customers.php etc.

 

1) das hat mit dem Topic hier absolut NULL zu tun...

2) was "interes" ist das nicht, das ist ein neues Feature was in den kommenden Froxlor versionen implementiert wird, mittlerweile aber separat entwickelt wird und wir im letzten release leider noch 2-3 "leichen" haben. L?sch einfach die Datei /var/www/froxlor/lib/navigation/30.multiserver.php und du bist das Notice los

Link to post
Share on other sites

Moin!

 

1) das hat mit dem Topic hier absolut NULL zu tun...

2) was "interes" ist das nicht, das ist ein neues Feature was in den kommenden Froxlor versionen implementiert wird, mittlerweile aber separat entwickelt wird und wir im letzten release leider noch 2-3 "leichen" haben. L?sch einfach die Datei /var/www/froxlor/lib/navigation/30.multiserver.php und du bist das Notice los

 

Danke!

 

Gru?,

 

Mike

Link to post
Share on other sites

Das war und ist immernoch ein awstat/perl bug, bitte verfolge entsprechende Mailing-Listen/Bugtracker, wir wissen auch nicht mehr als das

 

So hat mich ja nicht locker gelassen dieser Fehler. Und genervt wurde ich auch durch die Mails jede Nacht.

 

Hab dann mal nochmal den Patch von oben angesehen und stellte fest das die angeblich gepatchte "if" garnicht in meiner awstats.pl vorhanden ist :-(

 

Auf der suche nach dem ?belt?ter bin ich auf die: /usr/bin/awstats_buildstaticpages.pl gesto?en

 

Hier habe ich dann

 

if ($level > 1) {
warning("Warning: Perl versions before 5.6 cannot handle nested includes!");

gegen

if (( $] < 5.006 ) && ($level > 1)){
warning("Warning: Perl versions before 5.6 cannot handle nested includes!");

 

getauscht.

Wie bei dem Bugfix aus der awstats.pl von: http://sourceforge.net/tracker/index.php?func=detail&aid=1145729&group_id=13764&atid=113764

 

Bisher ist Ruhe und ich bin happy!

 

Gru?

newan

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...