Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
bgworms

fcgid installation

Question

Hallo,

 

ich habe heute Froxlor frisch installiert und alle Konfigurationen ausgef?hrt.

 

Ich habe noch keine User angelegt.

 

Danach wollte ich fcgid nach Anleitung in Wiki installieren. Nachdem ich alles durchgegangen bin konnte ich Froxlor nicht mehr

aufrufen. Er will immer die Datei runterladen, also schein php nicht zu funktionieren.

 

Was muss ich eigentlich bei der Datei /etc/apache2/sites-enabled/000-default eintargen ???

Das was in dem fcgi-Handbuch steht oder muss das was in dem fcgi-Handbuch steht dazugef?gt werden ?

 

Ich habe beides ausprobiert, danach den apache neu gestartet, aber mit dem selben "erfolg".

 

Hier mal die Ausgabe von ps faux:

 

 
server014:/etc/cron.daily# ps faux
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root         1  0.0  0.0   1984   680 ?        Ss   15:19   0:00 init [2]
root       295  0.0  0.0  28016  1252 ?        Sl   15:19   0:00 /usr/sbin/rsyslogd -c3
root       308  0.0  0.0   5276  1000 ?        Ss   15:19   0:00 /usr/sbin/sshd
root      8375  0.0  0.0   8596  2736 ?        Ss   18:32   0:00  \_ sshd: root@pts/1
root      8378  0.0  0.0   6012  1544 pts/1    Ss   18:32   0:00      \_ -bash
root      9565  0.0  0.0   5500   808 pts/1    R+   20:28   0:00          \_ ps faux
root      5569  0.0  0.0   5716  1260 ?        S    17:31   0:00 /bin/sh /usr/bin/mysqld_safe
mysql     5606  0.0  0.3 120044 17696 ?        Sl   17:31   0:01  \_ /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql
root      5607  0.0  0.0   4836   596 ?        S    17:31   0:00  \_ logger -p daemon.err -t mysqld_safe -i -t mysqld
bind      6324  0.0  0.2 104872 14656 ?        Ssl  17:43   0:00 /usr/sbin/named -u bind
root      7173  0.0  0.0   5480  1804 ?        Ss   17:56   0:00 /usr/lib/postfix/master
postfix   7180  0.0  0.0   5536  1892 ?        S    17:56   0:00  \_ qmgr -l -t fifo -u
postfix   9290  0.0  0.0   5796  1628 ?        S    19:35   0:00  \_ pickup -l -t fifo -u -c
root      7768  0.0  0.0   2004   600 ?        Ss   18:03   0:00 /usr/sbin/dovecot
vmail     7770  0.0  0.0   9420  2436 ?        S    18:03   0:00  \_ dovecot-auth
dovecot   7777  0.0  0.0   3504  1584 ?        S    18:03   0:00  \_ pop3-login
dovecot   7778  0.0  0.0   3504  1584 ?        S    18:03   0:00  \_ pop3-login
dovecot   7779  0.0  0.0   3504  1588 ?        S    18:03   0:00  \_ pop3-login
dovecot   7780  0.0  0.0   3508  1592 ?        S    18:03   0:00  \_ imap-login
dovecot   7781  0.0  0.0   3508  1588 ?        S    18:03   0:00  \_ imap-login
dovecot   7782  0.0  0.0   3508  1588 ?        S    18:03   0:00  \_ imap-login
proftpd   8172  0.0  0.0  10872  1552 ?        Ss   18:19   0:00 proftpd: (accepting connections)
root      8667  0.0  0.0 114356  1816 ?        Ssl  19:05   0:00 /usr/sbin/nscd
root      9151  0.0  0.0   5272   800 ?        Ss   19:23   0:00 /usr/sbin/cron
root      9533  0.0  0.0  13812  3000 ?        Ss   20:20   0:00 /usr/sbin/apache2 -k start
www-data  9535  0.0  0.0  13748  1844 ?        S    20:20   0:00  \_ /usr/sbin/apache2 -k start
www-data  9537  0.0  0.0  13812  2004 ?        S    20:20   0:00  \_ /usr/sbin/apache2 -k start
www-data  9538  0.0  0.0  13812  2004 ?        S    20:20   0:00  \_ /usr/sbin/apache2 -k start
www-data  9539  0.0  0.0  13812  2004 ?        S    20:20   0:00  \_ /usr/sbin/apache2 -k start
www-data  9540  0.0  0.0  13812  2004 ?        S    20:20   0:00  \_ /usr/sbin/apache2 -k start
www-data  9541  0.0  0.0  13812  2004 ?        S    20:20   0:00  \_ /usr/sbin/apache2 -k start
server014:/etc/cron.daily#

 

In der Anleitung steht auch unter Punkt 5, dass ich in der Froxlor-Einstellung bei FCGI das mit dem Vhost einschalten soll.

Das habe ich nicht gemacht, sondern nur im Hauptmenue Einstellungen FCGI eingeschaltet. Ich denke, das ist der Fehler, aber ich

kann es jetzt nicht mehr einstellen, da ich ja nicht mehr in Froxlor reinkommen. Wie und wo kann ich das aktivieren ?

 

LG Bodo

Share this post


Link to post
Share on other sites

Recommended Posts

Hallo,

 

was steht in den logs? (suexec.log / error.log)

 

Hier mal ein Beispiel vHost:

 

<VirtualHost IP:80>

ServerName kundencenter.domain.tld

DocumentRoot /var/www/froxlor/

SuexecUserGroup "froxlor" "froxlor"

<Directory /var/www/froxlor/>

AddHandler fcgid-script .php

FCGIWrapper /var/www/php-fcgi-scripts/system/froxlor/php-fcgi-starter .php

Options +ExecCGI

Order allow,deny

allow from all

</Directory>

 

ErrorLog /var/log/apache2/froxlor-error.log

CustomLog /var/log/apache2/froxlor-access.log combined

</VirtualHost>

 

 

Wichtig ist, das die Rechte des php-fcgi-starter richtig gesetzt sind. In der /var/log/apache2/suexec.log sollten n?here Infos zu deinem Problem stehen.

Share this post


Link to post
Share on other sites

In der error.log steht:

 

[sat Sep 25 20:20:38 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)

 

Die Datei /var/log/apache2/suexec.log gibt es nicht

Share this post


Link to post
Share on other sites

K?nntest du bitte deine vHost + php-fcgi-starter posten?

 

000-default:

 

<VirtualHost 127.0.0.1:80>

   ServerName server014.cdg-web.de
   ServerAdmin xxxx@xxxxxx.de

   DocumentRoot /var/www/froxlor

   <Directory "/var/www/froxlor">
       FCGIWrapper     /var/www/php-fcgi-scripts/froxlorlocal/php-fcgi-starter .php
       AddHandler      fcgid-script    .php
       Options         +FollowSymLinks -MultiViews +ExecCGI
       AllowOverride   AuthConfig FileInfo
   </Directory>

   SuexecUserGroup froxlorlocal froxlorlocal

</VirtualHost>

 

 

php-fcgi-starter:

 

#!/bin/sh

PHPRC='/var/www/php-fcgi-scripts/froxlorlocal/'
export PHPRC
PHP_FCGI_CHILDREN=0
export PHP_FCGI_CHILDREN
PHP_FCGI_MAX_REQUESTS=0
export PHP_FCGI_MAX_REQUESTS
exec /usr/bin/php5-cgi -c '/var/www/php-fcgi-scripts/froxlorlocal/'


Share this post


Link to post
Share on other sites

<VirtualHost 127.0.0.1:80>

 

Da muss schon die externe IP des Servers stehen, au?erdem kann Froxlor mittlerweile automatisch einen FCGID vhost f?r das Panels selbst erstellen, du musst das also nicht mehr so umst?ndlich machen wie in dem Handbuch beschrieben

Share this post


Link to post
Share on other sites

Da muss schon die externe IP des Servers stehen, au?erdem kann Froxlor mittlerweile automatisch einen FCGID vhost f?r das Panels selbst erstellen, du musst das also nicht mehr so umst?ndlich machen wie in dem Handbuch beschrieben

 

 

Irgendwie blicke ich es nicht so ganz. Was muss ich nicht machen wie in der Anleitung ?

Ich habe ja schon eine 000-default Datei. Muss ich die umbenennen und die in derAnleitung zus?tzlich dazuf?gen oder muss ich die vorhandene ersetzen ??

 

Wenn ich die IP in die 000-default eintrage und nur diese Datei in dem Verzeichniss habe kommt beim Restrart vom apache eine Fehlermeldung.

Share this post


Link to post
Share on other sites
.... kommt beim Restrart vom apache eine Fehlermeldung.

 

Und genau diese Fehlermeldung w?re mal interessant. Du musst statt der loopback Adresse 127.0.0.1 schon deine richtige server ip eintragen.

Share this post


Link to post
Share on other sites

Ich habe jetzt im Verzeichniss nur die Datei 000-default mit so wie in der Anleitung, nur das ich die IP des Vservers eingetragen habe. Jetzt bekomme ich folgende Warnung:

 


server014:~# /etc/init.d/apache2 restart
Restarting web server: apache2[sun Sep 26 22:37:24 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting [sun Sep 26 22:37:25 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
.
server014:~#

Share this post


Link to post
Share on other sites

Da auf dem System noch keine Seiten drauf sind installiere ich es wohl nochmal komplett von vorne.

Daher w?rde mich immer noch die Frage von vorhin interessieren:

 

 

Irgendwie blicke ich es nicht so ganz. Was muss ich nicht machen wie in der Anleitung ?

Ich habe ja schon eine 000-default Datei. Muss ich die umbenennen und die in derAnleitung zus?tzlich dazuf?gen oder muss ich die vorhandene ersetzen ??

 

 

Share this post


Link to post
Share on other sites

Welche Anleitung verwendest du eigentlich?

 

Die Anleitung auf der wiki-seite von Froxlor. http://wiki.froxlor.org/contrib/fcgid-handbook

 

In dem Beitrag #6 oben hat der User d00p geschrieben, dass man das aber nicht mehr so kompliziert machen muss, wie es in der Anleitung steht. Jetzt interessiert mich nat?rlich, was ich anders machen muss.

Share this post


Link to post
Share on other sites

lass man den ganzen unsinn mit der 000-default weg und dem anlegen der php-starter-script-Datei. Geh im panel als admin in die Einstellungen und unter FCGID checkst du das K?stchen "Enable FCGID for the Froxlor vhost" an :) Dann werden dir die Starter-Scripts und Vhosts automatisch erstellt

Share this post


Link to post
Share on other sites

lass man den ganzen unsinn mit der 000-default weg und dem anlegen der php-starter-script-Datei. Geh im panel als admin in die Einstellungen und unter FCGID checkst du das K?stchen "Enable FCGID for the Froxlor vhost" an :) Dann werden dir die Starter-Scripts und Vhosts automatisch erstellt

 

In der Einstellung im panel steht folgendes:

 

Verwende FCGID im Froxlor Vhost
Wenn verwendet, wird Froxlor selbst unter einem lokalem Benutzer ausgef?hrt
ACHTUNG:Hierzu m?ssen noch zus?tzliche Konfigurationen vorgenommen werden, siehe http://wiki.froxlor.org/contrib/fcgid-handbook

 

Welche zus?tzlichen Konfigurationen muss man vornehmen ?? Reicht Schritt 3-7 oder muss ich auch irgendwas anderes machen ? Oder ist das schon zuviel.

 

Soll ich die Einstellung im Panel vorher ?ndern und dann mit den Schritten im Handbuch beginnen ?

Share this post


Link to post
Share on other sites

Du musst lediglich den lokalen Benutzer anlegen und in den Einstellungen im Panel hinterlegen [Local user to use for FCGID (Froxlor vhost)].

 

Den Rest macht der Cronjob, wenn du die Einstellung aktiviert hast

Share this post


Link to post
Share on other sites

Du musst lediglich den lokalen Benutzer anlegen und in den Einstellungen im Panel hinterlegen [Local user to use for FCGID (Froxlor vhost)].

 

Den Rest macht der Cronjob, wenn du die Einstellung aktiviert hast

 

Also wenn ich das jetzt richtig verstanden habe muss ich nur im Panel alles aktiviren und den User so anlegen:

 

addgroup --gid 9999 froxlorlocal
adduser --no-create-home --uid 9999 --ingroup froxlorlocal --shell /bin/false froxlorlocal

 

Den Rest des Handbuches kann ich vergessen, da das alles Froxlor macht.

Share this post


Link to post
Share on other sites

Hallo,

 

ich habe jetzt alles nochmal neu installiert:

 

Debian 5.05 Froxlor mit aktuellen Debian-Paket. Alle Konfigurationsdateien (Apache, Postfix, Courier,...)

 

Dann nach neuem Handbuch im Wiki alle Schritte durchgegangen. Im Schritt 8 kam ich noch auf die Oberfl?che um die Einstallung mit dem vhost zu machen. Als ich dann mit Schritt 9 fertig war kam ich nicht mehr auf die Oberfl?che. er will immer die php-Datei runterladen.

 

Wenn ich den Servernamen aufrufe kommt it works vom apache, wenn ich IP/froxlor aufrufe will er immer die php-Datei runterladen. er findet also die Datei kann aber keine php.

 

Eine Error.log beim apache gibt es nicht. Beim restart vom apache kommt keine fehlermeldung. Was kann ich noch machen ?

Share this post


Link to post
Share on other sites
Eine Error.log beim apache gibt es nicht

 

Das ist sehr, sehr komisch.

 

 

will er immer die php-Datei runterladen

 

Apache kann wei? nicht was mit *.php anzufangen/ interpretieren soll, daher bietet er dir diese zum download an. Bitte poste uns mal die betroffenen vHosts.

Share this post


Link to post
Share on other sites

000-default:

 


<VirtualHost *:80>
       ServerAdmin webmaster@localhost

       DocumentRoot /var/www/
       <Directory />
               Options FollowSymLinks
               AllowOverride None
       </Directory>
       <Directory /var/www/>
               Options Indexes FollowSymLinks MultiViews
               AllowOverride None
               Order allow,deny
               allow from all
       </Directory>

       ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
       <Directory "/usr/lib/cgi-bin">
               AllowOverride None
               Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
               Order allow,deny
               Allow from all
       </Directory>

       ErrorLog /var/log/apache2/error.log

       # Possible values include: debug, info, notice, warn, error, crit,
       # alert, emerg.
       LogLevel warn

       CustomLog /var/log/apache2/access.log combined

   Alias /doc/ "/usr/share/doc/"
   <Directory "/usr/share/doc/">
       Options Indexes MultiViews FollowSymLinks
       AllowOverride None
       Order deny,allow
       Deny from all
       Allow from 127.0.0.0/255.0.0.0 ::1/128
   </Directory>

</VirtualHost>

 

Das diese Datei falsch ist denke ich auch, aber normalerweise sollte doch froxlor die Datei automatisch erstellen, oder ?

Share this post


Link to post
Share on other sites

Froxlor hat mit der 000-default nix zu tun. Nopaste doch mal bitte die vhosts-config die von Froxlor erstellt wurde (froxlor-vhosts.conf oder 10_* im vhosts-ordner, z.B. /etc/apache2/sites-enabled/)

 

Wenn er die PHP-Datei herunterladen will, ?berpr?fe doch mal, ob du mod_fcgid korrekt installiert hast.

 

Bei Debian auch immer gern ein "Bug": versuche mal ein /etc/init.d/apache stop und danach ein /etc/init.d/apache start (explizit so, kein reload oder restart!!!) - das hat schon manchen geholfen

Share this post


Link to post
Share on other sites

1. Froxlor hat mit der 000-default nix zu tun. Nopaste doch mal bitte die vhosts-config die von Froxlor erstellt wurde (froxlor-vhosts.conf oder 10_* im vhosts-ordner, z.B. /etc/apache2/sites-enabled/)

 

2. Wenn er die PHP-Datei herunterladen will, ?berpr?fe doch mal, ob du mod_fcgid korrekt installiert hast.

 

3. Bei Debian auch immer gern ein "Bug": versuche mal ein /etc/init.d/apache stop und danach ein /etc/init.d/apache start (explizit so, kein reload oder restart!!!) - das hat schon manchen geholfen

 

 

zu 1. Es gibt im Verzeichniss /etc/apache2/sites-enabled/ nur die Datei 000-default und es gibt auch keine froxlor-vhosts.conf auch dem Server

 

zu 2. mod_fcgid ist enabled

 

zu 3. habe ich gemacht, bringt leider nichts.

Share this post


Link to post
Share on other sites

zu 1. Es gibt im Verzeichniss /etc/apache2/sites-enabled/ nur die Datei 000-default und es gibt auch keine froxlor-vhosts.conf auch dem Server

 

Dann hast du das FCGID-Handbook nicht vollst?ndig befolgt oder Froxlor nicht korrekt konfiguriert (Cronjob?)

 

?berpr?fe bitte ob der Cronjob korrekt konfiguriert ist und ob dieser gelaufen ist.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...