Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
campari

ssl einbinden

Question

Hallo zusammen,

 

ich habe gerade ?ber das Froxlor-Panel einen neuen Port f?r SSL (443) angelegt. Doch sobald das update-script durchgelaufen ist, bekomme ich dieser Fehlermeldung:

 

Restarting web server: apache2(98)Address already in use: make_sock: could not bind to address [::]:80

(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80

 

Der Apache startet nicht mehr. Hat jemand eine Idee, wie ich das Problem l?sen kann?

Im Anhang habe ich einen Screenshot geh?ngt der die Ports-Konfiguration in Froxlor zeigt.

 

Im Einsatz ist Debian lenny, die neuste Froxlor Version mit Fcgi und Suhosinpatch.

 

Danke,

Campari

post-58-090867900 1282654722_thumb.jpg

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

Es liefen keine Prozesse mehr, es war eine falsche Einstellung in meinen Settings - Zuordnung der Zertifikate. Das Problem ist gel?st.

Nun habe ich aber ein anderes und vielleicht kannst du mir hier einen Tipp geben.

Ich bekomme einen Internen Server Error 500 wenn ich via SSL meine subdomain f?r phpmyadmin.xxxx.de aufrufen m?chte.

 

Folgende Settings habe ich vorgenommen:

 

User + Gruppe angelegt

--------------

addgroup --gid 9998 phpmyadmin

adduser --no-create-home --uid 9998 --ingroup phpmyadmin --shell /bin/false phpmyadmin

 

Dann nat?rlich die FCGI-Eintr?ge:

---------------------------------

PHPRC='/var/www/php-fcgi-scripts/system/phpmyadmin/'

export PHPRC

PHP_FCGI_CHILDREN=0

export PHP_FCGI_CHILDREN

PHP_FCGI_MAX_REQUESTS=250

export PHP_FCGI_MAX_REQUESTS

exec /usr/bin/php-cgi -c '/var/www/php-fcgi-scripts/system/phpmyadmin/'

 

Vhost Settings:

--------------

<VirtualHost xx.xxx.xxx.xx:443>

ServerAdmin webmaster@xxx.de

ServerName phpmyadmin.xxxx.com

DocumentRoot "/var/www/phpmyadmin/"

SuexecUserGroup "phpmyadmin" "phpmyadmin"

SSLEngine on

SSLCertificateKeyFile /etc/apache2/ssl/global.cert.key

SSLCertificateFile /etc/apache2/ssl/global.cert.crt

 

<Directory "/var/www/phpmyadmin/">

AddHandler fcgid-script .php

FCGIWrapper /var/www/php-fcgi-scripts/system/phpmyadmin/php-fcgi-starter .php

Options +ExecCGI

Order allow,deny

allow from all

</Directory>

 

ErrorLog "/var/log/apache2/phpmyadmin-error.log"

CustomLog "/var/log/apache2/phpmyadmin-access.log" combined

</VirtualHost>

 

 

Sobald ich die Seite aufrufe bekomme ich eine 500 Error.

 

In den logs steht:

---------------------

apache error.log:

 

mod_fcgid: process /var/www/phpmyadmin/index.php(17853) exit(communication error), terminated by calling exit(), return code: 120

[Wed Aug 25 09:37:35 2010] [notice] mod_fcgid: call /var/www/froxlor_fcgid/index.php with wrapper /var/www/php-fcgi-scripts/froxlor.panel/php-fcgi-starter

 

Aus mir noch unerkl?rlichen Gr?nden, wird hier auff das "froxlor.panel" verwiesen und nicht auf: /var/www/php-fcgi-scripts/system/phpmyadmin/php-fcgi-starter

 

Woran k?nnte das liegen?

Share this post


Link to post
Share on other sites

mod_fcgid: process /var/www/phpmyadmin/index.php(17853) exit(communication error), terminated by calling exit(), return code: 120

[Wed Aug 25 09:37:35 2010] [notice] mod_fcgid: call /var/www/froxlor_fcgid/index.php with wrapper /var/www/php-fcgi-scripts/froxlor.panel/php-fcgi-starter

 

Die zweite Zeile hat mit der ersten schon nichts mehr zu tun, wie sind denn die Rechte von /var/www/php-fcgi-scripts/system/phpmyadmin/

Share this post


Link to post
Share on other sites

×
×
  • Create New...