Jump to content
Froxlor Forum
  • 0
LiaraAlis

[gel?st] Einrichtung von awstats

Question

Hi zusammen,

 

ich w?rde gerne von Webalizer zu awstats wechseln (aus irgend einem Grund hatten die webalizer Verzeichnisse keinen .htaccess Schutz mehr). Deswegen habe ich awstats installiert und wie in Froxlor angegeben konfiguriert.

Nun wurden die awstats-Ordner angelegt inkl. der Ordner f?r die Domains. Auch die Konfigurationsdateien f?r die Domains liegen in /etc/awstats.

Allerdings ist der Inhalt dieser Ordner leer und somit kein Aufruf m?glich. Ich w?rde gerne eine dynamische Ausgabe von awstats realisieren.

Da ich mit awstats noch nie gearbeitet und somit keine Erfahrung habe, wei? ich leider auch noch nicht ganz, wie ich awstats richtig konfigurieren m?sste und konnte leider auch nichts hilfreiches finden.

 

W?re echt super, wenn mir jemand mal genau erkl?ren k?nnte, wie ich awstats f?r Froxlor richtig einrichte und konfiguriere.

 

Ich bedanke mich schon einmal im Voraus!

 

Gr??e,

Alex

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

die awstats-statistiken werden nur 1x pro tag generiert (nachts) und sind statisch (eine dynamische l?sung hatten wir auch mal, frisst aber performance und lohnt nicht)

Share this post


Link to post
Share on other sites
  • 0

Achso, okay. In welchem Zeitraum ist damit ungef?hr zu rechnen?

W?re ja sch?n, wenn wenigstens die statische Methode funktioniert, die ist m.E. nach immer noch besser als webalizer. :)

 

Danke f?r deine Antwort!

 

Gr??e,

Alex

Share this post


Link to post
Share on other sites
  • 0

Wie bereits gesagt, nachts (der timestamp ist so gesetzt, f?r Testzwecke kannst du allerdings den Intervall des Traffic-Cronjobs auf 5 Min heruntersetzen, dann macht er es alle 5 min! ACHTUNG: Das ist wirklich nur f?r testzwecke!)

Share this post


Link to post
Share on other sites
  • 0

Also ich habe das ganze mal ausprobiert.

Die index.html wird nun erstellt - allerdings scheint das ganze ein Symlink zu sein.

Abgesehen davon bekomme ich beim Aufruf weiterhin einen HTTP 403. Woran mag das liegen? Wie muss der Besitzer / Gruppe der Verzeichnisse / Dateien sein?

 

Danke euch!

 

Gr??e,

Alex

Share this post


Link to post
Share on other sites
  • 0

Also nach langer Zeit hat sich immer noch nichts getan. Die Dateien scheinen zwar alle erstellt zu werden, aber ich bekomme immer einen HTTP 403, wenn ich versuche, den ganzen Spa? aufzurufen? Woran mag das liegen? :(

Share this post


Link to post
Share on other sites
  • 0

403 = forbidden, so wie es auch sein soll, denn die ordner sollten htpasswd-gesch?tzt sein, bekommst du keine user/pwd-prompt beim aufruf der seite?

Share this post


Link to post
Share on other sites
  • 0

403 = forbidden, so wie es auch sein soll, denn die ordner sollten htpasswd-gesch?tzt sein, bekommst du keine user/pwd-prompt beim aufruf der seite?

Nein, sonst w?sste ich ja bescheid. Aber es kommt einfach 403, ohne Abfrage.

Share this post


Link to post
Share on other sites
  • 0

gibt es f?r den awstats ordner einen htpasswd schutz? wenn ja, bitte versuchen zu entfernen und dann nochmal versuchen

Share this post


Link to post
Share on other sites
  • 0

schau mal direkt in den kunden-ordner ob html dateien darin liegen und versuche diese mal direkt aufzurufen im Browser

Share this post


Link to post
Share on other sites
  • 0

In Froxlor > Einstellungen > Statistik Einstellungen

 

Die Dateien und Pfade stimmen.

 

Pfad zu AWStats 'awstats_buildstaticpages.pl' = /usr/bin/

 

AWStats Konfigurations-Pfad = /etc/awstats/

 

----------------------------------------------------

 

Der Pfad hat die Datei gar nicht gefunden.

Pfad zu AWStats 'awstats.pl' = /usr/bin/

 

 

Ich kenne mich mit AWStats auch nicht so aus.

 

Aber ich denk mal das die Datei wichtig ist.

 

Also die Datei liegt bei mir in /usr/lib/cgi-bin/

 

OS: Debian Lenny 64Bit

 

 

EDIT:

 

Bei mir l?uft es jetzt. :D

 

Unter Debian Lenny 64 Bit

 

In Froxlor > Einstellungen > Statistik Einstellungen

 

Pfad zu AWStats 'awstats.pl' = /usr/bin/

 

IN

 

Pfad zu AWStats 'awstats.pl' = /usr/lib/cgi-bin/

 

 

Und nur zur Testzwecken:

 

Cronjob Einstellungen Traffic-Berechnung auf 5 Minuten stellen und dann ?berpr?fen !

 

http://www.domainname.de/awstats/domainname.de/

 

Es sollte nun awstats anzeigen.

 

Nicht vergessen wieder auf 1 Tag umzustellen.

 

B)

Share this post


Link to post
Share on other sites
  • 0

Setting Lockfile to /var/run/froxlor_froxlor_master_cronjob.lock-4929
Setting Froxlor installation path to /var/www/froxlor
Userdatas included
Table definitions included
Database Class has been loaded
Database-connection established
Froxlor settings have been loaded from the database
Froxlor version and database version are correct
Logger has been included
Database-rootconnection established
Traffic run started...
http traffic for pokeforum started...

 

Das steht derzeit in der Cronjob-Logfile.

Ich lass das mal laufen, mal gucken, was passiert ?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×