Jump to content
Froxlor Forum
  • 0

API Access: Unauthenticated. Please provide api user credentials.




I'm trying to connect to the froxlor API using python (my script worked half a year ago with another instance of froxlor). I'm using Froxlor 2.1.9 on Debian 11

I enabled the API interface in the system settings, and I generated an API key (as the admin user).

I am using PHP-FPM for the froxlor instance, and I read the note about this:


If you are using php-fpm with apache2, in order for the API authentication to work properly, you need to enable Add "-pass-header Authorization" / "CGIPassAuth On" to vhosts in the PHP-configuration assigned to froxlor.

However, there is no such setting in the PHP-FPM configuration (even though I do not hide incompatible options).

Any hints what's wrong here?


Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

There IS a setting for it:

Login as admin -> PHP -> PHP Configurations -> Edit the config that is used by froxlor itself -> check "Passing HTTP AUTH BASIC/DIGEST headers from Apache to PHP"

Link to comment
Share on other sites

  • 0

Thank you for your extremely fast reply :)

Right, that setting is there, and is already activated. It sounded like what I was looking for, but not exactly what is written in the docs, that's why I'm asking :)

I'll have to look further into it. Might be a mistake on the python side ...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...