Jump to content
Froxlor Forum
  • 0

Urgent help ! Issue with PHP

Adam Fyfe



I tried to upgrade the froxlor panel using the web update feature... i am now stuck with this:


It seems you are using an older version of PHP

Froxlor requires at least PHP version 7.4.0

The installed version is: 7.3.33-14+ubuntu20.04.1+deb.sury.org+1


php -v

PHP 7.4.33 (cli) (built: Sep  2 2023 08:03:15) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.33, Copyright (c), by Zend Technologies

I have installed a later version of PHP and made sure it is system default, but Froxlor doesnt seem to recognise that - what am i doing wrong ?

How do i tell Froxlor to use the updated version of PHP ?


Thanks in advance



Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

and i guess you did not add newer php versions to the available fpm-daemons in froxlor prior to the update and now can't access froxlor to do so.

Try to adjust the values accordingly directly in mysql. The current values are shown by running:

SELECT * FROM `panel_fpmdaemons`;

The important fields to adjust are reload_cmd and config_dir

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...