Jump to content
Froxlor Forum
  • 0

White Blank page after installation process


joonn

Question

I tried to install Froxler on to a fresh stock Ubunu 22.04

After i got to step 3, which is finishig the installation, i got forwarded to xxx.serverip.xxx.xxx/froxler where i get just a white blank page.

I have nothing changed on the ubnutu installation the first thing what i did was installing froxler.

It was just the gd liabary missing for php, that was the only thing which i had to install before.

The thing is forgot to copying it but, when installing froxler trough SSH/Terminal i got a similar looking error like in the php error logs.
Something like: unexpected identifier "wRGv", expecting "]"

Here are some the error logs from php:

[Fri Apr 21 07:56:18.382286 2023] [mpm_prefork:notice] [pid 18777] AH00170: caught SIGWINCH, shutting down gracefully
[Fri Apr 21 07:56:42.501669 2023] [mpm_prefork:notice] [pid 742] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Fri Apr 21 07:56:42.505523 2023] [core:notice] [pid 742] AH00094: Command line: '/usr/sbin/apache2'
[Fri Apr 21 07:56:45.357808 2023] [php:error] [pid 799] [client 192.42.116.208:19258] PHP Parse error:  syntax error, unexpected identifier "wRGv", expecting "]" in /var/www/html/froxlor/lib/userdata.inc.php on line 8, referer: http://45.150.64.175/froxlor/install/install.php?step=3
[Fri Apr 21 07:57:11.069934 2023] [php:error] [pid 798] [client 192.42.116.208:17732] PHP Parse error:  syntax error, unexpected identifier "wRGv", expecting "]" in /var/www/html/froxlor/lib/userdata.inc.php on line 8, referer: http://45.150.64.175/froxlor/install/install.php?step=1
[Fri Apr 21 07:57:25.857746 2023] [php:error] [pid 801] [client 185.220.103.117:39305] PHP Parse error:  syntax error, unexpected identifier "wRGv", expecting "]" in /var/www/html/froxlor/lib/userdata.inc.php on line 8
[Fri Apr 21 07:59:58.838915 2023] [php:error] [pid 797] [client 185.220.103.117:31139] PHP Parse error:  syntax error, unexpected identifier "wRGv", expecting "]" in /var/www/html/froxlor/lib/userdata.inc.php on line 8
[Fri Apr 21 09:41:45.511320 2023] [php:error] [pid 799] [client 165.232.177.76:46392] script '/var/www/html/upl.php' not found or unable to stat
[Fri Apr 21 13:37:39.426743 2023] [php:error] [pid 799] [client 5.188.210.227:43699] script '/var/www/html/echo.php' not found or unable to stat, referer: https://www.google.com/
[Fri Apr 21 21:19:00.071904 2023] [php:error] [pid 800] [client 152.89.196.211:55398] script '/var/www/html/index.php' not found or unable to stat
[Fri Apr 21 22:31:09.674487 2023] [core:error] [pid 1336] [client 152.89.196.211:43480] AH10244: invalid URI path (/cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh)
[Fri Apr 21 22:44:10.434899 2023] [php:error] [pid 800] [client 192.42.116.196:28112] PHP Parse error:  syntax error, unexpected identifier "wRGv", expecting "]" in /var/www/html/froxlor/lib/userdata.inc.php on line 8
[Sat Apr 22 23:10:20.959967 2023] [php:error] [pid 798] [client 94.198.41.14:57987] script '/var/www/html/archivarix.cms.php' not found or unable to stat
[Sun Apr 23 07:43:05.388152 2023] [php:error] [pid 4309] [client 212.38.40.215:49570] script '/var/www/html/wp-login.php' not found or unable to stat
[Sun Apr 23 22:09:21.634024 2023] [php:error] [pid 799] [client 84.243.196.168:44544] script '/var/www/html/wp-login.php' not found or unable to stat, referer: http://tiiwtiiw.store
[Sun Apr 23 22:09:21.736630 2023] [php:error] [pid 801] [client 84.243.196.168:44550] script '/var/www/html/wp-login.php' not found or unable to stat, referer: http://blog.tiiwtiiw.store

Man kann auch ruhig auf Deutsch antworten, ist nur EN für SEO falls mal jemand über das selbe Problem stolpert.

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 1

yes, that's it. And escaping wont help as it alters the password. Try the following syntax (which we will ship with the next version):

[...]
$sql['password']=<<<EOT
dein'password'mit-einfachen-anführungsstrichen
EOT;
[...]

 

Link to comment
Share on other sites

  • 1

no, thats not valid nor correct.

<?php
// autogenerated froxlor file

$sql = [
        'debug' => false,
        'host' => 'localhost',
        'user' => 'unrprivileged_xxx',
        'password' => <<<'EOT'
lorempasswordlorem
EOT,
        'db' => 'dbnamelorem',
];
$sql_root = [
        '0' => [
                'caption' => 'Default',
                'host' => 'localhost',
                'user' => 'froxlerfullprivuserlorem',
                'password' => <<<'EOT'
lorempasswordlorem
EOT,
        ],
];

for syntax, see here: https://www.php.net/manual/en/language.types.string.php#language.types.string.syntax.nowdoc

Link to comment
Share on other sites

  • 0

That seems like the place where the SQL user, password etc. is safed.

I used a ' sign on the beginning of my password but the string is enclosed in two ' ' like 'password' but in my case ''password' that seems to brake the code.

Maybe there should be a check for that occasion?

Link to comment
Share on other sites

  • 0

I don't fully get it how to write it :P , but that seems like a perfect fix.

Is that right?

<?php
// autogenerated froxlor file

$sql = [
        'debug' => false,
        'host' => 'localhost',
        'user' => 'unrprivileged_xxx',
        'password' => [''lorempasswordlorem']=<<<EOT,
        'db' => 'dbnamelorem',
        EOT;
];
$sql_root = [
        '0' => [
                'caption' => 'Default',
                'host' => 'localhost',
                'user' => 'froxlerfullprivuserlorem',
                'password' => 'lorempasswordlorem',
        ],
];

Untoched code for you to alter comfortable.

Spoiler
<?php
// autogenerated froxlor file

$sql = [
        'debug' => false,
        'host' => 'localhost',
        'user' => 'unrprivileged_xxx',
        'password' => ''lorempasswordlorem',
        'db' => 'dbnamelorem',
];
$sql_root = [
        '0' => [
                'caption' => 'Default',
                'host' => 'localhost',
                'user' => 'froxlerfullprivuserlorem',
                'password' => 'lorempasswordlorem',
        ],
];

 

 

Link to comment
Share on other sites

  • 0

Hmm seems to we getting further :P

Now i get instead of a blank white page this error:

Not Found

The requested URL was not found on this server.


Apache/2.4.52 (Ubuntu) Server at 123.xxx.xxx.xxx Port 80
 

I looked also up the useres in my MariaDB and I have the unprivileged user created by Froxler 3 times in it.

Is that normal? It didn't even know that it is possible to have the exact same username 3 times oO

 

EDIT: Error Logs

[Mon Apr 24 16:56:55.624083 2023] [mpm_prefork:notice] [pid 742] AH00170: caught SIGWINCH, shutting down gracefully
[Mon Apr 24 16:56:55.746953 2023] [mpm_prefork:notice] [pid 48135] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal >
[Mon Apr 24 16:56:55.747058 2023] [core:notice] [pid 48135] AH00094: Command line: '/usr/sbin/apache2'
[Mon Apr 24 17:03:23.805228 2023] [mpm_prefork:notice] [pid 48135] AH00170: caught SIGWINCH, shutting down gracefully
[Mon Apr 24 17:03:49.341578 2023] [mpm_prefork:notice] [pid 736] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal op>
[Mon Apr 24 17:03:49.345452 2023] [core:notice] [pid 736] AH00094: Command line: '/usr/sbin/apache2'

 

Link to comment
Share on other sites

  • 0

a 404 not found is another error. Be sure the DocumentRoot in the virtual host config points to the correct location.

I doubt you have the same database user 3 times, most likely the "Hostname" value differs (e,.g. one user for 'localhost', one for '127.0.0.1' and maybe one for your ip address)

Link to comment
Share on other sites

  • 0

Hmm I have looked it up, and never touched anything about virutal hosts it is just by default DocumentRoot /var/www/html

Maybe something went wrong while installation since, the password was not "readable" at that point?

 

Link to comment
Share on other sites

  • 0

Well if the lib/userdata.inc.php file has been created (and you most likely ran the finalizing command from the installation) froxlor is installed. Just check your webserver config folder for possible generated virtual host configs. Or alternatively nopaste contents of the folders - I can only guess at what stage you are right now and what works and what not. Important to first adjust your lib/userdata.inc.php so the database connection is correct

Link to comment
Share on other sites

  • 0

Yeah userdata.inc.php is fixed already, like told it made also an effect.

But now i am stuck a the next step.. here the configs.

/etc/apache2/sites-enabled/000-default.conf

  GNU nano 6.2                    000-default.conf                              
<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port t>
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

 

/etc/apache2/ports.conf

  GNU nano 6.2                    000-default.conf                              
<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port t>
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...