Jump to content
Froxlor Forum
  • 0

Strange issue with SSL on PHP calls


Max Amigo
 Share

Question

Hi guys!

I have Froxlor server with Apache, Let's Encrypt and  PHP-FPM. I have a single WordPress site installed. My website is behind cloudflare.  I have a problem with WP-Cron service on Wordpress.

In the error log I see:

There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was:

stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages: error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert
handshake failure stream_socket_client(): Failed to enable crypto stream_socket_client(): unable to connect to 
ssl://your-silly-somain-123.com:443 (Unknown error)

 I could not find easily anything related to this issue in the google, so I am searching... I only saw something about Apache misconfiguration.

 

Any ideas are welcome!

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

depends, are you using the cloudflare proxy or just DNS? cloudflare can also provide ssl certificates which can be very irritating (issued by sni.cloudflaressl.com).

So, does you domain in froxlor have SSL enabled and a valid certificate assigned? Can you open your-silly-somain-123.com:443 from the error message in your browser without errors?

Link to comment
Share on other sites

  • 0
1 minute ago, d00p said:

Can you open your-silly-somain-123.com:443 from the error message in your browser without errors?

I don't know much about SSL stuff but everything was working perfectly. At first I had DNS set to my server, and I used Let's Encrypt on my domain - everything was fine.

Then I switched to cloudflare for security issues, so nobody cad DDOS me. Again - everything seemed to be cool until I realised that after switching to cloudflare WP-Cron stoped to work.

I believe it is because it is kind of WEB Cron?

Here is more about it: https://www.journeybytes.com/wordpress-cron-error-503-by-cloudflare/

---

Another option it manually call cron.php script from system cron.

Trying to understand what is better for me.

 

Link to comment
Share on other sites

  • 0

The best way to integrate the wp-cron is locally on the server

1) disable cron to be executed when visiting the site in wp-config.php, just add:

define('DISABLE_WP_CRON', 'true');

2) call wp-cron e.g. every 5 minutes via cronjob

*/5 * * * * root	wget -q -O - https://domain.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...