Jump to content
Froxlor Forum
  • 0

Post Bullseye update (Bind9 installed and running but not in /etc/init.d/bind9)


llucps
 Share

Question

Hi @d00p,

I just updated my server to Bullseye and although I had to reinstall mariadb, and also froxlor and some php7.4 packages it seems all is ok except with one thing bind9.

After the upgrade the /etc/init.d/bind9 was missing.. the bind9 service is running fine because I can use service bind9 status and I see it running

The problem is in DNS server reload command settings in Froxlor I had /etc/init.d/bind9 reload and obviously since it's not there it fails to reload the service.

What I did was change the command to service bind9 reload and it seems to be working fine.

My question is whether there should be really a bind9 in /etc/init.d

When I installed bind9 again I get this message:


Setting up bind9 (1:9.16.15-1) ...
named-resolvconf.service is a disabled or a static unit not running, not starting it.
Processing triggers for man-db (2.9.4-2) ...

/etc/init.d/resolvconf status is working fine

● resolvconf.service - Nameserver information manager
     Loaded: loaded (/lib/systemd/system/resolvconf.service; enabled; vendor preset: enabled)
     Active: active (exited) since Sun 2021-08-22 08:03:27 CEST; 27min ago
       Docs: man:resolvconf(8)
   Main PID: 1774 (code=exited, status=0/SUCCESS)
      Tasks: 0 (limit: 4559)
     Memory: 0B
        CPU: 0
     CGroup: /system.slice/resolvconf.service

 

Do you have any idea whether there should be bind9 in /etc/init.d/? or just using service bind9 reload/restart/start is fine?

 

Thanks!

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...