Jump to content
Froxlor Forum
  • 0

Rechteprobleme... Kundenverzeichniss


Akecheta
 Share

Question

Hallo. Ich habe vlt nur eine Blöde frage, aber wurde an den Ordnerrechten etwas verändert?

Ich habe auf 2 Server jeweils Froxlor am laufen. (Mein Server und Kumpel seiner) beide Systeme sind Debian buster mit aktuellen Packeten installiert.

nun haben die Kundenordner die Rechte 0755 anfangs bekommen. Aber nun haben wir laufend Probleme wenn wir neue kunden anlegen welche die Kundenordner nur noch mit den rechten 0750 bestücken. Wurde was geändert oder habe ich da irgendwo vlt einen Fehler gemacht?

zum System...
OS: Debian Buster
Apache2.x
php-fpm (Versionen 5.6 bis 7.4)

 

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Diese Änderung ist EWIG her (Jahre!) - aber ja, korrekt ist 0750 (nicht für 'andere' lesbar) - mit korrektem setup sollte es da zu keinen problemen kommen

Link to comment
Share on other sites

  • 0

hmm merkwürdig... wenn das schon Jahre geändert ist verstehe ich dann aber nicht wieso die Rechte dann noch so auf 0755 gesetzt waren... mein Setup ist von Juni 2020 wo ich komplett installiert habe... 

bei 0750 funktioniert kein Seitenaufruf via php :(

Link to comment
Share on other sites

  • 0

PHP wird via php-fpm eingebunden. So ist dieses jedenfalls im Froxlor eingestellt. 

libnss-extrausers ist eingerichtet. Andernfalls würden die Ordner Berechtigungen komplett versagen. Jedenfalls werden mir die Benutzer angezeigt vom Froxlor.

Link to comment
Share on other sites

  • 0

werde mir mal auf meinem Raspberry die installation nochmal anschauen und ggf. auf meinem Server das ganze anpassen. Vlt hab ich auch nur ein fehler drin den ich so nicht sehe...

 

Link to comment
Share on other sites

  • 0

root@host:~# id www-data

Zitat

uid=33(www-data) gid=33(www-data) groups=33(www-data),9999(froxlorlocal),10000(W                                                                              eb001),10001(Web002),64056(Joerg),64057(SoS),64058(test),64059(test1),64060(test                                                                              2),64061(test3),64062(test4),64063(test5)

 

Link to comment
Share on other sites

  • 0

joa, da stehen die kunden-gruppen drin - also so sehe ich erstmal kein problem. Wenn bitte explizite Fehlermeldungen bei dem Aufruf der Seite und welche Berechtigungen das Verzeichnis hat, und owner usw.usw.usw.

Link to comment
Share on other sites

  • 0

Okay nun bin ich etwas perplex... ich kann nicht sagen was nun los ist aber es ist anscheind nun nun wieder in ordnung. Kundenordner (test6) hat die berechtigung 0750 und gehört dem Benutzer test6, die Testseite die ich rein geladen habe wurde sfort angezeigt. *ich versteh das nun nicht warum da erst ein fehler kam...

Bitte entschuldige die in anspruch genommene Zeit. Werde aber akribsch schauen wo die ursache war und was sich nun geändert hat. Danke für dein Hilfeversuch. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...