Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Regaddi

Postfix/Dovecot

Question

Hallo,

 

seit nun 3 Tagen versuche ich auf meinem Server den E-Mail-Dienst einzurichten. Bisher leider erfolglos.

 

Ich habe per Froxlor-Konfiguration Debian 5.0 (Lenny) den SMTP-Dienst Postfix/Dovecot und den POP/IMAP-Dienst Dovecot gem?? den Anleitungen konfiguriert.

Leider l?uft immer noch kein E-Mail-Dienst.

Wenn ich versuche auf ein Kunden-E-Mail-Konto per Thunderbird zuzugreifen, erhalte ich immer die Meldung "Konnte keine Verbindung mit dem Mail-Server pandamailer.de aufbauen, da sie verweigert wurde."

 

Als Benutzername habe ich die E-Mail-Adresse angegeben, wie sie im Kunden-Panel angegeben ist.

Als Server habe ich cbrnnet.de eingetragen, welcher die Hauptdomain auf dem Server ist, ?ber den auch Froxlor zu erreichen ist.

 

Ich habe mittlerweile einige Tutorials durchgelesen, bin nun aber zum Entschluss gekommen hier direkt um Hilfe zu beten.

 

Mein Ziel ist es am Ende einen TLS-verschl?sselten E-Mail-Dienst laufen zu haben, der mit RoundCubeMail und Thunderbird l?uft.

 

Ich wei? jetzt nicht genau, was ihr alles braucht an Infos, aber ihr werdet es mir hoffentlich sagen k?nnen.

 

Liebe Gr??e,

 

Christian

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

Server-IP ?ber Port 143:

telnet: Unable to connect to remote host: Connection refused

 

Server-IP ?ber Port 25:

Connected to 78.46.73.107.

Escape character is '^]'.

 

Wenn ich es statt der Server-IP mit localhost versuche ist das Ergebnis das Gleiche.

 

Postfix und Dovecot sind neugestartet. Ich sch?tze du meintest statt Courier Dovecot.

Share this post


Link to post
Share on other sites

Pr?fe mal die Logfiles (/var/log/mail.log oder /var/log/syslog), ob Dovecot den Start mit einem Fehler quittiert. Wenn nicht, Firewall aktiv; entweder auf Serverseite oder lokal?

Share this post


Link to post
Share on other sites

Sehr h?ufig im mail.log:

 

Jun  3 19:21:32 pandamailer postfix/trivial-rewrite[13033]: fatal: mysql:/etc/postfix/mysql-virtual_alias_maps.cf(0,lock|fold_fix): table lookup problem
Jun  3 19:21:32 pandamailer postfix/trivial-rewrite[13034]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

 

Dieselbe Meldung taucht auch im syslog auf.

 

Ich habe in der my.cnf geschaut, da ist als socket /var/run/mysqld/mysqld.sock angegeben und diese existiert auch.

Als bind-adress habe ich localhost stehen.

 

Die Daten hier stimmen allerdings, denn die habe ich mit phpmyadmin getestet:

 

mysql-virtual_alias_maps.cf:

user = froxlor
password = ---hidden---
dbname = froxlor
table = mail_virtual
select_field = destination
where_field = email
additional_conditions = and TRIM(destination) <> ''
hosts = localhost

 

Eine andere Meldung die oft vorkommt:

Jun  3 19:21:33 pandamailer postfix/master[7555]: warning: process /usr/lib/postfix/trivial-rewrite pid 12984 exit status 1
Jun  3 19:21:33 pandamailer postfix/smtpd[2185]: warning: problem talking to service rewrite: Success
Jun  3 19:21:33 pandamailer postfix/smtpd[2100]: warning: problem talking to service rewrite: Connection reset by peer

Share this post


Link to post
Share on other sites

?ndere in allen /etc/postfix/mysql_... Dateien hosts = localhost auf hosts = 127.0.0.1. Dovecot l?uft chrooted, daher m?sstest du einen symbolischen Link auf den SQL Socket anlegen, aber das ?ndern des Hosts auf 127.0.0.1 ist in meinen Augen die wartungs?rmere L?sung.

Share this post


Link to post
Share on other sites

OK, erledigt.

 

Eine neue Meldung macht sich im mail.log breit:

 

Jun  3 19:54:18 pandamailer postfix/local[17215]: 8E8ED2AAC129: to=<www-data@cbrnnet.de>, relay=local, delay=476, delays=473/2.1/0/0.09, dsn=4.3.0, status=deferred (temporary failure)
Jun  3 19:54:18 pandamailer deliver(www-data): mbox: Can't create root mail directory /var/www/mail: Permission denied
Jun  3 19:54:18 pandamailer deliver(www-data): Failed to create storage for 'www-data' with mail ''

 

Ich bin mir jetzt nicht sicher: Eigentlich sollen die E-Mail-Postf?cher ja durch froxlor im /var/customers/mail-Verzeichnis landen.

Wie es scheint will der Server in ausgehenden Mails von php-mail() auf dem Server speichern (wenn ich mich jetzt nicht t?usche).

 

Bisher hatte ich allerdings keine Probleme mit :(

 

 

EDIT: Soeben sind in meinem Postfach Mails vom Server angekommen :)

 

Nun ist nur noch das Problem mit TLS und den Zugriff durch Thunderbird/Roundcube...

Share this post


Link to post
Share on other sites

Hallo ich habe bei der Konfiguration meines Mailserver probleme

 

Habe die kofigs gebau so geschrieben wie in der anleitung mein System:

 

Ubuntu 10.04 Postfix mit Dovecot

 

als ich dann eine virtual mailbox eingerichtet habe und smtp probierte kommt das in der Logfile:

"Fatal: postmaster_address setting not given"

 

Habe ich vl. was vergessen oder ?bersehen?

 

Danke f?r jede hilfe

Share this post


Link to post
Share on other sites

Steht doch da :D

 

"Fatal: postmaster_address setting not given"

 

Du musst eine Einstellung namens postmaster_adress setzen. Google hilft dir mit den ersten 3 Ergebnissen bereits weiter ;)

Share this post


Link to post
Share on other sites

hab nun eine angegeben geht noch nicht bin mittlerweile auch weitergekommen.

 

in der auth.log steht das mysql Login nicht erfolgreich wahr.

habe dann auth_debug auf yes gestellt und bekommen (mail.log):

 

Jun  5 15:27:52 Ubuntu-1004-lucid-64-minimal postfix/smtpd[1944]: CD76910206BF: client=localhost[127.0.0.1]
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal postfix/cleanup[1955]: CD76910206BF: message-id=<20100605132752.CD76910206BF@*******.de>
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal postfix/qmgr[1582]: CD76910206BF: from=<mail@******.de>, size=355, nrcpt=1 (queue active)
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): master in: USER#0111#011test@*********.de#011service=deliver
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): passwd(test@**********.de): lookup
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): passwd(test@*********.de): unknown user
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): prefetch(test@********.de): passdb didn't return userdb entries, trying the next userdb
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal dovecot: auth-worker(default): sql(test@**********.de): SELECT CONCAT(homedir, maildir) AS home, CONCAT('maildir:', homedir, maildir) AS mail, uid, gid, CONCAT('maildir:storage=', (quota*1024)) as quota FROM mail_users WHERE username = 'test@***********.de' OR email = 'test@**********.de'
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): master out: USER#0111#011test@********.de#011home=/var/customers/mail/user001/test@********.de/#011mail=maildir:/var/customers/mail/user001/test@*******.de/#011uid=2000#011gid=2000#011quota=maildir:storage=0
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal dovecot: deliver(test@*********.de): Fatal: postmaster_address setting not given
Jun  5 15:27:58 Ubuntu-1004-lucid-64-minimal postfix/pipe[1957]: CD76910206BF: to=<test@*****.de>, relay=dovecot, delay=28, delays=28/0.01/0/0.01, dsn=4.3.0, status=deferred (temporary failure)
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal postfix/qmgr[1582]: 714321020093: from=<mail@*****.de>, size=355, nrcpt=1 (queue active)
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): master in: USER#0111#011test@******.de#011service=deliver
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): passwd(test@*******.de): lookup
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): passwd(test@*******.de): unknown user
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): prefetch(test@******.de): passdb didn't return userdb entries, trying the next userdb
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal dovecot: auth-worker(default): sql(test@********.de): SELECT CONCAT(homedir, maildir) AS home, CONCAT('maildir:', homedir, maildir) AS mail, uid, gid, CONCAT('maildir:storage=', (quota*1024)) as quota FROM mail_users WHERE username = 'test@*******.de' OR email = 'test@********.de'
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal dovecot: auth(default): master out: USER#0111#011test@*******.de#011home=/var/customers/mail/user001/test@******.de/#011mail=maildir:/var/customers/mail/user001/test@******.de/#011uid=2000#011gid=2000#011quota=maildir:storage=0
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal dovecot: deliver(test@******.de): Fatal: postmaster_address setting not given
Jun  5 15:28:25 Ubuntu-1004-lucid-64-minimal postfix/pipe[1957]: 714321020093: to=<test@*****.de>, relay=dovecot, delay=2528, delays=2528/0.06/0/0.04, dsn=4.3.0, status=deferred (temporary failure)

 

kann mir da jemand helfen finde den fehler nicht

Share this post


Link to post
Share on other sites

als erstes schonmal: Fatal: postmaster_address setting not given

Share this post


Link to post
Share on other sites

Ich habe mittlerweile die Konfiguration von Postfix und Dovecot aufgegeben und bin nun mit einem niegelnagelneuem Exim4 + Courier gestartet.

 

Die Dienste an sich laufen, im Webmail kann ich auf die Mails zugreifen.

Mittlerweile kommen auch Mails eingetrudelt, die anscheinend schon l?nger unterwegs waren und bisher nicht angekommen sind.

 

Mein derzeitiges Problem ist noch, dass wenn ich eine E-Mail z.B. an eine gmail-Adresse schicken m?chte, ich sofort eine Mail-Delivery-Nachricht bekomme, die meint:

 

***@gmail.com

unroutable adress

 

Das ist zumindest in RoundCube der Fall.

 

In Squirrelmail bekomme ich eine Squirrel-Meldung, wenn ich eine E-Mail verschicken m?chte:

 

Message not sent. Server replied:

 

0 Can't open SMTP stream.

 

 

Was kann ich tun?

 

 

EDIT:

 

Mittlerweile habe ich rausgefunden, dass anscheinend ein Router in /etc/exim4/conf.d/router fehlt, der die Mails vom Server weg transportiert.

 

Ich habe mal

exim4 -d -bt **@gmail.com

ausprobiert, und da kam als Schlussmeldung:

 

no more routers
**@gmail.com is undeliverable: Unrouteable address

 

Allerdings habe ich bisher keine Router-File f?r diesen Fall gefunden.

Wei? jemand Rat???

Share this post


Link to post
Share on other sites

×
×
  • Create New...