Jump to content
Froxlor Forum
  • 0

Ubuntu 20.04 - libnss-mysql No Longer Available


JeffH
 Share

Question

Hello,

I am new to Froxlor but I really like what I see so far! I've started the process of installing it on Ubuntu Server 20.04, but got stuck during the apache2 with fcgid configuration. The installation calls for installing libnss-mysql. This package is no longer distributed with Ubuntu 20.04. It looks like it's also not available in Ubuntu 18.04.

I also looked at the documentation for installing Froxlor via apache2 with php fpm and it also calls for libnss-mysql. Lastly, I looked at nginx with php fpm and it calls for libnss-mysql-bg which also is no longer distributed with Ubuntu 20.04 (or Ubuntu 18.04).

It looks like the last time either libnss-mysql or libnss-mysql-bg were included with Ubuntu was in version 16.04 which reaches end of standard support in April 2021 (end of life in April 2024), so I do not want to deploy an operating system that's 2 months away from no longer being supported.

When was the last time this installation process validated and with which version(s) of Ubuntu? Are there any alternatives to libnss-mysql or libnss-mysql-bg?

Please advise?

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

OK great! I actually installed that package but wasn't entirely certain if it was a suitable replacement.

I do have one other question.... I installed froxlor from the repository. The documentation states that I should be able to open a browser and connect to http://<IP ADDRESS>/froxlor. It doesn't look like the package installation took care of creating the site under apache2/sites-available (/sites-enabled). Is it expected that we create that file manually?

Link to comment
Share on other sites

  • 0

I checked /etc/apache2/sites-available/000-default.conf and the default directory was /var/www/html. I just changed DocumentRoot to /var/www and restarted.

When I look under /var/www/froxlor, I see what's in the image below. Looks OK to me.

 

2021-02-03_17-15-43.jpg

Link to comment
Share on other sites

  • 0

OK - it was my fault. I had another site defined on the server set to use virtualhosts but it wasn't working the way it was supposed to. Apache was using it as the default site instead of the 000-default.conf.

Everything is OK now. Sorry to trouble you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...