Jump to content
Froxlor Forum
  • 0

Problem bei Ugrade mit der Datenbank


Go to solution Solved by d00p,

Question

Hallo ich hab von einer 0.95 Version auf die aktuelle 0.10.19   DB 20200515 upgedatet.

Jetzt funktioniert der cron nicht mehr. Wenn ich ihn per Hand aufrufe kommt diese Meldung:

root@mail:/var/www/froxlor/scripts# php -q froxlor_master_cronjob.php
Version of file doesn't match version of database. Exiting...

Possible reason: Froxlor update
Information: Current version in database: 0.10.19 (DB: 202005150) - version of Froxlor files: 0.9.39.5 (DB: 201809280)
Solution: Please visit your Foxlor admin interface for further information.

Was ist das schiefgelaufen? Anscheinend wurde die Datenbank nicht upgegradet. Das wurde mir aber nicht angezeigt. Ich habe was von DNS und Let´s Encrypt update gelesen und durchgeführt. Das Backend zeigt mir aber keinen weiteren Fehler an.
Besten Dank für einen Tipp

OS: Debian 8

 

 

Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 1
  • Solution
7 minutes ago, wwl said:

Kann es sein das ich irgendein Limit überschritten habe?

Nein

So, der Fehler sagt, Domain id 214, und taucht da auf wo er den documentroot prüft. Also bitte einmal die Ausgabe von 

SELECT documentroot FROM panel_domains WHERE id=214

Link to post
Share on other sites
  • 1

Steht doch genau da

15 minutes ago, wwl said:

Information: Current version in database: 0.10.19 (DB: 202005150) - version of Froxlor files: 0.9.39.5 (DB: 201809280)

Du hast offenbar, wie auch immer, die Datenbank aktualisiert aber deine froxlor Dateien sind noch 0.9.39.5 ....du hast sicher mehrere froxlor Ordner und dein Webserver zeigt auf den falschen...

Link to post
Share on other sites
  • 1

Dann schau doch bitte in deine /etc/cron.d/froxlor - wenn du immer noch den Versions mismatch Hast und Aufgaben nicht abgearbeitet werden, dann ruft doch dein cron-daemon was falsches auf

Link to post
Share on other sites
  • 1

Dann hast du irgendwo Stuss in deiner Datenbank/ deinen Einstellungen stehen das der cron ein leeres directory bekommt. Das kann eigentlich bei einem.standard Setup gar nicht vorkommen. Bitte schau in die panel_domains Tabelle im Feld documentroot ob da überall was drinsteht.

Link to post
Share on other sites
  • 1

Ich kann nicht Hellsehen. Du wiederholst einfach immer wieder die gleichen Meldungen und erhoffst dir andere Ergebnisse. 

Du musst bitte etwas mehr Info bereitstellen. Haben alle customer in der panel_customer ein homedir? Alle Domains ein documentroot? Gibt es die Ordner alle? Funktioniert deine Namensauflösung (libnss) und und und und.

Ohne mehr Info kann ich dir lediglich sagen das was an deinen Daten nicht stimmt, denn bei anderen funktioniert es ja auch.

Link to post
Share on other sites
  • 0

Hmm, war komisch habe die alte Version komplett aus dem Verzeichnis gelöscht und die neue reinkopiert. Dann die userdata.inc.php kopiert und das Backend aufgerufen. Da wurde eine  Update durchgeführt und danach lief alles mit der neuen Version. Unten Rechts in Froxlor Details wurde auch die Neue Version angezeigt. Soweit alles gut. Nur die Cron Scripte wurden nicht abgearbeitet. Dann hab ich cron über die shell gestartet und bekam die Meldung: Version of file doesn't match version of database. Exiting...

Jetzt hab ich nochmal alles runtergelöscht und nochmal in das Verzeichnis alle Neuen Daten kopiert und die userdata.inc.php platziert. Im Backend alles ok, ohne Updateroutine. - Jetzt geht auch die cron aufrufen über die shell. Die Dateien werden aber nicht erzeugt.

In Froxlor unter Froxlor Detail wird mir immer angezeigt das Cron Aufgaben ausstehen:

  • Neuerstellung der Webserver-Konfiguration
  • Neuerstellung der Bind-Konfiguration
  • Lösche SSL Dateien von Domain BlaBla******.de

Aber die Aufgaben wurden bereits abgearbeitet. Z.B. steht für Let´s Encrypt 30 Minuten in der Cron, aber es wird alle 5 Minuten ausgeführt. Auch Konfigurationsdateien werden laut Froxlor Details erstellt, liegen aber nicht im Verzeichnis.

Irgendwas stimmt mit den cron Jobs nicht. Die Konfigurationsdateien für Apache wurden immer unter /etc/apache2/sites-enabled abgelegt. Hat sich das nach dem Update geändert. Steht zumindest immer noch so unter den Froxlor Einstellungen drin. Jetzt tauchen sie nicht mehr auf.

Was ist das schiefgelaufen?

 

Hab noch was gefunden:


PHP Fatal error:  Uncaught Exception: Cannot validate directory in makeCorrectDir which is very dangerous. in /var/www/froxlor/lib/Froxlor/FileDir.php:289
Stack trace:
#0 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(660): Froxlor\FileDir::makeCorrectDir()
#1 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1073): Froxlor\Cron\Http\Apache->getWebroot()
#2 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1122): Froxlor\Cron\Http\Apache->getVhostContent()
#3 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(152): Froxlor\Cron\Http\Apache->createVirtualHosts()
#4 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(52): Froxlor\Cron\System\TasksCron::rebuildWebserverConfigs()
#5 /var/www/froxlor/lib/Froxlor/Cron/MasterCron.php(111): Froxlor\Cron\System\TasksCron::run()
#6 /var/www/froxlor/scripts/froxlor_master_cronjob.php(26): Froxlor\Cron\MasterCron::run()
#7 {main}
  thrown in /var/www/froxlor/lib/Froxlor/FileDir.php on line 289

 

Link to post
Share on other sites
  • 0

DAs Hauptproblem scheint aber folgendes zu sein:

 

PHP Fatal error:  Uncaught Exception: Cannot validate directory in makeCorrectDir which is very dangerous. in /var/www/froxlor/lib/Froxlor/FileDir.php:289
Stack trace:
#0 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(660): Froxlor\FileDir::makeCorrectDir()
#1 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1073): Froxlor\Cron\Http\Apache->getWebroot()
#2 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1122): Froxlor\Cron\Http\Apache->getVhostContent()
#3 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(152): Froxlor\Cron\Http\Apache->createVirtualHosts()
#4 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(52): Froxlor\Cron\System\TasksCron::rebuildWebserverConfigs()
#5 /var/www/froxlor/lib/Froxlor/Cron/MasterCron.php(111): Froxlor\Cron\System\TasksCron::run()
#6 /var/www/froxlor/scripts/froxlor_master_cronjob.php(26): Froxlor\Cron\MasterCron::run()
#7 {main}
  thrown in /var/www/froxlor/lib/Froxlor/FileDir.php on line 289

Deswegen werden keine Dateien angelegt. Der Cron wird angestoßen, aber nicht abgeschlossen.

 

Link to post
Share on other sites
  • 0

Ja, alles wie es sein soll.

Musste gestern Nacht wieder zurück auf 0.95 weil nichts mehr ging. Bin jetzt dabei nochmal das Upgrade zu machen.
Grund für ein Upgrade ist das neu angelegt Domains kein Let´s Encrypt Zertifikat mehr bekommen.

Link to post
Share on other sites
  • 0

Aktuelles Upgrade:

 

Updating from 0.9.39.5 to 0.9.40
Updating from 0.9.40 to 0.9.40.1
Updating from 0.9.40.1 to 0.10.0-rc1
Adding new api keys table[OK]
Adding new api settings[OK]
Adding new default-ssl-ip setting[OK]
Altering admin ip's field to allow multiple ip addresses[OK]
Adding dhparams-file setting[OK]
Adding new settings for 2FA[OK]
Adding new fields to admin-table for 2FA[OK]
Adding new fields to customer-table for 2FA[OK]
Adding new logview-flag to customers[OK]
Adding new is_configured-flag[OK]
Adding fields writeaccesslog and writeerrorlog for domains[OK]
Updating cronjob table[OK]
Removing ticketsystem[OK]
Updating nameserver settings[OK]
Adding new webserver error-log-level setting[OK]
Adding new ECC / ECDSA setting for Let's Encrypt[OK]
Removing current Let's Encrypt certificates due to new implementation of acme.sh[OK]
Inserting job to regenerate configfiles[OK]
Adding new froxlor vhost domain alias setting[OK]
Converting all MyISAM tables to InnoDB[OK]
Updating from 0.10.0-rc1 to 0.10.0-rc2
Adding new settings for CAA[OK]
Cleaning up old files[OK]
Updating from 0.10.0-rc2 to 0.10.0 final
Adding TLSv1.3-cipherlist setting[OK]
Adding field api_allowed to admins and customers[OK]
Updating from 0.10.0 to 0.10.1 final
Adjusting Let's Encrypt API setting[OK]
Adding new settings for ssl-vhost default content[OK]
Adding new fields to ips and ports-table[OK]
Adding new fields to domains-table[OK]
Adjusting IP/port settings for downward compatibility[OK]
Adjusting domain settings for downward compatibility[OK]
Updating from 0.10.1 to 0.10.2
Adding new TLS options to domains-table[OK]
Updating from 0.10.2 to 0.10.3
Updating from 0.10.3 to 0.10.4
Updating from 0.10.4 to 0.10.5
Optimizing customer and admin table for size[OK]
Updating from 0.10.5 to 0.10.6
Adding new settings for domain edit form default values[OK]
Updating from 0.10.6 to 0.10.7
Updating from 0.10.7 to 0.10.8
Updating from 0.10.8 to 0.10.9
Adding enhanced SSL control over domains[OK]
Updating from 0.10.9 to 0.10.10
Adding option to disable SSL sessiontickets for older systems[OK]
Adding custom phpfpm pool configuration field[OK]
Updating from 0.10.10 to 0.10.11
Migrate logfiles_format setting[OK]
Adding option change awstats LogFormat[OK]
Updating from 0.10.11 to 0.10.12
Updating from 0.10.12 to 0.10.13
Adding new field to domains table[OK]
Updating domain entries[OK]
Updating from 0.10.13 to 0.10.14
Updating from 0.10.14 to 0.10.15
Adding new setting to validate DNS when using Let's Encrypt[OK]
Updating from 0.10.15 to 0.10.16
Adding unique key on domainid field in domain ssl table[OK]
Updating from 0.10.16 to 0.10.17
Updating from 0.10.17 to 0.10.18
Updating from 0.10.18 to 0.10.19
Checking database integrity[Monkeys ate the integrity]
Trying to remove monkeys, feeding bananas[Integrity restored]

Link to post
Share on other sites
  • 0

Jetzt hab ich in der aktuellen Version mal den Cron per shell aufgerufen. Es läuft alles saber durch nur am schluss kommen diese Meldungen:

[information] apache::createVirtualHosts: creating vhost container for domain 460, customer desumed
[information] apache::createVirtualHosts: creating vhost container for domain 40, customer desumed
[information] apache::createVirtualHosts: creating vhost container for domain 77, customer leicht
[information] apache::createVirtualHosts: creating vhost container for domain 485, customer beyond
[information] apache::createVirtualHosts: creating vhost container for domain 427, customer beyond
chown: der Eigentümer von „/var/www/php-fcgi-scripts/beyond/www.beyond-history.com/php-fcgi-starter“ wird geändert: Die                                    Operation ist nicht erlaubt
[information] apache::createVirtualHosts: creating vhost container for domain 428, customer beyond
[information] apache::createVirtualHosts: creating vhost container for domain 417, customer leicht
[information] apache::createVirtualHosts: creating vhost container for domain 41, customer beubl
[information] apache::createVirtualHosts: creating vhost container for domain 266, customer stimmelmayer
[information] apache::createVirtualHosts: creating vhost container for domain 44, customer heindl
chown: der Eigentümer von „/var/www/php-fcgi-scripts/heindl/bianca-heindl.de/php-fcgi-starter“ wird geändert: Die Operat                                   ion ist nicht erlaubt
[information] apache::createVirtualHosts: creating vhost container for domain 158, customer chrisleblanc
chmod: Beim Setzen der Zugriffsrechte für „/var/www/php-fcgi-scripts/chrisleblanc/christophweis.com/php-fcgi-starter“: D                                   ie Operation ist nicht erlaubt
chown: der Eigentümer von „/var/www/php-fcgi-scripts/chrisleblanc/christophweis.com/php-fcgi-starter“ wird geändert: Die                                    Operation ist nicht erlaubt
[information] apache::createVirtualHosts: creating vhost container for domain 159, customer chrisleblanc
[information] apache::createVirtualHosts: creating vhost container for domain 161, customer chrisleblanc
[information] apache::createVirtualHosts: creating vhost container for domain 212, customer karmaloft
chown: der Eigentümer von „/var/www/php-fcgi-scripts/karmaloft/florianluettich.de/php-fcgi-starter“ wird geändert: Die O                                   peration ist nicht erlaubt
[information] apache::createVirtualHosts: creating vhost container for domain 214, customer karmaloft
PHP Fatal error:  Uncaught Exception: Cannot validate directory in makeCorrectDir which is very dangerous. in /var/www/f                                   roxlor/lib/Froxlor/FileDir.php:289
Stack trace:
#0 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(660): Froxlor\FileDir::makeCorrectDir()
#1 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1073): Froxlor\Cron\Http\Apache->getWebroot()
#2 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1122): Froxlor\Cron\Http\Apache->getVhostContent()
#3 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(152): Froxlor\Cron\Http\Apache->createVirtualHosts()
#4 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(52): Froxlor\Cron\System\TasksCron::rebuildWebserverConfigs()
#5 /var/www/froxlor/lib/Froxlor/Cron/MasterCron.php(111): Froxlor\Cron\System\TasksCron::run()
#6 /var/www/froxlor/scripts/froxlor_master_cronjob.php(26): Froxlor\Cron\MasterCron::run()
#7 {main}
  thrown in /var/www/froxlor/lib/Froxlor/FileDir.php on line 289

 

Link to post
Share on other sites
  • 0

Wenn ich wüste was ich fragen müsste 😉
In panel_customers sind alle documentroot felder richtig eingetragen /home/httpd/customerX/

In panel_domains sind auch alle documentroot eingertragen /home/httpd/customerX/domain.de/

Liegt die Fehlermeldung an irgenwelchen Sonderzeichen? In der alten Version haben die Pfade ja auch gestimmt.
Alle 130 Domains können doch jetzt nicht falsch sein. An den Verzeichnisrechten hab ich ja auch nichts geändert. Alle haben die richtigen Nutzerrechte
Die 0.95er Version hat nach /etc/apache/sites-enabled schreiben können, die 0.10 gibt Fehler aus.

Kann es sein das ich irgendein Limit überschritten habe?

 

Link to post
Share on other sites
  • 0

Ja, schande auf mein Haupt. Eine Domain wo kein Eintrag drin war.
Jetzt läuft die Cron sauber durch. Ich werde noch mal alles testen.

Vielen Dank für Deine Hilfe

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...