Jump to content
Froxlor Forum
  • 0
e-Ra

SSL Zertifikat für Froxlor Panel erneuern

Question

Hallo,

ich möchte gerne das SSL Zertifikat des Froxlor Panels durch Froxlor selbst erneuern lassen und habe dafür folgende Einstellungen gesetzt:

Ips and Ports -> Erstelle vHost-Container JA

Froxlor VirtualHost Einstellungen -> Let's Encrypt für den froxlor Vhost verwenden JA

Nach einer automatischen Ausführung des Cronjobs erhalte ich folgende Meldung:

[debug] System certificate file "" does not seem to exist. Disabling SSL-vhost for "<froxlor_panel_domain>"

 

Jemand eine Idee?

 

Viele Grüße

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

was sagt denn der debug output des cronjobs noch so alles davor? Hat er versucht ein Let's Encrypt Zertifikat für deine froxlor-panel-domain zu erstellen?

Share this post


Link to post
Share on other sites
  • 0

Hier die komplette log Ausgabe:

/usr/bin/php7.2 /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug --force                                                                                                          

[information] Requesting/renewing Let's Encrypt certificates
[information] No new certificates or certificates due for renewal found
[information] TasksCron: Searching for tasks to do
[information] Running Let's Encrypt cronjob prior to regenerating webserver config files
[information] Requesting/renewing Let's Encrypt certificates
[information] No new certificates or certificates due for renewal found
[information] apache::createIpPort: creating ip/port settings for  <IP1>:80
[notice] <IP1>:80 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP1>:443
[notice] <IP1>:443 :: namevirtualhost-statement no longer needed for apache-2.4
[debug] System certificate file "" does not seem to exist. Disabling SSL-vhost for "<FROXLOR_PANEL_DOMAIN>"
[debug] <IP1>:443 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  <IP1>:80
[notice] <IP1>:80 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP1>:443
[notice] <IP1>:443 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP2>:80
[notice] <IP2>:80 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP2>:443
[notice] <IP2>:443 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP3>:80
[notice] <IP3>:80 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP3>:443
[notice] <IP3>:443 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createVirtualHosts: creating vhost container for domain 356, customer <CUSTOMER>
.
.
.
[information] Setting Options +Indexes for /var/customers/webs/server/
[information] Enabling perl execution for /var/customers/webs/server/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi
[notice] Checking system's last guid

 

Falls relevant hier noch der Inhalt der '/root/.acme.sh/<FROXLOR_PANEL_DOMAIN>/<FROXLOR_PANEL_DOMAIN>.conf':

Le_Domain='<FROXLOR_PANEL_DOMAIN>'
Le_Alt='no'
Le_Webroot='/var/www/froxlor'
Le_PreHook=''
Le_PostHook=''
Le_RenewHook=''
Le_Keylength='4096'
Le_OrderFinalize='https://acme-v02.api.letsencrypt.org/acme/finalize/XXXXXXXXXXXXXXXXXXXXXX'
Le_LinkOrder='https://acme-v02.api.letsencrypt.org/acme/order/XXXXXXXX/XXXXXXX'
Le_LinkCert='https://acme-v02.api.letsencrypt.org/acme/cert/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
Le_CertCreateTime='1588328054'
Le_CertCreateTimeStr='Fri May  1 10:14:14 UTC 2020'
Le_ForceNewDomainKey='1'
Le_NextRenewTimeStr='Tue Jun 30 10:14:14 UTC 2020'
Le_NextRenewTime='1593425654'

 

Laut Browser ist das Zertifikat gültig:

von ‎Dienstag, ‎10. ‎März ‎2020 00:47:05
bis ‎Montag, ‎8. ‎Juni ‎2020 00:47:05

Share this post


Link to post
Share on other sites
  • 0

Die IP/port auch SSL enabled? auf IP1? bei den anderen kommt das nicht vor, und IP1 hast du da zweimal...kann nicht ganz sein. 

Share this post


Link to post
Share on other sites
  • 0

Da hast du natürlich vollkommen Recht, mein Fehler beim Ersetzen der IPs.

Hier nochmal die Log Ausgabe:

/usr/bin/php7.2 /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug --force                                                                                                          

[information] Requesting/renewing Let's Encrypt certificates
[information] No new certificates or certificates due for renewal found
[information] TasksCron: Searching for tasks to do
[information] Running Let's Encrypt cronjob prior to regenerating webserver config files
[information] Requesting/renewing Let's Encrypt certificates
[information] No new certificates or certificates due for renewal found
[information] apache::createIpPort: creating ip/port settings for  <IP1>:80
[notice] <IP1>:80 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP1>:443
[notice] <IP1>:443 :: namevirtualhost-statement no longer needed for apache-2.4
[debug] System certificate file "" does not seem to exist. Disabling SSL-vhost for "<FROXLOR_PANEL_DOMAIN>"
[debug] <IP1>:443 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  <IP2>:80
[notice] <IP2>:80 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP2>:443
[notice] <IP2>:443 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP3>:80
[notice] <IP3>:80 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP3>:443
[notice] <IP3>:443 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP4>:80
[notice] <IP4>:80 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createIpPort: creating ip/port settings for  <IP4>:443
[notice] <IP4>:443 :: namevirtualhost-statement no longer needed for apache-2.4
[information] apache::createVirtualHosts: creating vhost container for domain 356, customer <CUSTOMER>
.
.
.
[information] Setting Options +Indexes for /var/customers/webs/server/
[information] Enabling perl execution for /var/customers/webs/server/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi
[notice] Checking system's last guid

 

Der A-Record der Froxlor Panel Domain zeigt auf <IP1>

Für <IP1>:443 ist die Einstellung 'Ist dies ein SSL-Port' gesetzt.

 

Share this post


Link to post
Share on other sites
  • 0

Zeigt denn froxlor in der SSL-Zertifikate übersicht überhaupt ein Zertifikat für den froxlorvhost an? Oder wurde ggfls gar keins erstellt? Wie sieht der entsprechende Vhost (10_froxlor_ipandport_[ip] ...) aus?

Share this post


Link to post
Share on other sites
  • 0

Zertifikat wird in der SSL-Zertifikat Übersicht angezeigt:

Issuer: Let's Encrypt
Gültig ab: 01.05.2020
Gültig bis: 30.07.2020

Der Browser meint aber:

Gültig ab: 10.03.2020
Gültig bis: 08.06.2020

Hier die '/etc/apache2/sites-enabled/10_froxlor_ipandport_<IP1>.443.conf':

# 10_froxlor_ipandport_<IP1>.443.conf                                                                                                               
# Created 05.05.2020 21:02                                                                                                                                   
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.                                                                                                                                                                                                          
<VirtualHost <IP1>:443>                                                                                                                               
DocumentRoot "/var/www/"                                                                                                                                     
SSLEngine On                                                                                                                                               
SSLProtocol -ALL +TLSv1.2                                                                                                                                   
SSLCompression Off                                                                                                                                          
SSLHonorCipherOrder off                                                                                                                                     
SSLCipherSuite ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:D
HE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDH
E-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-
AES256-SHA:DHE-RSA-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128:AES256:AES:DES-CBC3-SHA:HIGH:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!MD5:!PSK             
SSLVerifyDepth 10
SSLCertificateFile /etc/ssl/froxlor-custom/<FROXLOR_PANEL_DOMAIN>.crt
SSLCertificateKeyFile /etc/ssl/froxlor-custom/<FROXLOR_PANEL_DOMAIN>.key
SSLCACertificateFile /etc/ssl/froxlor-custom/<FROXLOR_PANEL_DOMAIN>_CA.pem
SSLCertificateChainFile /etc/ssl/froxlor-custom/<FROXLOR_PANEL_DOMAIN>_chain.pem
</VirtualHost>                                                                 

 

Das '/etc/ssl/froxlor-custom/<FROXLOR_PANEL_DOMAIN>.crt' Zertifikat hat folgende Gültigkeit:

Not Before: May  1 09:14:12 2020 GMT
Not After : Jul 30 09:14:12 2020 GMT
 

Sieht so aus als ob da ein anderes Zertifikat ausgeliefert wird?

Share this post


Link to post
Share on other sites
  • 0

Hä? Also da kann ja was nicht stimmen, der cronjob sagt er deaktiviert den SSL vhost, aber offenbar ist er ja da. Also das kann nicht ganz sein, es müsste diese Meldung ja sonst auch im vhost als Kommentar stehen.

Nutzt du auch den aktuellen Release 0.10.16?

Share this post


Link to post
Share on other sites
  • 0

Installierte Version: 0.10.13 (DB: 201912313)

[debug] System certificate file "" does not seem to exist. Disabling SSL-vhost for "<FROXLOR_PANEL_DOMAIN>"

Was ist denn dieses  'System certificate file'? Der SSL-vhost wird ja deaktiviert weil damit was nicht passt, oder?

Share this post


Link to post
Share on other sites
  • 0

Bitte definitiv Erstmal updaten. 0.10.13 ist vom Februar

Share this post


Link to post
Share on other sites
  • 0

Froxlor ist jetzt aktualisiert.

Installierte Version 0.10.16 (DB 202004140)

Folgende Ausgabe erhalte ich nach wie vor nach Ausführung von '/usr/bin/php7.2 /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug --force':

[debug] System certificate file "" does not seem to exist. Disabling SSL-vhost for "<FROXLOR_PANEL_DOMAIN>"

Interessant ist noch, dass das Zertifikat aber kurz vor dem Update noch erneuert wurde.

Kurze Zeit später ist dann diese Meldung von Let's Encrypt gekommen:

Zitat

According to our records, the software client you're using to get Let's
Encrypt TLS/SSL certificates issued or renewed at least one HTTPS certificate
in the past two weeks using the ACMEv1 protocol. Here are the details of one
recent ACMEv1 request from each of your account(s):

Client IP address: <IP1>

User agent:  CertbotACMEClient/0.10.2 (Debian GNU/Linux 8 (jessie)) Authenticator/webroot Installer/None

Hostname(s):  "<FROXLOR_PANEL_DOMAIN>"

Request time:  2020-05-08 22:55:26 UTC

Im Admin Panel ist aber ACME v2 ausgewählt (geht ja sowieso nichts anderes) sowie die v2 Live URL.

Share this post


Link to post
Share on other sites
  • 0

Lösch doch mal das entsprechende Zertifikat aus der SSL-Zertifikate übersicht in froxlor und via "/root/.acme.sh/acme.sh --remove -d [domain]" auch aus dem dateisystem und fang clean von vorne an

On 5/22/2020 at 5:47 PM, e-Ra said:

User agent:  CertbotACMEClient/0.10.2 (Debian GNU/Linux 8 (jessie)) Authenticator/webroot Installer/None

Das ist auch garantiert nicht das von froxlor genutzte system. Hast du da selbst noch nen certbot installiert  und machst da manuell mit zertifikaten was?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...