Jump to content
Froxlor Forum
  • 0
john9

Cannot Move Froxlor to VAR HTML

Question

Hi there, 

I run UBUNTU 18.04 and installed LAMP.

MySQL and PHP everything good.

Installed Froxlor BUT I cannot move it to var/www/html because it says it is not empty 

 

mv: cannot move 'froxlor/actions' to '/var/www/html/actions': Directory not empty
mv: cannot move 'froxlor/css' to '/var/www/html/css': Directory not empty
mv: cannot move 'froxlor/doc' to '/var/www/html/doc': Directory not empty
mv: cannot move 'froxlor/install' to '/var/www/html/install': Directory not empty
 

I have also tried to clean the folder with

du -csh /var/*

but it did not work when trying to move it I still have this warning message.

 

please help

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
11 minutes ago, john9 said:

du -csh /var/*

Cleaning the folder? Using du???? Where did you get THAT? Only thing that command does is outputting a summarized (-s), human-readable (-h) total sum (-c) of the contents of /var/* (du == disk usage). Also, you would definetly not want to clean /var/* !!!

And problem with the move you want to do is, it seems that there are already folders in /var/www/html/.

Let's say /var/www/html/ is clear and froxlor is in /var/www/, there is no problem with running:

mv /var/www/froxlor /var/www/html/froxlor

Done that millions of times 

Share this post


Link to post
Share on other sites
  • 0

I'm not expert and I found that command on a different website. 

Great to know your suggestion. But how to know which folders are in var html and how to delete them or how to avoid this issue?

 

Thank you

Share this post


Link to post
Share on other sites
  • 0

So you're telling me you run any command you find online? Without knowing what it does? Puuuh.

Well, which files are important and which are not is something only YOU can know. By default, there is only a index.html file in /var/www/html - so putting the froxlor folder in there should not be a problem. 

Share this post


Link to post
Share on other sites
  • 0

in effect sometimes I'm too impulsive. it was here https://www.linuxquestions.org/questions/linux-software-2/how-to-clean-var-directory-635863/ 

but I knew it was not the same :)

Honestly I care just about froxlor and this server is pretty new. There is nothing on it other than LAMP and froxlor

the point is why I'm stuck here:

$ cd /var/www/html $ sudo wget https://files.froxlor.org/releases/froxlor-latest.tar.gz $ sudo tar -zxvf froxlor-latest.tar.gz $ sudo mv froxlor/* /var/www/html

 

Share this post


Link to post
Share on other sites
  • 0

with these messages

mv: cannot move 'froxlor/tests' to '/var/www/html/tests': Directory not empty
mv: cannot move 'froxlor/vendor' to '/var/www/html/vendor': Directory not empty

Share this post


Link to post
Share on other sites
  • 0

Why do you want to move everything from froxlor/* to /bar/www/html/ anyway? No need. Just extract to /var/www/html/, open http://[ip]/froxlor an proceed. You can later in the settings tell froxlor to be accessable directly via the given domain from the installation.

Share this post


Link to post
Share on other sites
  • 0

I followed a guide step by step. And this was the almost the last step. That's why I wanted to do that.

I'm trying doing what you said with tar xvzf froxlor-latest.tar.gz -C /var/www/html

but it does not work. Any suggestion?

Share this post


Link to post
Share on other sites
  • 0

Ist the froxlor folder in /var/www/html/froxlor?

Did you specify the folder in the address bar of the browser? Like http://your-ip-address/froxlor/ ?

Share this post


Link to post
Share on other sites
  • 0

in this case I have: Not Found

despite I have double checked it and after this command tar xvzf froxlor-latest.tar.gz -C /var/www/html

it has been extracted somewhere. and I guess froxlor folder because it is the only folder I see

Share this post


Link to post
Share on other sites
  • 0

I think there is a problem with LAMP because I worked with the below guide: 

https://blog.ssdnodes.com/blog/froxlor-control-panel-ubuntu/

and I did everything alright

But just before the point 3 it says to test the LAMP installation with a php.info file. And I do it. but I do not see it.

in the browser I see 

Not Found

The requested URL was not found on this server.


Apache/2.4.29 (Ubuntu) Server at 185.181.9.139 Port 80

Share this post


Link to post
Share on other sites
  • 0

These are really very basic tasks at the beginning, which a sysadmin should know. It seems to me you are missing basic knowledge on how to operate a Linux system. And from what I can see this tutorial explains every small step. So there is not much you can do wrong. Now, in order to help you, is there ANYTHING you did besides what's in the tutorial? Regarding the server, the domain, anything?! Because 99% of the time (from my experience) at the end it's something really insignificant and the user thought it's not worth mentioning. So please, save us both a lot of time

Share this post


Link to post
Share on other sites
  • 0

:) 🤣:) 

i Understand. Honestly I did nothing else than what's written in that guide. 

But let me rebuild the server.  And do it again step by step. 

Then I will come back here in the case it does not work.

Share this post


Link to post
Share on other sites
  • 0

Now I got it in the folder and I run the installation BUT it ends the installation saying:

Could not create /var/www/html/froxlor/lib/userdata.inc.php, please create it manually with the following content:

Share this post


Link to post
Share on other sites
  • 0

You should chown the froxlor directory with the.webserver user, then you do not need.to manually do that. Or you could just do what it says...it's really simple

Share this post


Link to post
Share on other sites
  • 0

Now I see froxlor folder on the both so it is just to understand why I do not see the installation window

Share this post


Link to post
Share on other sites
  • 0
21 minutes ago, john9 said:

Seemed about right, you somehow missed index.php as DirectoryIndex, if you open /install/index.php directly it works, but seems.to.be fixed now as I see the index right away

Share this post


Link to post
Share on other sites
  • 0

now I installed it. And I see this message

File was saved in /tmp/userdata.inc.php, please move to /var/www/html/froxlor/lib/.

 

I saw a similar issue in the forum and you provided this solution

mv /tmp/userdata.inc.php /var/www/froxlor/lib

But it doesn't work with me ubuntu and apache and it says

mv /tmp/userdata.inc.php /var/www/froxlor/lib
mv: cannot stat '/tmp/userdata.inc.php': No such file or directory
 

despite it was saved in that directory

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...