Jump to content
Froxlor Forum
  • 0
xep22

SSL Zertifikat wird im browser nicht erkannt

Question

moin,

habe auf einer testumgebung froxlor neu installiert, diesmal mit debian 9 und PHP 7. soweit ging auch alles, habe jetzt SSL aktiviert und die Webserver konfiguration durchgeführt. dann noch in putty diesen Befehl verwendet :

openssl req -new -days 999 -newkey rsa:4096bits -sha512 -x509 -nodes -out server.crt -keyout server.key

dann in Froxlor die IP mit port 443 hinzugefügt und gewartet. in froxlor wird das Zert. angezeigt und in /etc/ssl/froxlor-custom ist es auch. aber im Browser kommt 

Diese Website kann keine sichere Verbindung bereitstellen
janis0705.tk hat eine ungültige Antwort gesendet.

aber wieso ? das hat so immer funktioniert. was mache ich falsch ? wie kann ich da debuggen ?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
1 minute ago, xep22 said:

jetzt ist sie da :


# 35_froxlor_ssl_vhost_janis0705.tk.conf
# Created 11.05.2019 12:28
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 2 (SSL) - CustomerID: 1 - CustomerLogin: user1
<VirtualHost 91.200.103.227:443>
  ServerName janis0705.tk
  ServerAlias www.janis0705.tk
  ServerAdmin gwegew@egewew.de
  SSLEngine On
  SSLProtocol -ALL +TLSv1 +TLSv1.2
  SSLCompression Off
  SSLHonorCipherOrder On
  SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128
  SSLVerifyDepth 10
  SSLCertificateFile /etc/ssl/froxlor-custom/janis0705.tk.crt
  SSLCertificateKeyFile /etc/ssl/froxlor-custom/janis0705.tk.key
  SSLCACertificateFile /etc/ssl/froxlor-custom/janis0705.tk_CA.pem
  SSLCertificateChainFile /etc/ssl/froxlor-custom/janis0705.tk_chain.pem
  <IfModule mod_headers.c>
    Header always set Strict-Transport-Security "max-age=0"
  </IfModule>
  DocumentRoot "/var/customers/webs/user1/"
  php_admin_value sendmail_path "/usr/sbin/sendmail -t -f gwegew@egewew.de"
  php_admin_value open_basedir "/var/customers/webs/user1:/tmp"
  ErrorLog "/var/customers/logs/user1-error.log"
  CustomLog "/var/customers/logs/user1-access.log" combined
</VirtualHost>

die Apache-Zertifikate fehlen aber immer noch. 

 

Meldung genau Bitte bzw. error.log mal vom apache posten.
und deine selbst erstellten apache cert. haben nichts mit LE oder dem Vhost zu tun.
Weil deine LE Cert sind korrekt in deinem Vhost drin, daher weiß ich nicht ohne Logs, wo er deine eigenen Certs haben will ...

 

Share this post


Link to post
Share on other sites
  • 0

welches selbst erstellt für apache? wie gesagt habe ich es jetzt ohne opensll eingerichtet. Froxlor erstellt doch neben den webseiten-Zertifikaten auch die für apache oder nicht ?

error.log :

[Sat May 11 10:34:00.140950 2019] [ssl:warn] [pid 367] AH01906: janis0705.tk:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sat May 11 10:34:00.141013 2019] [ssl:warn] [pid 367] AH01909: janis0705.tk:443:0 server certificate does NOT include an ID which matches the server name

 

Share this post


Link to post
Share on other sites
  • 0

Also noch mal, du hast erwähnt

2 hours ago, xep22 said:

die Apache-Zertifikate fehlen aber immer noch. 

Also noch mal, deine Apache Cert, die du selbst erstellt hast, brauchst du nicht mehr, nach dem du LE aktiviert und benutzt hast.
Wenn du Froxlor über eine IP aufrufst, bekommst du natürlich kein LE Cert, sondern brauchst halt eine Domain o. Sub-Domain für Froxlor.
Froxlor macht, alles von alleine was LE angeht, du musst nur wenn du eine Domain oder Sub-Domain in Froxlor anlegst, musst du nur dann SSL für diese Domain oder Sub-Domain einstellen, den Rest macht das Panel.

Share this post


Link to post
Share on other sites
  • 0

ja schon. aber wie bereits erwähnt erhalte ich ohne die 2 Certs in /etc/apache2 nach einem Neustart von Apache2 den error:

Mai 11 15:10:00 root.eurenikz.de systemd[1]: apache2.service: Failed with result 'exit-code'.
Mai 11 15:10:00 root.eurenikz.de systemd[1]: Starting The Apache HTTP Server...
Mai 11 15:10:00 root.eurenikz.de apachectl[22701]: AH00526: Syntax error on line 14 of /etc/apache2/sites-enabled/10_froxlor_ipandport_185.254.97.69.443.conf:
Mai 11 15:10:00 root.eurenikz.de apachectl[22701]: SSLCertificateFile: file '/etc/apache2/apache2.pem' does not exist or is empty
Mai 11 15:10:00 root.eurenikz.de apachectl[22701]: Action 'start' failed.
Mai 11 15:10:00 root.eurenikz.de apachectl[22701]: The Apache error log may have more information.

 

Share this post


Link to post
Share on other sites
  • 0

also deine Fehler Meldung sagt doch schon alles /etc/apache2/apache2.pem' does not exist or is empty entferne mal die Certs unter den SSL Settings im Panel und starte den Froxlor Cron neu oder erstelle die fehlende Cert von hand.

Share this post


Link to post
Share on other sites
  • 0

ja das sagte ich ja, die Certs für apache fehlen... bzw. die im Ordner von apache halt.

wo entferne ich die im Panel? da sind ja nur die Pfade. 

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, xep22 said:

ja das sagte ich ja, die Certs für apache fehlen... bzw. die im Ordner von apache halt.

wo entferne ich die im Panel? da sind ja nur die Pfade. 

Du hast gerade dir die Antwort selbst gegeben, ja die Pfade.

Share this post


Link to post
Share on other sites
  • 0

hä? die pfade raus löschen also? was soll das aber bringen? habe ich mal gemacht und den Cron ausgeführt

[information] cron_tasks: Searching for tasks to do
[information] apache::createIpPort: creating ip/port settings for  91.200.103.22                                                                                                                                                                              7:80
[notice] 91.200.103.227:80 :: namevirtualhost-statement no longer needed for apa                                                                                                                                                                              che-2.4
[debug] 91.200.103.227:80 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  91.200.103.22                                                                                                                                                                              7:443
[error] root.janis0705.tk :: empty certificate file! Cannot create ssl-directive                                                                                                                                                                              s
[debug] 91.200.103.227:443 :: inserted vhostcontainer
[information] apache::createVirtualHosts: creating vhost container for domain 2,                                                                                                                                                                               customer user1
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::reload: reloading apache
[information] Task4 started - Rebuilding froxlor_bind.conf
[information] Cleaning dns zone files from /etc/bind/domains/
[debug] domId    domain                                  ismainbutsubto parent d                                                                                                                                                                              omain                           list of child domain ids
[debug] 2        janis0705.tk                            0              -                                                                                                                                                                                     
[information] `/etc/bind/domains/janis0705.tk.zone` written
[debug] Generating dns config for janis0705.tk
[information] froxlor_bind.conf written
[information] bind daemon reloaded
[information] Task4 finished
[notice] Checking system's last guid

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...