Jump to content
Froxlor Forum
  • 0
Mediaworld

Domain not forward

Question

Hi People,

I'm trying to setup Froxlor but i have one issue, i have added domain in the admin panel in Froxlor the domain will view /var/www/html not /var/customers/(*), is there anybody can help me, so i have all tried nothing works.

 

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

1) dir you adjust all settings to fit your system?

2) did you go through all the configuration steps to configure your system and services?

3) did the cronjob run? Try running it manually with the force flag, e.g. php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

 

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, d00p said:

1) dir you adjust all settings to fit your system?

 2) did you go through all the configuration steps to configure your system and services?

3) did the cronjob run? Try running it manually with the force flag, e.g. php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

 

I have done the steps

If i will run the command with, php /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --force --debug

it says 

[information] cron_tasks: Searching for tasks to do

[information] apache::createIpPort: creating ip/port settings for  ipserver:80

[notice] ipserver:80 :: namevirtualhost-statement no longer needed for apache-2.4

[debug] ipserver:80 :: inserted vhostcontainer

[information] apache::createVirtualHosts: creating vhost container for domain 3, customer far

[information] apache::createVirtualHosts: creating vhost container for domain 1, customer far

[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/

[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/

[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/

[information] apache::reload: reloading apache

[information] Task4 started - Rebuilding froxlor_bind.conf

[information] Cleaning dns zone files from /etc/bind/domains/

[debug] domId    domain                                  ismainbutsubto parent domain                           list of child domain ids

[debug] 3        domain                    0              -                                       

[information] `/etc/bind/domains/domain.zone` written

[debug] Generating dns config for domain

[information] froxlor_bind.conf written

sh: 1: /etc/init.d/bind9: not found

[error] Error while running `/etc/init.d/bind9 reload`: exit code (127) - please check your system logs

[information] Task4 finished

[notice] Checking system's last guid

Share this post


Link to post
Share on other sites
  • 0

If you want to use nameserver you need to adjust the settings correctly (bind-reload command).

And the customer domain still points to /var/www/html? Be sure, if your server has an IPv6 address you need to add it to froxlors up/port too and assign it to the domain

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, d00p said:

If you want to use nameserver you need to adjust the settings correctly (bind-reload command).

And the customer domain still points to /var/www/html? Be sure, if your server has an IPv6 address you need to add it to froxlors up/port too and assign it to the domain

Already tried, see http://m201-sj3-cloud.tk/ it points to /var/www/html my server is ipv4

Share this post


Link to post
Share on other sites
  • 0

So validate that the vhosts are being generated correctly (see /etc/apache2/sites-enabled/).

Also your domain seems to have an IPv6 address, so please be sure to check that again (2606:4700:30::681b:abe2)

Share this post


Link to post
Share on other sites
  • 0

Yeah wow....i would need to see the CONTENT of the files. And as said, you dont have ipv6 added in froxlor but your domain has an IPv6 A-Record....run an "ifconfig" on your server and check if you really do not have an ipv6 address, otherwise remove the AAAA record from the domains nameserver zone

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...