Jump to content
Froxlor Forum
  • 0
DavidCK

Error 503. Totally lost

Question

Hi Guys!

I started a fresh froxlor installation on Debian 9.5. Everything worked great until I finished the setup for the PHP-FPM. I got a 503 error in all the pages including the main panel website. I don't know where I can start looking for errors. I ran the cronjob code and I don't get any error. Apache is stopping, running, loading, and starting without errors. Does anyone can help me? 

*UPDATE*

I found this line: [information] apache::reload: fpm config directory "/etc/php/7.0/fpm/pool.d/" is empty. Creating dummy. after running the master cronjob command. Could it be related with the error? 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
8 minutes ago, davidoct14 said:

Hi d00p, how can I change the path if the web panel interface is not working?

either directly in the database (if you know what you are doing!!!) or you just delete the generated vhosts in /etc/apache2/sites-enabled/, re-enable mod_php and open froxlor via http://[ip-address]/froxlor like you did for the installation.

10 minutes ago, davidoct14 said:

I've looking for that file in /etc/php/7.0/ but the pool.d folder is empty. Do you know where can I find that file?

what file? The pool-config you mean? It's really hard to help if i have to ask for everything.

if you have activated fpm - there will be pool-configs generated for the domains. If php-fpm does not seem to work, the first thing you do is checking whether the daemon is running and if not, what the problem is. If the corresponding pool-config directory is empty you either did not activate fpm correctly or storing the poolconfigs in the wrong directory. 

Share this post


Link to post
Share on other sites
  • 0

I'd say you did not adjust your fpm config and thus the path where the pool configs are being generated is not the one needed.

Share this post


Link to post
Share on other sites
  • 0

What do You mean by "how do You make sure it's adjusted properly"? I'd say it works correctly if adjusted properly ... 

You as system admin should know what fpm version you've installed and tell froxlor about the correct path where the pool configs need to be stored. As I don't know your Systems, you need to give way more info then just "it's not working". Provide logs, Daemon status, steps you performed prior the error, etc.etc.etc. I don't have the time to guess all the time...

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, d00p said:

I'd say you did not adjust your fpm config and thus the path where the pool configs are being generated is not the one needed.

Hi d00p, how can I change the path if the web panel interface is not working? I've looking for that file in /etc/php/7.0/ but the pool.d folder is empty. Do you know where can I find that file?

Thanks. 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Pineo said:

Getting the 503 error as well. How do you make sure the fpm config is adjusted properly, d00p?

 Hi Pineo. Could run the master cronjob command adding --force --debug? copy the input here. Try stopping and starting apache2 or the web server that you are using looking for any error. If you provide these info it could be easier to help you. 

Regards,

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, d00p said:

It's really hard to help if i have to ask for everything.

hahaha. Thank you! It is working.

I used to have froxlor running on Ubuntu, so I got confused when I didn't error restarting apache2. 

Solution:

1) /etc/init.d/apache2 stop

2) a2dismod suexec proxy_fcgi actions

3) a2enmod php7.0

4) rm vhost located in /etc/apache2/sites-enabled/

5)/etc/init.d/apache2 start

6) Open your panel http(s)://(your ip)

7) Check settings. In my case (Use libnss-extrausers instead of libnss-mysql ) was unchecked.

8 ) Go to configuration and follow the config files webserver, cronjob, libnss-extrausers, and PHP-FPM

Regards,
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...