Jump to content
Froxlor Forum
  • 0
Jorge Merlino

Let's encrypt not working

Question

I enabled let's encrypt for one of my domains but can't get it to work. SSL in general is working with other certificates.

What I see is that the let's encrypt cronjob takes a very long time and never finishes successfully. This is what I see in froxlor_froxlor_master_cronjob-letsencrypt.lock:

Setting Lockfile to /var/run/froxlor_froxlor_master_cronjob-letsencrypt.lock-4413
Setting Froxlor installation path to /var/www/html/froxlor
Userdatas included
Table definitions included
Database-connection established
Previous cronjob didn't exit clean. PID: 3780
Removing lockfile: /var/run/froxlor_froxlor_master_cronjob-letsencrypt.lock-3780
Checking froxlor file permissions
Logger has been included
Froxlor version and database version are correct

It always says that the previous cronjob didn't exit clean.

How can I get more debug about this issue?

Thanks

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
php /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug

Also, did you configure apache after enabling Let's Encrypt? (Admin -> Configuration -> webserver). You need a /etc/apache2/conf-enabled/acme.conf (shown in the configuration steps)

Share this post


Link to post
Share on other sites
  • 0

try using ACMEv1 (froxlor settings) - it's more stable in froxlor imho

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...