Jump to content
Froxlor Forum
  • 0
karambeat

Ordner berechtigung

Question

Hey nochmals,

ich habe mal wieder eine Frage...

Ich habe nun einen Benutzer (Kunden) auf meinem Froxlor-System angelegt und will dort Wordpress installieren.

Hat alles soweit funktioniert, mein eigentliches Problem ist aber, dass ich nicht die Möglichkeit habe, Bilder per Wordpress auf den FTP hochzuladen. Muss ich dort irgendeine Berechtigung seitens Froxlor setzen?

Ich will das alles möglichst automatisiert funktioniert und ich nicht immer einzelt irgendwelche Berechtigungen vergebe. Ist das möglich? Habe auf Google jetzt nichts direktes dazu gefunden.

sDTGJ1C.png

 

Share this post


Link to post
Share on other sites

24 answers to this question

Recommended Posts

  • 0

Datenn gehören User "kunde123" - ich gehe davon aus du nutzt weder FCGID noch php-fpm, d.h. der Webserver und damit php läuft unter dem User "www-data". Froxlor setzt in der Benutzertabelle den User "www-data" als MItglied in die "kunde123" Gruppe, damit er Zugriff hat, damit er das allerdings aus der Datenbankauslesen kann, musst du libnss-mysql oder alternativ libnss-extrausers (muss explizit in den froxlor einstellungen aktiviert werden!) einrichten. Die Konfigurationstemplates dafür findest du unter der Kategorie "System / Sonstiges"

Share this post


Link to post
Share on other sites
  • 0

Habe libness-mysql installiert, wie genau muss ich vorgehen, damit das Bilder hochladen in Wordpress möglich wird?

Brauche das wirklich dringend. 😕

Wäre nett, wenn du mir das erklären könntest.

Share this post


Link to post
Share on other sites
  • 0

Ja nicht nur installieren auch konfigurieren....

8 hours ago, d00p said:

Die Konfigurationstemplates dafür findest du unter der Kategorie "System / Sonstiges"

 

Share this post


Link to post
Share on other sites
  • 0
vor 2 Minuten schrieb d00p:

Ja nicht nur installieren auch konfigurieren....

 

Hab ich ja gemacht, nur geändert hat sich nicht wirklich etwas. Muss ich sonst noch irgendwas machen?

Share this post


Link to post
Share on other sites
  • 0

Hey, das hat leider nicht wirklich funktioniert. 😕

Funktioniert das ganze nur bei neu angelegten Kunden oder auch bei den bereits angelegten Kunden?

Habe jetzt:

- Konfiguration durchgeführt: Debian Jessie (8) -> Sonstige (System) -> libness-mysql

- Webspace (Apache) neu gestartet

 

Ich starte mal den kompletten Server neu.

 

Share this post


Link to post
Share on other sites
  • 0

Das hilft nie xD ist doch kein Windows. Dann schau doch Mal ob bei dem befehl "id www-data" die Kunden da in seiner Gruppe auftauchen

Share this post


Link to post
Share on other sites
  • 0
vor 1 Minute schrieb d00p:

Das hilft nie xD ist doch kein Windows. Dann schau doch Mal ob bei dem befehl "id www-data" die Kunden da in seiner Gruppe auftauchen

Ahahaha

Ja, alle Kunden sind in der Liste gelistet.

Share this post


Link to post
Share on other sites
  • 0

Wie sind denn die Berechtigungen im Heimatordner des Kunden und in dem Upload Ordner?

Share this post


Link to post
Share on other sites
  • 0

Also wenn du auf der Shell nicht Mal Berechtigungen ablesen kannst bin ich nicht sicher ob das hier Sinn macht ...

Share this post


Link to post
Share on other sites
  • 0

Wie gesagt, bin leider nicht wirklich bewandert mit dem System... Hatte vor paar Jahren mal aktiv mit Linux gearbeitet, aber da ist nicht wirklich viel hängen geblieben.

Soweit ich weiß, wurde da nichts großartig geändert. Also nur lesen, ausführen, ...

Brauche das unbedingt, mein eigentlicher Servertechniker ist derzeit nicht da.

Kann ich die Berechtigungen für alle neuen Benutzer ändern? Also jeden neuen den ich über Froxlor anlege?

Share this post


Link to post
Share on other sites
  • 0

Du brauchst nen sysadmin ;) ein einfaches "ls -la" aufs homedir des Kunden und den Upload Ordner und dann hier Posten...ist schwer zu helfen wenn man alle Infos aus der Nase ziehen muss

Share this post


Link to post
Share on other sites
  • 0

Tut mir wirklich Leid, wäre aber trotzdem nett, wenn du mir eben kurz helfen könntest. 😕


total 224
drwxr-xr-x  6 becker becker  4096 Nov 14 23:34 .
drwxr-xr-x  4 root   root    4096 Nov 13 20:39 ..
-rwxr-xr-x  1 becker becker    14 Nov 14 23:36 .ftpquota
-rwxr-xr-x  1 becker becker   418 Nov 14 23:31 index.php
-rwxr-xr-x  1 becker becker 19550 Nov 14 23:31 license.txt
-rwxr-xr-x  1 becker becker  8729 Nov 14 23:31 liesmich.html
-rwxr-xr-x  1 becker becker  7415 Nov 14 23:31 readme.html
drwxr-xr-x  2 becker becker  4096 Nov 15 00:00 webalizer
-rwxr-xr-x  1 becker becker  5458 Nov 14 23:31 wp-activate.php
drwxr-xr-x  9 becker becker  4096 Nov 14 23:31 wp-admin
-rwxr-xr-x  1 becker becker   364 Nov 14 23:31 wp-blog-header.php
-rwxr-xr-x  1 becker becker  1889 Nov 14 23:31 wp-comments-post.php
-rwxr-xr-x  1 becker becker  3837 Nov 14 23:34 wp-config.php
-rwxr-xr-x  1 becker becker  3636 Nov 14 23:31 wp-config-sample.php
drwxr-xr-x  6 becker becker  4096 Nov 14 23:44 wp-content
-rwxr-xr-x  1 becker becker  3669 Nov 14 23:31 wp-cron.php
drwxr-xr-x 18 becker becker 12288 Nov 14 23:32 wp-includes
-rwxr-xr-x  1 becker becker  2422 Nov 14 23:31 wp-links-opml.php
-rwxr-xr-x  1 becker becker  3306 Nov 14 23:31 wp-load.php
-rwxr-xr-x  1 becker becker 37794 Nov 14 23:31 wp-login.php
-rwxr-xr-x  1 becker becker  8048 Nov 14 23:31 wp-mail.php
-rwxr-xr-x  1 becker becker 16246 Nov 14 23:31 wp-settings.php
-rwxr-xr-x  1 becker becker 30091 Nov 14 23:31 wp-signup.php
-rwxr-xr-x  1 becker becker  4620 Nov 14 23:31 wp-trackback.php
-rwxr-xr-x  1 becker becker  3065 Nov 14 23:31 xmlrpc.php

 

Und hier der wp-content Ordner:

 total 28
drwxr-xr-x 6 becker becker 4096 Nov 14 23:44 .
drwxr-xr-x 6 becker becker 4096 Nov 14 23:34 ..
-rwxr-xr-x 1 becker becker   28 Nov 14 23:31 index.php
drwxr-xr-x 4 becker becker 4096 Nov 14 23:31 languages
drwxr-xr-x 3 becker becker 4096 Nov 14 23:31 plugins
drwxr-xr-x 7 becker becker 4096 Nov 14 23:36 themes
drwxr-xr-x 2 becker becker 4096 Nov 14 23:36 upgrade

 

Share this post


Link to post
Share on other sites
  • 0

Ich weiß nicht obs daran liegt, aber Apache lässt sich jetzt nicht mehr restarten. 😕

systemctl status apache2.service
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─forking.conf
   Active: failed (Result: exit-code) since Thu 2018-11-15 20:24:00 CET; 2min 46s ago
  Process: 9347 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
  Process: 8971 ExecReload=/etc/init.d/apache2 reload (code=exited, status=1/FAILURE)
  Process: 9420 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Nov 15 20:24:00 Debian-810-jessie-64-minimal apache2[9420]: Starting web server: apache2 failed!
Nov 15 20:24:00 Debian-810-jessie-64-minimal apache2[9420]: The apache2 configtest failed. ... (warning).
Nov 15 20:24:00 Debian-810-jessie-64-minimal apache2[9420]: Output of config test was:
Nov 15 20:24:00 Debian-810-jessie-64-minimal apache2[9420]: AH00526: Syntax error on line 5 of /etc/apache2/sites-enable...onf:
Nov 15 20:24:00 Debian-810-jessie-64-minimal apache2[9420]: Invalid command 'SSLStaplingCache', perhaps misspelled or de...tion
Nov 15 20:24:00 Debian-810-jessie-64-minimal apache2[9420]: Action 'configtest' failed.
Nov 15 20:24:00 Debian-810-jessie-64-minimal apache2[9420]: The Apache error log may have more information.
Nov 15 20:24:00 Debian-810-jessie-64-minimal systemd[1]: apache2.service: control process exited, code=exited status=1
Nov 15 20:24:00 Debian-810-jessie-64-minimal systemd[1]: Failed to start LSB: Apache2 web server.
Nov 15 20:24:00 Debian-810-jessie-64-minimal systemd[1]: Unit apache2.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.


Schaue mal eben nach

Share this post


Link to post
Share on other sites
  • 0

Nov 15 21:01:06 Debian-810-jessie-64-minimal apache2[9813]: Starting web server: apache2 failed!
Nov 15 21:01:06 Debian-810-jessie-64-minimal apache2[9813]: The apache2 configtest failed. ... (warning).
Nov 15 21:01:06 Debian-810-jessie-64-minimal apache2[9813]: Output of config test was:
Nov 15 21:01:06 Debian-810-jessie-64-minimal apache2[9813]: AH00526: Syntax error on line 5 of /etc/apache2/sites-enabled/03_froxlor_ocsp_cache.conf:
Nov 15 21:01:06 Debian-810-jessie-64-minimal apache2[9813]: Invalid command 'SSLStaplingCache', perhaps misspelled or defined by a module not included in t
Nov 15 21:01:06 Debian-810-jessie-64-minimal apache2[9813]: Action 'configtest' failed.
Nov 15 21:01:06 Debian-810-jessie-64-minimal apache2[9813]: The Apache error log may have more information.
Nov 15 21:01:06 Debian-810-jessie-64-minimal systemd[1]: apache2.service: control process exited, code=exited status=1
Nov 15 21:01:06 Debian-810-jessie-64-minimal systemd[1]: Failed to start LSB: Apache2 web server.

Was soll ich mit der Datei "/etc/apache2/sites-enabled/03_froxlor_ocsp_cache.conf" machen? :I

 

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, karambeat said:

apache2[9813]: Invalid command 'SSLStaplingCache', perhaps misspelled or defined by a module not included in t

Darum ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...