Jump to content
Froxlor Forum
  • 0

Deutsche Anleitung für SSL einrichten in Froxlor


Question

Guten Morgen , ich habe heute früh die deutsche Anleitung für SSL herunterladen wollen und bekomme immer nur ein File mit 0 Bytes herunter.

Ich beötige sie da ich Vorgestern auf https umgestellt habe aber jetzt keinen Zugriff mehr auf Froxlor oder phpmyadmin besitze.

Könnte ich diese Anleitung nochmal bekommen ?

mit freundlichem Gruß

Th.J

Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0

Ihr habt mal in einem anderen Beitrag hier die deutsche Anleitung als PDF Link gegeben und den wollte ich jetzt aufrufen . bekomme zwar den Download aber er ist 0 Bytes gross und lässt sich klarerweise dann auch nicht mit nem PDF Programm öffnen..

 

Wenn ich versuche auf https://v22017084876852623.supersrv.de/froxlor/

zu gehen bekomme ich nur einen Seitenladefehler . Verbindung fehlgeschlagen.

kann aber auch nicht die Das selbe passiert mit PHPmyAdmin ..

Vielleicht habe ich ja in der config was übersehen oder nicht gemacht . daher wollte ich mal die deutsche Anleitung haben..

und das ist der Link zu der Antleitung :

https://forum.froxlor.org/applications/core/interface/file/attachment.php?id=163

von diesem Topic :

 

Link to post
Share on other sites
  • 0

Vielen Dank . Leider komme ich noch nicht weiter.

Ich habe bisher alles versucht aber wenn ich versuche meine Seite für Froxlor aufzurufen geht er sofort auf https:// was ja erstmal gut ist , aber ich bekomme nur einen Seitenlade Fehler. Ich werde weiterhin versuchen mein Problem zu lösen . Sollte ich es geschafft haben dann melde ich mich gerne wieder ..

 

Link to post
Share on other sites
  • 0

dann hast du wohl einen ssl-redirect eingerichtet und/oder hsts werte > 0 gesetzt, dann will dein browser immer auf die sichere seite wenn er die kennt.

Was sagt denn der Seitenladefehler? Was steht in der error-log des Webservers?

Link to post
Share on other sites
  • 0


Diesen Fehler bekomme ich zu sehen wenn ich apachectl -t mache:

 

AH00526: Syntax error on line 1 of /etc/apache2/mods-enabled/ssl.conf:
Invalid command 'SSLStaplingCache', perhaps misspelled or defined by a module not included in the server configuration

 

Nehme ich das SSLStaplingCache per hand aus der conf raus , dann startet der apache zwar aber ich komme immer noch nicht auf Froxlor oder auf den phpmyadmin.

 

Das gibt mir a2emod ssl raus:

 

Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
ERROR: Config file ssl.conf not properly enabled: /etc/apache2/mods-enabled/ssl.conf is a real file, not touching it

 

Link to post
Share on other sites
  • 0

Welches OS, welche apache version? welche openssl version? -> Compatibility:    Available if using OpenSSL 0.9.8h or later

3 minutes ago, Tomjac said:

ERROR: Config file ssl.conf not properly enabled: /etc/apache2/mods-enabled/ssl.conf is a real file, not touching it

Hast du da etwa schon manuell rumgefummelt? :P Die Modul-Configs liegen alle in "mods-available" und werden via a2enmod / a2dismod entsprechend via symlink nach mods-enabled geleitet...der fehler sagt aber das die ssl.conf in der mods-enabled kein symlink ist. 

Link to post
Share on other sites
  • 0

Apache 2

Server version: Apache/2.4.29 (Debian)
Server built:   2018-01-14T11:01:58

Debian 8 Jessie

und ich habe nur in dem 03_froxlor_ocsp_cache.conf die # vor dem SSL gemacht und auch bei der ssl.conf. Damit startet zwar der Apache wie gesagt. Aber ist ja nicht die Lösung ^^

 

Und liegen immer noch mods-aviable , da habe ich nur die ssl.conf wie gesagt bearbeitet nachdem der apache mit der fehlermeldung nicht mehr starten wollte.

 

 

Link to post
Share on other sites
  • 0
3 minutes ago, Tomjac said:

und ich habe nur in dem 03_froxlor_ocsp_cache.conf die # vor dem SSL gemacht und auch bei der ssl.conf. Damit startet zwar der Apache wie gesagt. Aber ist ja nicht die Lösung ^^

Ne, das ist nicht sinn der sache, vorallem werden die configs ja wieder neu generiert :)

3 minutes ago, Tomjac said:

Und liegen immer noch mods-aviable , da habe ich nur die ssl.conf wie gesagt bearbeitet nachdem der apache mit der fehlermeldung nicht mehr starten wollte.

Eh, wie "und liegen immer noch [in] mods-available"? Lässt du etwa die vhosts von froxlor dort hin generieren? Die gehören nach sites-enabled

Link to post
Share on other sites
  • 0

entschuldigung , ich habe mich vertan ^^ Liegen im sites-enabled..

Also vielleicht nochmal von vorne , alles lief bis ich dann das let encrypt zertifikat hatte und das auch im Froxlor eingetragen ist.

Ich wollte dieses Zertifikat automatisch erstellen lassen das funktionierte nicht also bin ich hingegangen und habe das zetifikat

per Hand erstellen lassen und habe den Pfad angegeben . Das ging dann auch erstmal .

mittels expand auf eine weitere domain zufügen wollen.Und damit hatt es dann quasi angefangen , ich habe lediglich die confs bearbeitet damit er den apache wieder hoch fährt. An sonstigen Einstellungen habe ich nichts gemacht.

Kann man denn vielleicht alles erstmal SSL wieder ausschalten sodass ich erstmal wieder auf das Froxlor komme ?

Link to post
Share on other sites
  • 0
14 minutes ago, Tomjac said:

Ich wollte dieses Zertifikat automatisch erstellen lassen das funktionierte nicht also bin ich hingegangen und habe das zetifikat

per Hand erstellen lassen und habe den Pfad angegeben . Das ging dann auch erstmal .

hässlich hässlich...ich hät ja vllt eher mal geschaut warum es nicht funktioniert...(self-check deaktivieren, manche kisten mögen das nicht)

15 minutes ago, Tomjac said:

mittels expand auf eine weitere domain zufügen wollen.Und damit hatt es dann quasi angefangen , ich habe lediglich die confs bearbeitet damit er den apache wieder hoch fährt. An sonstigen Einstellungen habe ich nichts gemacht.

Expand? das klingt nich nach irgendwas von froxlor..

 

16 minutes ago, Tomjac said:

Kann man denn vielleicht alles erstmal SSL wieder ausschalten sodass ich erstmal wieder auf das Froxlor komme ?

rm apache2/sites-enabled/* , apache restart und dann http://ip/froxlor - WENN alles standard ist.

Link to post
Share on other sites
  • 0

Ich habe doch nochmal ne Frage : Ich komme jetzt auf alles drauf nur auf Froxlor noch nicht , dort schaltet er auch wenn ich http://IP/froxlor eingebe autuomaitsch https:// vor , wo muss ich das einstellen bzw. heraus nehmen damit ich wieder zugreifen kann ?

Fehlt mir vielleicht noch eine conf datei für das froxlor im sites-enabled ?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...