Jump to content
Froxlor Forum
  • 0
luke0

LetsEncrypt

Question

Hallo,

 

ich habe vorhin Froxlor auf die neuste Version geupdatet. Nun wollte ich LetsEncrypt ausprobieren.

Ich habe es aktiviert, die Konfigurationsdatei angelegt, Apache2 neugestartet, den Cron ausgeführt und IP:443 & Alias www eingestellt.

Nun bekomme ich von Google Chrome einen ERR_SSL_PROTOCOL_ERROR.

Der Apache Error Log sagt folgendes:

 

 

[warn] RSA Server certificate CommonName (CN) `domain.tld`  does NOT match Server Name!?
- (Das Zertifikat wurde von Froxlor erstellt, über die Option Benutze Let's Encrypt; Habe meine domain mit domain.tld ersetzt)

Außerdem kommt folgende Meldung:
[error] [client MEINE_IP] Invalid method in request \x16\x03\x01
- Habe bereits danach gegoogelt und auch einiges (aber nichts was mir hilft) gefunden.
 
Wie kann ich dies lösen?
Werden weitere Dateien (vHost,...), Ausschnitte o.a. benötigt? 
 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hast du denn auch ein Zertifikat für die IP/Port Vhost-Config? Das brauchst du nämlich. Einfach irgendein self-signed cert erstellen.

Share this post


Link to post
Share on other sites
  • 0

// private key und csr erstellen

openssl req -new -newkey rsa:4096 -nodes -sha256 -out server-name.csr -keyout server-name.key

 

// selbst-signiertes cert erstellen

openssl x509 -req -days 3650 -in server-name.csr -signkey server-name.key -out server-name.crt

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...