Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Picco1337

Mailserver Problem

Question

Hallo Liebe Froxlor Gemeinde,

 

Ich habe den Mailserver Postfix/Courier nach Anleitung installiert und habe keinerlei Fehlermeldung bekommen. Dann habe ich im Froxlor eine Mailadresse eingerichtet und auch kein Fehler bekommen. Nun habe ich die Mailadresse in thunderbird eingerichtet und bekomme die Fehlermeldung chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/ failed gibt es daf?r eine L?sung? 

Share this post


Link to post
Share on other sites

Recommended Posts

Schau bitte mal was in den Fehlerlogs des Servers so steht

Share this post


Link to post
Share on other sites

/var/log/mail* und ja - aber bitte nicht komplett...das ist etwas viel. Du wirst denke ich schon sehen, welche Zeilen relevant sind, wenn sie mit [error] o.?. markiert sind

Share this post


Link to post
Share on other sites

Jun 29 06:31:46 Debian-75-wheezy-64-minimal postfix/pickup[8750]: fatal: file /etc/postfix/main.cf: parameter myhostname: bad parameter value: mail.hjk Server
Jun 29 06:31:47 Debian-75-wheezy-64-minimal postfix/master[8413]: warning: process /usr/lib/postfix/pickup pid 8750 exit status 1
Jun 29 06:31:47 Debian-75-wheezy-64-minimal postfix/master[8413]: warning: /usr/lib/postfix/pickup: bad command startup -- throttling
Jun 29 06:32:47 Debian-75-wheezy-64-minimal postfix/pickup[8781]: warning: valid_hostname: invalid character 32(decimal): mail.hjk Server

 

Die Fehlermeldung ist darin immer wieder zu lesen.

 

Und nur von 29.06 kein aktuelles Datum enthalten

Share this post


Link to post
Share on other sites

also das sieht doch eindeutig aus. was sagt denn

grep "myhostname" /etc/postfix/main.cf

Share this post


Link to post
Share on other sites

Das sieht auch eindeutig aus aber wo kann ich den Hostname ?ndern?

 

# The myhostname parameter specifies the internet hostname of this
# from gethostname(). $myhostname is used as a default value for many
# Froxlor Note: $myhostname can and should be the same as $mydomain as long as
# for the case of a subdomain, $mydomain *must* be equal to $myhostname,
myhostname = mail.$mydomain
#myhostname = virtual.domain.tld
# The default is to use $myhostname minus the first component.
# mail appears to come from. The default is to append $myhostname,
#myorigin = $myhostname
#inet_interfaces = $myhostname
#inet_interfaces = $myhostname, localhost
# The default is $myhostname + localhost.$mydomain.  On a mail domain
#mydestination = $myhostname, localhost.$mydomain, localhost
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
#mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
# You MUST specify $myhostname at the start of the text. That is an
#smtpd_banner = $myhostname ESMTP $mail_name
#smtpd_banner = $myhostname ESMTP $mail_name ($mail_version)
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_sasl_local_domain = $myhostname

Share this post


Link to post
Share on other sites

myhostname = mail.$mydomain

 

Dann hau gleich ein 

grep "mydomain" /etc/postfix/main.cf

hinterher....ich habe die vermutung du hast dort keine echte domain angegeben

Share this post


Link to post
Share on other sites

# Froxlor Note: $myhostname can and should be the same as $mydomain as long as
# for the case of a subdomain, $mydomain *must* be equal to $myhostname,
# also check the note about $mydomain below.
myhostname = mail.$mydomain
# The mydomain parameter specifies the local internet domain name.
# $mydomain is used as a default value for many other configuration
mydomain = hjk Server
# machines, you should (1) change this to $mydomain and (2) set up
#myorigin = $mydomain
# The default is $myhostname + localhost.$mydomain.  On a mail domain
# gateway, you should also include $mydomain.
#mydestination = $myhostname, localhost.$mydomain, localhost
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
#mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
#       mail.$mydomain, www.$mydomain, ftp.$mydomain
#relayhost = $mydomain
append_dot_mydomain = no

Share this post


Link to post
Share on other sites

kann ich bei mydomain auch die IP vom Server rein? oder muss da ne domain rein? Weil ich will mehrere Mailadressen mit verschiedenen Domains einrichten.

Share this post


Link to post
Share on other sites

mydomain = hjk Server

 

Das ist KEINE Domain....das kann nicht funktionieren. Da muss eine ECHTE Domain rein, z.B. "deine-domain.de" - was anderes ist Unsinn und wird nicht wirklich funktionieren. Au?erdem wird auch dein Froxlor nicht funktionieren wenn du dort als Hostname "hjk Server" hinterlegt hast (was glaube ich gar nicht gehen sollte, aber egal).

 

Du brauchst schon einen FQDN....

Share this post


Link to post
Share on other sites

Mein Froxlor lauf unter ip/froxlor und ich m?chte halt mehrere Email Adressen auf verschiedenen Domains nutzen kann ich also bei mydomain auch die IP vom Server eintragen?

Share this post


Link to post
Share on other sites

...nat?rlich geht das, sonst w?re froxlor recht sinnfrei, denkst du nicht auch?

 

Das eine ist deine SERVER-DOMAIN, bzw. HAUPT-DOMAIN f?r den Mailserver. Das andere sind KUNDEN-Domain/E-Mail Adressen. Das sind zwei paar Schuhe...

Share this post


Link to post
Share on other sites

Bin ich auch drauf gekommen nachdem ich dein Beitrag gelesen habe :)

Leider gibt mein Thunderbird immernoch den Fehler an

 

chdir hjkratingen/hausmakler-ratingen.de/test/Maildir failed

Der Ordner Exitiert auch garnicht er kann da garnicht reinwechseln.

Share this post


Link to post
Share on other sites

Nat?rlich existiert der Ordner nicht, der wird ja auch erst angelegt, wenn eine E-Mail an das Konto geschickt wird. Das macht normal Froxlor f?r dich, da du aber keinen funktionierenden SMTP (postfix) hattest, konnte das nat?rlich nicht passieren.

Share this post


Link to post
Share on other sites

Ich habe beim den Postfix mit richtiger Domain nun mal Restartet

Bin in Froxlor gegangen zu dem Kunden und wollte ne neue Mail einrichten

Dann kommt Fehlermeldung Das versenden der Nachricht an test@hausmakler-ratingen.de schlug fehl

Share this post


Link to post
Share on other sites

Edit: dann schau bitte in die Logs wo das Problem jetzt liegt.

Share this post


Link to post
Share on other sites

Jul  3 13:16:18 Debian-75-wheezy-64-minimal postfix/master[374]: daemon started -- version 2.9.6, configuration /etc/postfix
Jul  3 13:16:54 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:16:57 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory
Jul  3 13:19:44 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:19:50 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory
Jul  3 13:23:57 Debian-75-wheezy-64-minimal postfix/master[374]: terminating on signal 15
Jul  3 13:24:03 Debian-75-wheezy-64-minimal postfix/master[747]: daemon started -- version 2.9.6, configuration /etc/postfix
Jul  3 13:24:11 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:24:13 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory
Jul  3 13:26:35 Debian-75-wheezy-64-minimal authdaemond: stopping authdaemond children
Jul  3 13:26:35 Debian-75-wheezy-64-minimal authdaemond: modules="authmysql", daemons=5
Jul  3 13:26:35 Debian-75-wheezy-64-minimal authdaemond: Installing libauthmysql
Jul  3 13:26:35 Debian-75-wheezy-64-minimal authdaemond: Installation complete: authmysql
Jul  3 13:26:52 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:26:52 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory
Jul  3 13:26:55 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:26:58 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory
Jul  3 13:28:08 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:28:08 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory
Jul  3 13:28:47 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:28:47 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory
Jul  3 13:30:08 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:30:08 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory
Jul  3 13:32:43 Debian-75-wheezy-64-minimal pop3d: Connection, ip=[::ffff:93.192.98.79]
Jul  3 13:32:43 Debian-75-wheezy-64-minimal pop3d: chdir hjkratingen/hausmakler-ratingen.de/test/Maildir/: No such file or directory

Share this post


Link to post
Share on other sites

das sind nur courier-logs...wo sind die eintr?ge von Postfix? Welche logdatei nimmst du da immer? Hast du die Services auch so eingerichtet wie Froxlor es in "Konfiguration" vorgibt?

Share this post


Link to post
Share on other sites

Naja, kann ja nicht sein, dass da gar nichts von Postfix drinsteht. Nopaste bitte mal die ganze log via pastebin.com oder so

Share this post


Link to post
Share on other sites

Das passiert wenn ich den Postfix restarte:

 

Stopping Postfix Mail Transport Agent: postfix/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
.
Starting Postfix Mail Transport Agent: postfixpostconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=

Share this post


Link to post
Share on other sites





×
×
  • Create New...