Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
bumskoeter

[solved] E-Mail Benutzer f?r die Hostdomain erstellen

Question

Hallo,

 

wie kann ich einen Mail Benutzer f?r die Hostdomain erstellen? Mein OS: Debian 7. Ich habe einen Webmailer. Mails k?nnen erfolgreich verschickt/empfangen werden.

 

Mit freundlichen Gr??en

bumskoeter

Share this post


Link to post
Share on other sites

Recommended Posts

Direkt nicht. Wenn du f?r Froxlor eine subdomain der domain nutzt f?ge dich einfach selbst als Kunde ein. Ansonsten geht das nicht

Share this post


Link to post
Share on other sites

Das ist mir klar. Ich habe es in den "System"-Einstellungen ge?ndert. Leider kann ich meine ganze Webseite nicht mehr aufrufen. Es erscheint ein "403" Error.

Share this post


Link to post
Share on other sites

Was genau hast du wo eingetragen? Zeigt der DNS auch komplett auf den Server?

Share this post


Link to post
Share on other sites

Ja, die DNS meiner Webseite zeigt komplett auf den Server. Ich habe dies in den "Systemeinstellungen" eingetragen. Den Server habe ich nun neu installiert. Dann muss ich nur noch die Froxlor-URL um?ndern.

Share this post


Link to post
Share on other sites

 

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

 

 Ich hoffe, dass ich die richtige vHost rausgesucht habe. Ich glaube, dass es die falschen sind.

Share this post


Link to post
Share on other sites

Exakt. Das ist keine von Froxlor erstellte... Lief denn der cronjob ?berhaupt schon?

Share this post


Link to post
Share on other sites

Jain. Ich musste Cronjob mit dem Befehl manuell starten:

php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Welche vHost-Datei brauchst Du?

Share this post


Link to post
Share on other sites

Da ist der Ausschnitt der 10_froxlor_ipandport_127.0.0.1.conf:

# 10_froxlor_ipandport_127.0.0.1.conf
# Created 08.06.2014 23:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

NameVirtualHost 127.0.0.1:80
<VirtualHost 127.0.0.1:80>
DocumentRoot "/var/www/"
 ServerName website.de
</VirtualHost>

 

 

Muss ich den ServerName in dieser .conf-Datei ?ndern?

Share this post


Link to post
Share on other sites

127.0.0.1 funktioniert nicht...das ist ja nur localhost...nimm die echte externe server-ip

Share this post


Link to post
Share on other sites

Ahja, kann ich doch nicht riechen...sowas musst mir sagen oder eine IP einfach durch xxx.xxx.xxx.xxx verschleihern. Wenn da 127.0.0.1 steht denk ich du hast das da eingetragen.

 

Ich dachte du wolltest statt website.de aber eine subdoman nutzen wie froxlor.website.de - darum gings doch - hast du das nicht in den Einstellungen angepasst? Lief nach der ?nderung auch der Cronjob? Wenn du schon sagst, du musst den manuell anschubsen, hast du denn die Services nicht korrekt eingerichtet nach der Installation?

Share this post


Link to post
Share on other sites

Den Server hatte ich doch neu installiert. Das sagte ich bereits. Den Server habe ich nach der Froxlor-Konfigurationanleitung entsprechend eingerichtet.

Share this post


Link to post
Share on other sites

Und deswegen steht auch in der Vhost immernoch "ServerName website.de" obwohl du doch "irgendwas.website.de" nutzen wolltest als Froxlor Hostname? Jetzt lass dir doch bitte nicht alles so aus der Nase ziehen, sonst zieht sich das hier noch Stunden...

Share this post


Link to post
Share on other sites

Genau. Ich habe es so belassen, weil ich das doch schon in der Froxlor-Konfiguration so eingestellt hatte. Daraufhin konnte ich meine ganze Webseite nichtmehr aufrufen.

Share this post


Link to post
Share on other sites

Was ist "deine ganze Website"? Meinst du Froxlor selbst? Oder eine Kunden-Website? Meinst du die "website.de" die du als Froxlor-Hostname angegeben hast? Was denn nu genau?! Mit dem bisschen was du immer sagst kann man kaum was anfangen...

Share this post


Link to post
Share on other sites

Nein das ist nicht klar. Und "website.de" hast du doch als Froxlor Hostname eingerichtet - da liegt NUR froxlor. Was glaubst du warum ich dir gesagt habe, benutze als Froxlor Hostname eine SUBDOMAIN der "website.de" und lege dich dann selbst als Kunden an, so kannst du website.de als deine Website weiterhin normal nutzen, sogar mit E-Mail adressen usw.

Share this post


Link to post
Share on other sites

Genau. Das habe ich in den Froxlor-Systemeinstellungen gemacht, dann kam der Fehler. In die vorhin gepostete .conf-Datei muss ich "SUBDOMAIN.website.de" durch "website.de" ersetzten, dann ist auch Froxlor unter der Subdomain erreichbar? Das hei?t f?r mich, dass meine vollst?ndige Webseite dann unter "SUBDOMAIN.website.de" erreichbar ist.

Share this post


Link to post
Share on other sites

Nein du sollst in den Vhost-Configs gar nichts manuell ?ndern...was glaubst du wieso du es in den Einstellungen anpassen kannst?! Und ich glaube auch du verstehst das Prinzip nicht:

 

SUBDOMAIN.website.de => Froxlor 

website.de => Kunde => deine vollst?ndige Website

Share this post


Link to post
Share on other sites

Einstellungen -> System-Einstellungen -> Hostname, optional w?rde ich in dem Fall auch die Option "Froxlor direkt ?ber den Hostnamen erreichbar machen" aktivieren.

Share this post


Link to post
Share on other sites

×
×
  • Create New...