Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
WebCF

[solved] [0.9.32 | Wheezy 7.5] PHP-FPM: No pool defined

Question

Hi :)

 

Some infos:

* Debian 7.5
* Froxlor 0.9.32 (yay!)
* Apache2 2.2.22-13
* PHP5 [FPM] 5.4.4-14

I've reinstalled my server today [Debian 7.5, amd64] with Froxlor 0.9.32 (Tarball installation).

So far so good - I having problems with the setup of PHP-FPM...

 

Panel settings are set (FPM enabled), I've leaved the fpm- (path) settings untouched.

 

The first thing I've noticed: After "a2dismod php5" there is a "/etc/init.d/apache2 restart" missing (right?). I did it anyway. While trying to access froxlor again: 500 - Internal server error

 

php5-fpm.log:

[23-May-2014 21:37:53] ERROR: No pool defined. at least one pool section must be specified in config file
[23-May-2014 21:37:53] ERROR: failed to post process the configuration
[23-May-2014 21:37:53] ERROR: FPM initialization failed

Whoops...

 

Then I've started some research...

 

The cronjob created a file @ /etc/php-fpm.d. BUT /etc/php5/fpm/php-fpm.conf say, that the pool is /etc/php5/fpm/pool.d/*.conf and not /etc/php-fpm.d/ (which does not exist as of the latest php5-fpm package) as the defaults are saying that.

 

Another thing is the default value for the FPM init.d script: default value points to /etc/init.d/php-fpm which not exist. php5-fpm would be right.

 

However, I did some magic:

cp /etc/php-fpm.d/myhost.conf /etc/php5/fpm/pool.d/
/etc/init.d/php5-fpm restart
# and I set the new path for the restart script in phpfpm.reload in panel_settings. Same for the configdir.

And: It's working again!

 

So, it seems, that the default values for PHP-FPM for Wheezy are not valid anymore..?

 

If I forgot something while config, please say it :D

 

EDIT: Damn. You already know, that the default value is /etc/php-fpm.d/... -> http://forum.froxlor.org/index.php/topic/12474-solved-500-error-beim-froxlor-panel/?p=25897

I forgot, that the Panel settings are not adjusted while adapting all the configs - right... So, Am I right with the assumption that this value needs to be adjusted for every Debian environment? If yes, a hint in the configuration assistant would be awesome :)

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

EDIT: Damn. You already know, that the default value is /etc/php-fpm.d/... -> http://forum.froxlor.org/index.php/topic/12474-solved-500-error-beim-froxlor-panel/?p=25897

I forgot, that the Panel settings are not adjusted while adapting all the configs - right... So, Am I right with the assumption that this value needs to be adjusted for every Debian environment? If yes, a hint in the configuration assistant would be awesome :)

 

Well, adjusting or at least CHECKING your settings according to your needs is something we assume every admin does after install/update

Share this post


Link to post
Share on other sites

×
×
  • Create New...