Jump to content
Froxlor Forum
  • 0

SSL Zertifikat


hmurauer

Question

Hallo,

 

ich suche mir schon die Finger wund im Netz und ich finde keine L?sung f?r mein Problem.

 

M?chte gerne meine Subdomain mit einem Zertifikat versehen,

jedoch mach mir Froxlor das nicht.

 

Mein System: Debian 7 > CGI/FastCGI > Froxlor: 0.9.31.2-1

 

Ich habe 3 Daten:

 

domain.crt.txt

domain.pkey.txt

PostivesSSLCA2.crt

 

Bei der Einrichtung bin ich so vorgegangen:

 

Habe unter Einstellungen > SSL auf JA gesetzt.

 

Dann unter IP & Ports:

> Die IP vom Server 1.1.1.1:80, nochmal angelegt mit 1.1.1.1:443 | H?ckchen rein bei NameVirtualHost.

 

Bei der Hauptdomain habe ich die SSL IP (1.1.1.1:443) mit einen H?ckchen versehen (SSL Weiterleitung habe ich nicht aktiviert)

 

Dann habe ich noch bei der Subdomain, wo das Zertifikat auch funktionieren soll: cp.domain.tld

> Da habe ich auf die Weltkugel geklickt > und habe dann 4 Felder vor mir.

 

Feld1: domain.crt.txt

Feld2: domain.pkey.txt

Feld3: NICHTS

Feld4:

PostivesSSLCA2.crt

 

habe da jeweils den Inhalt rein kopiert.

 

nach ca. 1 Stunde warten klappt es noch immer nicht, das ich via https://cp.domain.ltd zugreifen kann.

 

Was mache ich das Falsch, bzw. was habe ich falsch gemacht?

 

Lg

 

 

Link to post
Share on other sites

16 answers to this question

Recommended Posts

Wurde bei der Port 443 IP auch SSL-IP=Ja aktiviert? Nicht nur h?kchen bei "NameVirtualHost"...

 

Wenn du willst, dass das Zertifikat bei der Hauptdomain UND der subdomain domain funktioniert, spezifiziere es nur in der Hauptdomain.

 

Du musst doch auch keine Stunde warten, um nachzuschauen, ob die entsprechende Config von Froxlor erstellt wurde?!

Link to post
Share on other sites

Das klingt doch schonmal gut. Dann stelle doch jetzt mal sicher, ob der Cronjob lief und die entsprechenden vhost-configs und ssl-dateien an den von dir eingestellten Ordnern erstellt wurden.

Link to post
Share on other sites

Hatte auch den Server schon mal neu gestartet das sich die Daten neu laden.

 

Cronjob lief

 

SSL Dateien sind vorhanden unter /etc/ssl/froxlor-custom | domain.crt | domain.key | domain_CA.pem

 

 

20_froxlor_ssl_vhost_DOMAIN.conf:

 

<VirtualHost IPADRESSE:443>
  ServerName xxxx.xx
  ServerAdmin hm@xxxx.xx
  SSLEngine On
  SSLHonorCipherOrder On
  SSLCipherSuite ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH
  SSLVerifyDepth 10
  SSLCertificateFile /etc/ssl/froxlor-custom/xxxx.xx.crt
  SSLCertificateKeyFile /etc/ssl/froxlor-custom/xxxx.xx.key
  SSLCACertificateFile /etc/ssl/froxlor-custom/xxxx.xx_CA.pem
  DocumentRoot "/var/customers/webs/BENUTZER/xxxx.xx/"
  FcgidIdleTimeout 30
  SuexecUserGroup "hmurauer" "hmurauer"
  <Directory "/var/customers/webs/hmurauer/xxxx.xx/">
    <FilesMatch "\.(php)$">
      SetHandler fcgid-script
      FcgidWrapper /var/www/php-fcgi-scripts/hmurauer/xxxx.xx/php-fcgi-starter .php
      Options +ExecCGI
    </FilesMatch>
    Order allow,deny
    allow from all
  </Directory>
  Alias /webalizer "/var/customers/webs/hmurauer/webalizer"
  ErrorLog "/var/customers/logs/hmurauer-error.log"
  CustomLog "/var/customers/logs/hmurauer-access.log" combined
</VirtualHost>

 

und bei: 10_froxlor_ipandport_IPADRESSE.conf

 

steht nur das drinnen:

 

NameVirtualHost IPADRESSE:443

Link to post
Share on other sites

Habe ich aktiviert, nun erhalte ich das da:

 

[....] Restarting web server: apache2[sat Jan 04 17:51:34 2014] [warn] NameVirtualHost IPADRESSE:443 has no VirtualHosts
[sat Jan 04 17:51:34 2014] [warn] NameVirtualHost IPADRESSE:443 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address IPADRESSE:443
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
 failed!
 

 

Es erscheint 2 mal, da ich auf dem Server 2 IPS habe

Link to post
Share on other sites

Bitte nicht blind einfach h?kchen setzen. Du solltest nur ?berpr?fen ob du kein listen hast. Dann mach das r?ckg?ngig und schau halt in die Logs. Irgendeinen Fehler muss es ja geben wenn du sagst es geht nicht.

Link to post
Share on other sites

kann den Apache nicht mehr starten...

 

Das steht im apache2/error.log:

 

[sat Jan 04 17:00:57 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[sat Jan 04 17:00:57 2014] [notice] Apache/2.2.22 (Debian) mod_fcgid/2.3.6 mod_ssl/2.2.22 OpenSSL/1.0.1e configured -- resuming normal operations
[sat Jan 04 17:10:03 2014] [notice] SIGUSR1 received.  Doing graceful restart
[sat Jan 04 17:10:03 2014] [warn] NameVirtualHost IPDASESSE:443 has no VirtualHosts
[sat Jan 04 17:10:03 2014] [notice] Apache/2.2.22 (Debian) mod_fcgid/2.3.6 mod_ssl/2.2.22 OpenSSL/1.0.1e configured -- resuming normal operations
[sat Jan 04 17:50:03 2014] [notice] SIGUSR1 received.  Doing graceful restart
[sat Jan 04 17:50:06 2014] [warn] NameVirtualHost IPADRESSE:443 has no VirtualHosts
[sat Jan 04 17:50:06 2014] [error] Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)

Link to post
Share on other sites

L?sche alle vhost configs die von Froxlor erstellt wurden. Dann geht es wieder. Du musst nat?rlich dann im panel die Einstellungen wieder anpassen sonst geht es nach 5minuten wieder nicht.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...