Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
xouco

Domains schalten sich nciht auf

Question

Hallo,

 

ich habe grade mein Froxlor Panel eingebaut und installiert nun habe ich ein Problem und zwar 

wenn ich eine domain aufschalte dann wird sie nicht in das verzeichnis wo sie hin soll geschickt 

aufschaltung per IP.. Wei? jemand ne l?sung

Share this post


Link to post
Share on other sites

Recommended Posts

Einstellungen anpassen, Services einrichten - vorallem den CRON. Siehe auch http://redmine.froxlor.org/projects/froxlor/wiki/InstallationTarball

 

Bitte stelle unbedingt sicher, dass alle Pfade in den Einstellungen f?r dein System angepasst wurden (vhost-config dir etc.). Ansonsten bitte auch mal den Cronjob manuell ausf?hren (mit parameter --force) und schauen, ob es Fehler gibt.

Share this post


Link to post
Share on other sites

Einstellungen anpassen, Services einrichten - vorallem den CRON. Siehe auch http://redmine.froxlor.org/projects/froxlor/wiki/InstallationTarball

 

Bitte stelle unbedingt sicher, dass alle Pfade in den Einstellungen f?r dein System angepasst wurden (vhost-config dir etc.). Ansonsten bitte auch mal den Cronjob manuell ausf?hren (mit parameter --force) und schauen, ob es Fehler gibt.

 

Also ich habe es eigentlich genau so gemacht wie es in den einstellungen f?r mein system vorgegeben ist nur bei apache schreibt er wirklich ?berhaupt nix da steht ja nur 

 

mkdir -p /var/customers/webs/
mkdir -p /var/customers/logs/
mkdir -p /var/customers/tmp
chmod 1777 /var/customers/tmp
a2dismod userdir

 

und dann restarten .. dann hatte ich ne domain hinzugef?gt und diese wurde in /var/www hin geschoben anstadt in sein verzeichnis

Share this post


Link to post
Share on other sites

Ist ja auch klar, apache configs erstellt der Cronjob.

 

Bitte f?hre den Cronjob mal manuell aus.

Share this post


Link to post
Share on other sites

Ist ja auch klar, apache configs erstellt der Cronjob.

 

Bitte f?hre den Cronjob mal manuell aus.

 

welchen?

 

Edit: habe kahm das

 

[Mon Dec 16 14:09:45 2013] [warn] NameVirtualHost *:80 has no VirtualHosts

Share this post


Link to post
Share on other sites

Jetzt habe ich nehn anderes problem nun ?ndert der cron immer ins folgende 

 

<VirtualHost *zensiert*:80>
DocumentRoot "/var/"
 ServerName *zensiert*
</VirtualHost>
 
soll aber in var/www

Share this post


Link to post
Share on other sites

in welcher directory hast du denn Froxlor installiert? ich hoffe doch in /var/www/ ?

Share this post


Link to post
Share on other sites

Hast du in den IP/Port einstellungen den "document" ge?ndert? z.B. auf "/var"? 

Share this post


Link to post
Share on other sites

Einmal die Ausgabe von 

ls -la /etc/apache2/sites-enabled/

und wenn dort nichts drin ist, hast du die Einstellungen vermutlich nicht ganz angepasst, dann hast du die /etc/apache2/vhosts.conf wo alle vhosts drin sein sollten. Diese wird per default nicht in apache eingebunden. Es ist also ratsam, als vhost-configuration directory "/etc/apache2/sites-enabled/" anzugeben.

Share this post


Link to post
Share on other sites

Einmal die Ausgabe von 

ls -la /etc/apache2/sites-enabled/

und wenn dort nichts drin ist, hast du die Einstellungen vermutlich nicht ganz angepasst, dann hast du die /etc/apache2/vhosts.conf wo alle vhosts drin sein sollten. Diese wird per default nicht in apache eingebunden. Es ist also ratsam, als vhost-configuration directory "/etc/apache2/sites-enabled/" anzugeben.

Ich habe da drinne stehen

 

total 8
drwxr-xr-x 2 root root 4096 Dec 16 12:11 .
drwxr-xr-x 8 root root 4096 Dec 16 14:05 ..
lrwxrwxrwx 1 root root   26 Dec 16 12:11 000-default -> ../sites-available/default

Share this post


Link to post
Share on other sites

liegt in /etc/apache2/sites-available

 

->>>

 

 

 

Ich habe da drinne stehen

 

total 8
drwxr-xr-x 2 root root 4096 Dec 16 12:11 .
drwxr-xr-x 8 root root 4096 Dec 16 14:05 ..
lrwxrwxrwx 1 root root   26 Dec 16 12:11 000-default -> ../sites-available/default

 

 

Wie passt das zusammen?

 

Und bitte NICHT in sites-available, sondern sites-enabled, die aus sites-available werden NICHT eingebunden

Share this post


Link to post
Share on other sites

Okay habe ich in sites-enabled rein gemacht nun zeigt er mir wieder alles in "/var/" an 

 

Also bei der Hauptdomain steht wieder das selbe wie vorherr also "var" kann mann das beheben ?

Share this post


Link to post
Share on other sites

Klar kann man das beheben. Aber da scheint ja was von dir verstellt worden zu sein. Ich habe noch nie erlebt, dass beim vhost da /var/ als docroot steht. Das kann gar nicht sein beim standard setup

Share this post


Link to post
Share on other sites

Klar kann man das beheben. Aber da scheint ja was von dir verstellt worden zu sein. Ich habe noch nie erlebt, dass beim vhost da /var/ als docroot steht. Das kann gar nicht sein beim standard setup

 

ich habe es normal installiert und halt so wie beschrieben alles eingestellt und dann wahr das so deswegen wundert es mich ja das er nach jedem cron ieder das "/var/" einf?gt anstadt "/var/www"

Share this post


Link to post
Share on other sites

habe es neu installiert er zeigt mir direkt wieder alles so an

 

NameVirtualHost IP:80
<VirtualHost IP:80>
DocumentRoot "/var/"
 ServerName Domain
</VirtualHost>
 
(System nart?rlich auch komplett neu installiert)

Share this post


Link to post
Share on other sites

Zeig doch bitte nich immer so St?cke, zeig uns bitte die ganze Datei, die von Froxlor da erstellt wurde. Domainnamen und IPs kannst du nat?rlich gerne verf?lschen

Share this post


Link to post
Share on other sites

Er erstellt dies:

 

# vhosts.conf
# Created 16.12.2013 17:04
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.
 
  <Directory "/var/customers/webs/">
    Order allow,deny
    allow from all
  </Directory>
 
 
NameVirtualHost IP:80
<VirtualHost IP:80>
DocumentRoot "/var/"
 ServerName DOMAIN
</VirtualHost>

Share this post


Link to post
Share on other sites

Tut mir leid, aber du hast entweder froxlor nur in /var/ installiert oder der IP in Froxlor den documentroot "/var/" gegeben. Anders geht das so nicht.

 

Als Zweites: Setze die Vhost-Configuration directory doch bitte auf "/etc/apache2/sites-enabled/". So werden f?r jeden vhost eigene Dateien erstellt und das Debugging f?llt leichter. Ebenso wird dieser Ordner unter Debian standardm??ig vom Apache inkludiert (/etc/apache2/vhosts.conf nicht!!!).

Share this post


Link to post
Share on other sites

Als Zweites: Setze die Vhost-Configuration directory doch bitte auf "/etc/apache2/sites-enabled/". So werden f?r jeden vhost eigene Dateien erstellt und das Debugging f?llt leichter. 

 

das hat geholfen

Share this post


Link to post
Share on other sites

Nein nun ist es wieder so das er "/var/" rein schreibt 

 

Falls sie skype haben > XoucoHD

 

und die domain kommt ma per pn dann sehen sie mal selber 

Share this post


Link to post
Share on other sites

Ich habe Skype, aber der kostenfreie Support f?r die Community l?uft hier ?ber das Forum.

Share this post


Link to post
Share on other sites

×
×
  • Create New...