Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Ex0bi

Standardsubdomain wird auf Hauptdomain umgeleitet

Question

Hallo,

 

Ich habe k?rzlich Froxlor auf meinem VPS eingerichtet, aber mir ist schon ganz zu Anfang aufgefallen, dass wenn ich einen neuen Kunden anlege, die Standartsubdomain nicht auf das Kundenverzeichnis geschaltet ist, sondern auf die Hauptdomain weiterleitet. Bei der Domain ist zwar das korrekte Verzeichnis angegeben, aber sobald ich die Domain aufrufe komme ich auf die Hauptdomain.

 

Meine Hauptdomain ist bei Dot.TK registriert und l?uft ?ber einen Nameserver bei ClouDNS.net.

 

LG

~Julius

Share this post


Link to post
Share on other sites

Recommended Posts

1) was ist f?r dich die "hauptdomain"? Der System-Hostname oder eine Domain des Kunden?

2) Lief der cronjob, wurden entsprechende vhost-configs f?r die std-subdomains erstellt?

3) Foren-Suche benutzen

Share this post


Link to post
Share on other sites
1) was ist f?r dich die "hauptdomain"? Der System-Hostname oder eine Domain des Kunden?

 

Damit meine ich den System-Hostnamen

 

2) Lief der cronjob, wurden entsprechende vhost-configs f?r die std-subdomains erstellt?

 

Der blutige Anf?nger ist etwas ?berfordert ^^

 

3) Foren-Suche benutzen

 

Schon gemacht, bin daraus aber nicht schlau geworden.

Share this post


Link to post
Share on other sites

Naja, ob der Cronjob gelaufen ist, steht im Admin-Panel (unten). Und ob die Konfigurationen erstellt wurden kontrollierst du am besten via Shell, in dem du schaust ob sie existieren und ggfls. postest, was drin steht.

Share this post


Link to post
Share on other sites
ob der Cronjob gelaufen ist, steht im Admin-Panel (unten)

 

Was meinst du mit "unten". Cronjob-Einstellungen? Ich benutzte Froxlor erst seit sehr kurzer Zeit und habe vorher sehr lange i-MSCP benutzt.

 

Und ob die Konfigurationen erstellt wurden kontrollierst du am besten via Shell

 

Wie kann ich das nachschauen? Sry, wenns ein bisschen bl?d r?berkommt ^^

Share this post


Link to post
Share on other sites

1) Login als admin -> auf DER seite unten steht sowas wie "Erstellen von Konfigurationsdateien: 01.11.2013 16:50:01"

2) das kommt nicht nur ein bisschen bl?d r?ber, das wirkt als solltest du die finger von servern lassen...sorry, ein gewisser grad an kenntnissen sollte sogar bei froxlor vorhanden sein. Konfigurationen liegen in /etc/apache2/sites-enabled/

Share this post


Link to post
Share on other sites

?brigens, pr?fe bitte mal deine E-Mail Adresse in deinem Account hier, denn ich bekomme bei jedem Post eine Fehlermeldung von unserem Mailserver:

550 Requested action not taken: mailbox unavailable

Share this post


Link to post
Share on other sites

Das sieht aber nicht so aus, denn es existiert keinerlei Vhost-Config die von Froxlor erstellt wurde. Bist du sicher das du den Cronjob eingerichtet hast und das die Pfade zum Apache-Config-Verzeichnis stimmen, etc.etc.?

Share this post


Link to post
Share on other sites

Werden die configs erstellt wenn du den Cronjob manuell "anstubst"?

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Share this post


Link to post
Share on other sites

Dann hast du den Cronjob nicht korrekt eingerichtet.

 

Pr?fe bitte, ob das Problem jetzt erledigt ist. Denn das sollte es.

Share this post


Link to post
Share on other sites

Ich habe meinen VPS jetzt mit Debian 7 Wheezy neu aufgesetzt und Froxlor neu installiert. Aber das Problem bleibt. Es wird auch im Kundenverzeichnis die standardm??ige index.html angelegt. Aber ?ber die Kundensubdomain ist das Kundenverzeichnis nicht erreichbar. Ich ebenfalls ?ber die Konfiguration den Cronjob konfiguriert.

 

EDIT: Hier ?brigends meine DNS-Konfiguration:

57xqk.jpg

Share this post


Link to post
Share on other sites

Im Verzeichnis /etc/apache2/sites-enabled/ liegt schon wieder nur 000-default.

 

EDIT: Und wenn ich den Cronjob manuell anstupse bekommen ich nur die Meldung: sh: 1: /etc/init.d/apache: not found 

Eigentlich m?sste er doch auch apache2 und nicht apache ausf?hren oder nicht?

Share this post


Link to post
Share on other sites

Und wieder einmal: du hast die Einstellungen nicht angepasst....wir sind wieder bei http://forum.froxlor.org/index.php/topic/12320-standardsubdomain-wird-auf-hauptdomain-umgeleitet/#entry24759

 

Nat?rlich m?sste er /etc/init.d/apache2 reload ausf?hren - der Reload-Befehl ist in den Einstellungen hinterlegt, man muss ihn f?r sein System entsprechend anpassen, du liest nicht genau. So kann ich dir echt schwer helfen

Share this post


Link to post
Share on other sites

Ich habe dem Verzeichnis jetzt die Rechte gegeben, einen neuen Kunden angelegt und den Cronjob neu gestartet. Aber es funktioniert nicht.

Share this post


Link to post
Share on other sites

Was denn f?r Rechte an welches Verzeichnis? Ich glaub du bist gerade ganz falsch. Du sollst dich in deinem Froxlor als Admin einloggen und die entsprechenden Einstellungen korrigieren, ist doch klar, dass sonst nichts funktionieren. Ein wenig solltest du dein System schon kennen, sonst kann ich dir nur davon abraten, einen Server zu betreiben.

Share this post


Link to post
Share on other sites

Das habe ich doch schon von Anfang an gemacht. Froxlor ist an und f?r sich konfiguriert. Aber es scheint trotzdessen nicht zu funktionieren.

Share this post


Link to post
Share on other sites

Ich wiederhole mich jetzt ein letztes Mal: 

 

Log dich als Admin ein und nimm die entsprechenden Einstellungen vor, damit sie auf dein System passen (wie z.B. das Apache-Reload Kommando, oder der Vhost-Configuration Ordner). Denn das hast du offensichtlich nicht getan.

Share this post


Link to post
Share on other sites

×
×
  • Create New...