Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
snoopotic

[fixed] 0.9.29 debian wheezy apache2 froxlor on fcgid

Question

Hi if you run froxlor on fcgid and tick the responsible checkbox (use fcgi in froxlor vhost) the configfile written is on old (not working!) style.

 

 

the diff looks like that (the above one is a copy I made before the cron created the wrong one):
 
< # Created 26.09.2013 18:40
---
> # Created 26.09.2013 18:55
13,17c13,15
<   <FilesMatch "\.(php)$">
<       SetHandler fcgid-script
<       FcgidWrapper /var/www/php-fcgi-scripts/froxlor.panel/<hostname>/php-fcgi-starter .php
<       Options +ExecCGI
<     </FilesMatch>
---
>     AddHandler fcgid-script .php
>     FcgidWrapper /var/www/php-fcgi-scripts/froxlor.panel/<hostname>/php-fcgi-starter .php
>     Options +ExecCGI

This is obviously a bug, isn't it? :)

 

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

So? I cannot fix already released packages. You will get the fix with the next release as debian package or you can use the current git-version (installation from tarball)

Share this post


Link to post
Share on other sites

Yeah in my production system i like to use "stable" ones. Maybe i think about that again or you may build a fix release for the distributions. Do you have a automated buildsystem? Otherwise I may help you.

I tested your fix by replacing the file from the corresponding commit on my testsystem, but that threw a strange db error. Obviously you've made some other important changes...

Share this post


Link to post
Share on other sites

You cannot just use single files from newer versions. All or nothing.

 

Also, theres no buildsystem. What for, Froxlor does not need to be compiled or anything ;)

Share this post


Link to post
Share on other sites

Hi, okay, thanks for your reply. Well I know whot php is, but I meant the .deb package that must be built :P

 

Nevertheless... I tried the git Repo but the cron throws then:

PHP Notice:  Undefined variable: user in .../froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 231

 

THe notice is right. you shall set this variable .=)

 

But the script works.

Share this post


Link to post
Share on other sites

I found out the php-fpm one has the same bug as reported on topic :)

Sorry for making you a lot work :)

 

the old one:

   # AddHandler php5-fastcgi .php
   # Action php5-fastcgi /fastcgiphp
   # Options +ExecCGI

shall be replaced by:

 <FilesMatch "\.(php)$">
      SetHandler php5-fastcgi
      Action php5-fastcgi /fastcgiphp
      Options +ExecCGI
    </FilesMatch>

:)

Share this post


Link to post
Share on other sites

really really weird, thought that stuff has been updated for ages....i've no idea why this is still AddHandler...i have memories of updating that...well, here we go, fixed in git

Share this post


Link to post
Share on other sites

This "SetHandler" thing can only work if you ADDED that handler (using AddHandler) before anywhere...needs more fixing

Share this post


Link to post
Share on other sites

×
×
  • Create New...