Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Malvin1990

500 internal server error - Ich wei? nicht mehr weiter

Question

guten Abend .... 

 

ich hatte mich mal an die installation von froxlor  und fcgid rangewagt ... und nun hab ich den ganzen server zerschossen .... leider wei? ich nicht mehr weiter, bis zum letztem schritt der installation ging alles (auf debian).

 

nachdem ich aber dann php dismoded habe und die cronjobs angemacht habe und die konfiguration neu schreiben lassen habe - kommt nun der 500 fehler und ich bekomme ihn einfach nicht mehr weg (auch nicht nach anstellen von php5 und deaktivieren der cronjobs). daher vermute ich das es daran nicht zwangsl?ufig liegen muss.

 

ich bin leider absoluter laie wenn es um solche fehler geht, hatte mich hiermit auch nur befasst weil alles f?r mich verst?ndlich war.

 

was mir jetzt ?brigens im nachhinein aufgefallen ist das unter suexec -V die AP_DOC_ROOT nicht _mehr_ aufgelistet wird. zu anfang der installation hatte ich das noch ?berpr?ft, da stand dies drin.

kann es daran liegen ? wenn ja, wie trage oder kompiliere ich das da wieder rein?

 

im error.log steht leider nichts essenzielles - nur ein fehler, den ich aber auch schon vor tagen hatte, also daran kanns wohl nicht liegen:

 


[Tue Aug 20 19:01:47 2013] [notice] caught SIGTERM, shutting down
[Tue Aug 20 19:01:48 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Tue Aug 20 19:01:48 2013] [warn] module cgi_module is already loaded, skipping
[Tue Aug 20 19:01:48 2013] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze16 with Suhosin-Patch configured -- resuming normal operations
[Tue Aug 20 19:01:53 2013] [alert] [client 91.33.74.106] /var/www/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: http://62.108.41.144/
[Tue Aug 20 19:01:54 2013] [alert] [client 91.33.74.106] /var/www/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: http://62.108.41.144/
[Tue Aug 20 19:01:55 2013] [alert] [client 91.33.74.106] /var/www/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: http://62.108.41.144/
[Tue Aug 20 19:02:34 2013] [alert] [client 91.33.74.106] /var/www/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: http://62.108.41.144/
[Tue Aug 20 19:04:22 2013] [alert] [client 87.102.234.222] /var/www/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
[Tue Aug 20 19:04:22 2013] [alert] [client 87.102.234.222] /var/www/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
[/code}
 
wenn ich nach 500 interner error google, bekomme ich leider nur allgemeine sachen die mich nicht weiterbringen. auch der beitrag im wiki hier von froxlor ist leider sehr allgemein gehalten.
 
k?nnte mir bitte jemand auf die spr?nge helfen das wieder r?ckg?ngig zu machen, ich brech gleich in panik aus :(:(:(:(:(
 
notfalls auch wie ich das ganze wieder "deinstalliere" so das zumindest zugrff auf die seite ist und ich nochmal von neu beginnen kann.

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

Du hast "mod_rewrite" nicht aktiviert....er sagt es doch: 

 

Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

Share this post


Link to post
Share on other sites

Du hast "mod_rewrite" nicht aktiviert....er sagt es doch: 

 

mhm das war es tats?chlich - was mich allerdings wundert da ich den fehler schon vor paar tagen hatte laut log. nunja zumindest die seite geht wieder - auch wenn er fcgi nicht ?bernommen hat :/

jedenfalls bist du ein genie - danke sehr.

 

in froxlor steht immernoch 

 

APACHE2HANDLER

 

obwohl ich mit dem letzten schritt durch bin und jetzt auch kein fehler mehr angezeigt wird. kann es an der ap_doc_root liegen die nicht drin steht? wenn ja wie mach ich das da rein? oder ne andere idee?

 

P.S.: jetzt kann ich wenn ich auf die hauptdomain gehe, meine seite runterladen - ich lass es gleich.

Share this post


Link to post
Share on other sites

Hast du auch f?r den Froxlor-Eigenen-Vhost FCGID aktiviert? Daf?r muss auch ein lokaler user angelegt werden etc.pp. (steht auch im handbuch glaub ich)

Share this post


Link to post
Share on other sites

ja hab ich beides gemacht :

addgroup --gid 9999 froxlorlocaladduser --no-create-home --uid 9999 --ingroup froxlorlocal --shell /bin/false froxlorlocal

war beim letzten schritt wie gesagt - dem user geh?rt auch das verzeichniss froxlor 

 

aber wieso kann ich jetzt nachdem ich php wieder ausgemacht habe, meine seite runterladen - irgendwie hat er nichts ?bernommen.

 

http://www.fotos-hochladen.net/uploads/mjh1ed2rfzbq.jpg

 

http://www.fotos-hochladen.net/uploads/nrkw9oe17yx.jpg

 

irgendwas kann hier ja nicht stimmen, hab aber die besagten schritte wiederholt.

Share this post


Link to post
Share on other sites

na nur user anlegen reicht da nicht, in den settings musst du auch sagen, dass f?r Froxlor selbst auch ein FCGID vhost angelegt werden soll. Dann muss der Cron nat?rlich auch gelaufen sein da sonst die configs ja gar nicht erstellt wurde

Share this post


Link to post
Share on other sites

das zweite bild passt scho - du hast suexec-custom

 

erstellt er denn die entsprechenden vhost-configs in /etc/apache2/....?

Share this post


Link to post
Share on other sites

auch mal reingeguckt ob FCGID zeug drinsteht? Hast du auch geschaut ob die fcgi-starter in dem von dir angegebenen ordner erstellt wurden? Auf welchen Ordner zeigt dein suexec-DOCROOT? (warum ?berhaupt suexec-custom?)

Share this post


Link to post
Share on other sites

also FCGID zeug steht drine, soweit ich das beurteilen kann:

 

rei? mir bitte nicht den kopf ab aber welche fcgi starter und in welchem schritt soll ich das eingestellt haben ?

 

suexec-custom hab ich zu suexec ge?ndert. wusste nicht das da ein unterschied ist.

 

suexec zeigt den document root jetzt auf /var/www

NameVirtualHost 62.108.41.144:80
<VirtualHost 62.108.41.144:80>
DocumentRoot "/var/www/"
 ServerName ts.gameplorer.de
  FcgidIdleTimeout 30
  SuexecUserGroup "froxlorlocal" "froxlorlocal"
  <Directory "/var/www/">
    AddHandler fcgid-script .php
    FcgidWrapper /var/www/php-fcgi-scripts/froxlor.panel/ts.gameplorer.de/php-fcgi-starter .php
    Options +ExecCGI
    Order allow,deny
    allow from all
  </Directory>
</VirtualHost>

Share this post


Link to post
Share on other sites

Diese Starter: /var/www/php-fcgi-scripts/froxlor.panel/ts.gameplorer.de/php-fcgi-starter

 

Scheint ja geklappt zu haben. Allerdings zeigt ts.gameplorer.de auf eine Joomla-Installation und nicht auf Froxlor, da hast du wohl noch was falsches eingestellt!?

Share this post


Link to post
Share on other sites

mhm so war das eigentlich gedacht ... 

 

bzw. wollte ich froxlor nur f?r mich selbst installieren, nicht f?r weitere kunden etc. daher sollte das auch so sein, das die hauptdomain meine joomla seite ist.

 

geht das denn dann so ?berhaupt ? oder _muss_ die hauptdomain froxlor sein?

 

bzw. frage ich mich gerade wie du auf die seite kommst, wenn ich nur die downloadaufforderung bekomme.

Share this post


Link to post
Share on other sites

ich kam nicht auf die Seite, ich kann aber Code lesen von der heruntergeladenen PHP-Datei :)

 

Und nein, du musst nicht die Hauptdomain nutzen, du kannst auch eine Subdomain f?r Froxlor nutzen. Ich dachte nur da du den Vhost mit SuExecUser "froxlorlocal" geposted hast und dort diese Domain hinterlegt war, ginge ich jetzt eigentlich davon aus, dass das dein Froxlor-Vhost ist und kein Kundenvhost.

Share this post


Link to post
Share on other sites

dazu kann ich nur sagen: logs, logs und logs...da steht alles drin, wenn was nich stimmt. 

 

Auch libnss-mysql installiert und konfiguriert?

Share this post


Link to post
Share on other sites

in den logs ist jetzt aber kein fehler mehr. 

 

und ja hab ich installiert. 

 

aber ich merke schon das ist doch ne spur zu hoch f?r mich alles, ich lass es sein, dankesch?n f?r deine hilfe!

Share this post


Link to post
Share on other sites





×
×
  • Create New...