Jump to content
Froxlor Forum
  • 0

Backup nur f?r bestimmte Ordner


Wolf212

Question

14 answers to this question

Recommended Posts

In phpmyadmin sind folgende Datenbanken angelegt/vorhanden:

froxlor, ...sql1, webmailsql1 und in der ....sql1 sind min.6,68MB Daten vorhanden, er erstellt zwar ein Backup von der ...sql1 aber ohne Inhalt

Hat das vielleicht mit den Rechten was zu tuen?

Link to post
Share on other sites

Nein, der backupcronjob sollte, wie die anderen cronjobs auch, mit root-Rechten ausgef?hrt werden, daher sollten Berechtigungen keine Rolle spielen. Ich kann dir allerdings so jetzt nicht sagen, wieso er die ohne Inhalt anlegt. 

Hast du in den Einstellungen auch den korrekten Pfad zu "mysqldump" angegeben? Ausgef?hrt wird das folgenderma?en:

/pfad/zu/mysqldump --opt --force --allow-keywords -u rootuser -pRooTPassword -h sqlhostname DATENBANKNAME -r BACKUP_DIR/webX/DATENBANKNAME.sql

Vielleicht probierst du das zur Kontrolle manuell? Nur um zu schauen ob es funktioniert

Link to post
Share on other sites

Nein, der backupcronjob sollte, wie die anderen cronjobs auch, mit root-Rechten ausgef?hrt werden, daher sollten Berechtigungen keine Rolle spielen. Ich kann dir allerdings so jetzt nicht sagen, wieso er die ohne Inhalt anlegt. 

Hast du in den Einstellungen auch den korrekten Pfad zu "mysqldump" angegeben? Ausgef?hrt wird das folgenderma?en:

/pfad/zu/mysqldump --opt --force --allow-keywords -u rootuser -pRooTPassword -h sqlhostname DATENBANKNAME -r BACKUP_DIR/webX/DATENBANKNAME.sql

Vielleicht probierst du das zur Kontrolle manuell? Nur um zu schauen ob es funktioniert

Ja hast recht es k?nnte am Pfad liegen, habe jetzt folgendes eingegeben:

/var/run/mysqld/ --opt --force --allow-keywords -u rootuser -pRooTPassword -h sqlhostname DATENBANKNAME -r BACKUP_DIR/webX/DATENBANKNAME.sql

Leider noch immer nichts oder muss ich da noch Benutzer und Passwort ?ndern?

Link to post
Share on other sites

 

/var/run/mysqld/

 

Wie kommst du auf diesen Pfad? Das ist ein Pfad und kein Programm, du musst dort das Programm mysqldump angeben, wo das liegt, kriegst du raus, wenn du folgendes in der Shell ausf?hrst:

# which mysqldump

Und was da rauskommt tr?gst du in den Einstellungen ein, z. B. /usr/bin/mysqldump

Link to post
Share on other sites

/var/run/mysqld/ --opt --force --allow-keywords -u rootuser -pRooTPassword -h sqlhostname DATENBANKNAME -r BACKUP_DIR/webX/DATENBANKNAME.sql

Leider noch immer nichts oder muss ich da noch Benutzer und Passwort ?ndern?

 

Ja nat?rlich musst du...ich kenn doch dein root-passwort nicht...bitte lies die kommando-zeile genau. Genauso ist nat?rich "DATENBANKNAME", "BACKUP_DIR" und "webX" mit den entsprechenden Werten zu ersetzen, die auf dein System zutreffen...

Link to post
Share on other sites

ok habe das jetzt mal mit der shell ausprobiert, da scheint es zu funktionieren, aber das Backup der SQL ist nicht komplett da fehlen noch einige Tabellen!?

und in froxlor wird das Backup immer noch mit leerem Inhalt ausgegeben

Link to post
Share on other sites

Stimmt denn ggfls das mysql root-Passwort in der lib/userdata.inc.php von Froxlor nicht? Ansonsten f?llt mir jetzt auf die schnelle nicht ein, wo da das Problem liegen k?nnte...

Link to post
Share on other sites

Wie gesagt, mir f?llt jetzt so auf die schnelle nichts mehr ein, ich kann dir nur anbieten, du besuchst uns mal im IRC und ich schau mir das mal auf deinem Server an

Link to post
Share on other sites

Hallo d00p

ich musste heute den apache2 neustarten, was nicht funktionierte und folgender fehler trat auf:

Syntax error on line 11 of /etc/apache2/sites-enabled/20_froxlor_normal_vhost_********.de.conf:
Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
 failed!

in der error.log steht folgendes:

[Fri May 24 20:31:22 2013] [notice] caught SIGTERM, shutting down

 Jetzt l?st sich der http Webserver ?berhaupt nicht mehr aufrufen. Hat das irgendwas mit gestern zu tuen?

Link to post
Share on other sites

Du hast dein PHP nicht korrekt installiert/konfiguriert. Das habe ich dir gestern gesagt. Du hattest php-fpm aktiviert obwohl es nicht mal installiert war. Falls PHP installiert ist, schau halt ob das php5 Apache Modul aktiviert ist (a2enmod php5). Ansonsten hat das nichts mit dem backup Problem zu tun und geh?rt daher nicht in dieses Thema - das verwirrt nur.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...