Jump to content
Froxlor Forum

Release 0.9.28 *update*


d00p
 Share

Recommended Posts

Dear Froxlor Community,
 
the release candidate of version 0.9.28 has been released a month ago and thanks to a bunch of community users for testing and reporting, a lot of bugfixes found their way into this release and we are proud to announce a new stable release of Froxlor: 0.9.28
 
The upcoming release-candidates, followed by a stable release, of version 0.9.29 will include improved SSL-support and IPv4/IPv6 dual-stack support as announced earlier.
Also you might have noticed that we started to work on our new version tree 0.99 which will be API based. It's under heavy development and still in its beginnings.
 
As we probably will not be finished with 0.99 after 0.9.29 is released, depending on bug-reports or similar, there will of course be another maintenaince release of 0.9.x if necessary.
 
As announced in the release-candidate thread, support for php's safe_mode, mod_log_sql and Debian Lenny has been removed in this release. Also, Ubuntu Hardy completely and dovecot-1 on Gentoo have been marked as deprecated as they will be removed in 0.9.29.
 
Please report bugs/errors in the bugtracker (http://redmine.froxlor.org) as usual.
 
Changes in 0.9.28:

+ #536 Use complete domain name as default path for DocumentRoot

+ #1150 added possibility to add random prefixes to a customers database-name


~ #668 fixed FreeBSD 8.2: Bind 9 is missing from list of Daemons

~ #758 fixed bug in "Amount of APS installations" counter

~ #916 fixed webserver-specific default vHost settings don't work in ligHTTPd

~ #1023 fixed Redirect with SSL Enabled Domain

~ #1058 fixed bug in "Amount of autoresponders" counter

~ #1085 fixed incorrect configuration command for awstats under Gentoo

~ #1127 fixed falsely used e-mail sender name

~ #1134 updated default parameter list of sendmail-program in php.ini-template

~ #1136 fixed falsely added specialsettings to a ssl-redirect

~ #1160 fixed usage of empty value for CertificateChainFile (it's allowed)

~ #1172 cleaned up language files

~ #1173 fixed redirect to "ip:port"

~ #1180 fixed clean-up if fcgid/php-fpm configurations

 
Important information: 
The configurations for postfix on FreeBSD have been updated. Please check using http://config.froxlor.org/.

Update: Due to a syntax-error in the updater we had to re-release as version 0.9.28.1 - for all who got stupid errors on updating, we are sorry :/

Download: froxlor 0.9.28.1
 
Note: Debian packages and the Gentoo ebuild will follow shortly.
 
Visit http://www.froxlor.org or join our IRC channel #froxlor on irc.freenode.net.
 
Thank you,
d00p

Link to comment
Share on other sites

  • 3 weeks later...

as you might have noticed already, debian 7.0 got released a few hours ago.

going on par with that a small change and a note:

 

squeeze users:

stable is now oldstable, if you are pointing to the "stable" symlink in your configuration, you might want to change that to "squeeze" or "oldstable"

 

wheezy users:

there will be *no* wheezy packages for 0.9.28.1, this will have to wait for the next froxlor release

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...