Jump to content
Froxlor Forum
  • 0

Bind9 Fails to Start



Bind9 fails to start using Froxlor generated config files. Pasted below are the commands and response:


syshost:~# /etc/init.d/bind9 reload

Reloading domain name service...: bind9rndc: connect failed: connection refused


syshost:~# named -4 -S 1024 -c /etc/bind/named.conf -g

09-Apr-2010 01:39:41.788 starting BIND 9.5.1-P3 -4 -S 1024 -c /etc/bind/named.conf -g

09-Apr-2010 01:39:41.788 found 8 CPUs, using 8 worker threads

09-Apr-2010 01:39:41.789 using up to 1024 sockets

09-Apr-2010 01:39:41.794 loading configuration from '/etc/bind/named.conf'

09-Apr-2010 01:39:41.794 /etc/bind/froxlor_bind.conf:11: undefined ACL 'ns1.syshost.com'

09-Apr-2010 01:39:41.795 loading configuration: failure

09-Apr-2010 01:39:41.795 exiting (due to fatal error)

Where does Froxlor define an Access Control List?


Pasted below is the Froxlor generated froxlor_bind.conf file contents:

# Domain ID: 6 - CustomerID: 2 - CustomerLogin: spflanze

zone "syshost.com" in {

type master;

file "/etc/bind/domains/syshost.com.zone";

allow-query { any; };

allow-transfer {




Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Substituting the IP address for localhost in the froxlor_bind.conf file worked to get named started. I do have a working DNS server now and it took more than this substitution to make it work. The configuration instructions need to instruct what to put in the files /etc/bind/rndc.conf and /etc/bind/named.conf.local. I found these instructions at: http://www.netadmintools.com/art25.html . These instructions worked after I figured out that in my case the content should go in /etc/bind/named.conf.local instead of the file /etc/named.conf . And the rndc.conf file needs to be in /etc/bind/ instead of /etc/.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...