Jump to content
Froxlor Forum

kingsley ezenwa

Members
  • Posts

    123
  • Joined

  • Last visited

Posts posted by kingsley ezenwa

  1. 27 minutes ago, d00p said:

    Adjust your settings...Over and Over and Over again...the settings are all self-explaining. Hundreds of users have no problem setting up and using froxlor. I think you're overthinking. Setting up froxlor is a matter of minutes....

    Or is it because am using CENTOS 7 ?

    Would have switched OS but am more comfortable with CentOS 7 but willing to play around with other OS if that's the issue.

    Can you please help me look into this ?
    Am willing to give server login details

  2. I can see this   Nginx PHP backend
    this is where the PHP process is listening for requests from nginx, can be a unix socket of ip:port combination
    *NOT used with php-fpm

    but don't really know what it means.
    does *NOT used with php-fpm mean it's not applicable to php-fpm  AND Can I delete it's current value 127.0.0.1:8888  and leave it blank as it's always added to all Vhosts created by FROXLOR

     

        location ~ \.php {
            fastcgi_split_path_info ^(.+\.php)(/.+)$;
            include /etc/nginx/fastcgi_params;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_path_info;
            try_files $fastcgi_script_name =404;
            fastcgi_pass 127.0.0.1:8888;
            fastcgi_index index.php;
        }

  3. 7 minutes ago, d00p said:

    second: if you don't know what it is, you're either not using it or you shouldn't be using it

    Nginx PHP backend
    I use PHP-FPM with Nginx if that helps.

    I know this   fastcgi_pass 127.0.0.1:9000 in NGINX location ~ \.php{} config
    AND my php-fpm listens on    listen = 127.0.0.1:9000   in /etc/php-fpm.d/www.conf file .

    Just posted above info if that helps for Nginx PHP backend in Web Server setting for NGINX  which is currently set to  127.0.0.1:8888 in FROXLOR

     

    Thanks

  4. Another noob question

    Am used to restarting/reloading NGINX with Systemctl restart nginx and nginx -t for testing configuration  But now since /etc/init.d/nginx is not working (maybe because I installed NGINX from repo), and am unable to quickly get a response from Google, I did a guess work by typing Which NGINX and the out put was /usr/sbin/nginx but now am not sure it's the right thing to give FROXLOR  in "Webserver reload command
    What's the webserver command to reload configfiles?"

     

    Also, this  "Nginx PHP backend
    this is where the PHP process is listening for requests from nginx, can be a unix socket of ip:port combination
    *NOT used with php-fpm" has the value  127.0.0.1:8888 which I don't know if it's correct or not

  5. 5 minutes ago, d00p said:

    ...how can it not matter? Domain not pointing to the server ...

    Sorry Domain points to server but not the FQDN

    Sample domain is example.com while 
    FQDN is test.example.com
     

    Real domain i.e example.com already points to server BUT i didn't point test.example.com to server because it's FQDN and didn't know it mattered.

    I have just added my FQDN to my A records and set ttl to 5 minutes.
    Thanks

  6. 1 minute ago, d00p said:

    2nd thing i notice, you did NOT adjust your settings correctly...

    -> sh: /etc/init.d/nginx: No such file or directory
    -> sh: /etc/init.d/cron: No such file or directory

    This way, new configs WONT take effect...please adjust the corresponding restart commands in the settings

    Where do I do this please ?
    Am suspecting in FROXLOR settings under NGINX web server.
    Guess documentation would have been so cool. Maybe time to provide paid support for your time

  7. Here's output of   "php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug"  .

     

     


    [information] cron_tasks: Searching for tasks to do
    [information] nginx::createIpPort: creating ip/port settings for  139.162.225.38:80
    [information] nginx::writeConfigs: rebuilding /etc/nginx/sites-enabled/
    [information] nginx::reload: reloading nginx
    sh: /etc/init.d/nginx: No such file or directory
    [information] nginx::reload: running service php7.0-fpm restart
    Redirecting to /bin/systemctl restart php7.0-fpm.service
    Failed to restart php7.0-fpm.service: Unit not found.
    [notice] Checking system's last guid
    sh: /etc/init.d/cron: No such file or directory
     

  8. Also normally i can always reapply existing folder/file permissions  But when i try to do same to files/folder created by FROXLOR in the /var/customers/webs folder, I get the following error

    • 10000 user not found on this system
    • 10000 group does not exist on this system

    And since this user:group is a virtual user/group, am totally lost on an alternate way to fix it.

     

    I would have paid you to set up the server for me BUT won't as that means tomorrow if anything breaks, I would know almost nothing on how to fix it.

     

    Am not so much a noob if I have access to materials/tutorials but FROXLOR really lacks documentations especially for Nginx & CentOS 7.

    My first trial with ISPConfig3 was like I have been setting it up for a very long time BUT I really want to leave ISPConfig3 because it's bloated to me and I want to customize thing as time goes on.

     

    Please help me

    Thanks
     

  9. 30 minutes ago, d00p said:

    you know linux right? And you basically understand what "permission denied" / "forbidden" means right? You said yourself the user "10000" cannot be found ... so how can it have any permission? Also you split your problems in a dozen tiny posts here on the forum...how are we supposed to see the "whole"? I have actually no idea what you are doing there....so please:

    - state what EXACTLY you want to achieve / setup and

    - tell us EXACTLY where / what the issues are, provide LOGS (there are ALWAYS logs)

     

    Okay

    Sorry I will make all posts on this thread to avoid littering everywhere and so you can help me as am gradually losing hope on FROXLOR. So much time gone down the drain.

     

    In fact, not really sure on how to explain the situation.

    I have installed FROXLOR and it seems to be working correctly though  FROXLOR installation gives 404 error anytime I restart  Nginx and the only way to make it work again is to delete the vhost files created by FROXLOR in /etc/nginx/sites-enabled/ and restart NGINX  then it's starts working till next time I restart  NGINX daemon which would make it stop and give 404 error again

    Another issue which seems to be a major issue is that 1 have added 2 Customer with 2 domains But both domains keeps displaying NGINX default web-page .

     

     

    Don't know much about the NSCD  but below is the output of systemctl status nscd
     nscd[5827]: 5827 monitoring directory `/etc` (2)
     nscd[5827]: 5827 monitoring file `/etc/hosts` (4)
     nscd[5827]: 5827 monitoring directory `/etc` (2)
     nscd[5827]: 5827 monitoring file `/etc/resolv.conf` (5)
     nscd[5827]: 5827 monitoring directory `/etc` (2)
     nscd[5827]: 5827 monitoring file `/etc/services` (6)
     nscd[5827]: 5827 monitoring directory `/etc` (2)
     nscd[5827]: 5827 disabled inotify-based monitoring for file `/etc/netgroup': No such file or directory
     nscd[5827]: 5827 stat failed for file `/etc/netgroup'; will try again later: No such file or directory
     systemd[1]: Started Name Service Cache Daemon.
     

     

    Will be waiting to provide more information

     

    Thanks

  10. I have installed and Configured Froxlor and everything seems to be working BUT after adding 2 domains, I get 403 Forbidden error message which I know is a Permission issue on NGINX but after trying to figure out the issue as the error logs were saying nothing, I decieded to go into the customer's web folder for the domain and I saw that the files and folders has the user:group name as 10000:10000 .

    Just to be sure, I tried to reapply the permissions But I got this error message    

    • 10000 user not found on this system
    • 10000 group does not exist on this system

    My Server machine config is
    CentOS 7
    Nginx
    MariaDB
    PHP7.0

    Here's how FROXLOR was installed
    I replaced NGINX default web page in /var/www with my mini website hence /var/www/mini-website.com/cpanel/froxlor  and it seems to be working well including all it's internal pages as they are not controlled by FROXLOR but all domains controlled and added by FROXLOR are having the permission (403 forbidden error) issue .

    any idea what might be wrong please ?

  11. Hi

    Am here again, don't want to litter the forum with short threads hence my reason for asking additional related questions here.

    I have configured FROXLOR and even added 1 customer with 2 Domains BUT both domains redirects to the default server webpage.

    Here is an overview of how I installed FROXLOR

    I replaced NGINX default web-page with my website THEN installed FROXLOR in a subfolder e.g http://mywebsite.com/cpanel/froxlor   and FROXLOR seems to be working well BUT after adding 1 Customer + 2 Domains, both domains are redirecting to http://mywebsite.com

    I have also tested email (though I didn't configure POSTFIX ) using the Test Email and it worked successfully.

    I have equally set-up libnss-mysql following the configuration instructions.

    Please kindly help me out.
    Thanks

  12. Hi

    What does this mean

    Please note: The MySQL-password has not been replaced for security reasons. Please replace "FROXLOR_MYSQL_PASSWORD" on your own or use the javascript form below to replace it on-site. If you forgot your MySQL-password you'll find it in "lib/userdata.inc.php" 

    Does "FROXLOR_MYSQL_PASSWORD" represent my FROXLOR database password or my MYSQL database password?
    Must the text FROXLOR_MYSQL_PASSWORD be changed or can I just leave it as it is ?
    Does it mean I should replace FROXLOR_MYSQL_PASSWORD with my MYSQL password ?
    There's no place it was mentioned that the text FROXLOR_MYSQL_PASSWORD is a place holder OR not.

     

    My Server machine architecture
    -CentOS 7
    -Nginx 
    -MariaDB
    -PHP 7.0

    I appreciate the time and resources being put into the development of FROXLOR and I have plans to donate to FROXLOR as soon as am able to get it to use BUT lot's of things really needs to be taken care of.

    I can  install and set-up ISPConfig in less than 2-minutes BUT with FROXLOR, I have spent almost 1-hour (despite it not beingmy first time) and yet to finish up.

    Thanks

  13. On 1/25/2018 at 1:37 AM, d00p said:

    If you enable fpm and specify the pool-config directory (/etc/php-fpm.d/) froxlor automatically manages this folder. The www.conf is NOT necessary as froxlor itself generates all required configs. You simply do not need the www.conf pool. You cannot stop the removal.

    libnss-mysql:

    Configuration -> Select your OS -> select "Other (system)" -> select "libnss-mysql"

     

    libnss-extrausers:

    Settings -> System settings -> enable option "Use libnss-extrausers instead of libnss-mysql"
    Configuration -> Select your OS -> select "Other (system)" -> select "libnss-extrausers"

    Just downloaded , Installed and trying to configure FROXLOR .

    I saw this  

    Use libnss-extrausers instead of libnss-mysql
    Do not read users from the database but from files. Please only activate if you have already gone through the required configuration steps (system -> libnss-extrausers).
    For Debian/Ubuntu only (or if you have compiled libnss-extrausers yourself!)

     

    Now seems if I don't tick the checkbox, libnss-mysql is used by default .
    And I want to understand it's  only "Debian/Ubuntu    OR anyone who compiled libnss-extrausers" that can use   libnss-extrausers  /

     

    Well I want to know which is better than the other  between   libnss-extrausers and libnss-mysql  .

    Thanks

  14. 40 minutes ago, d00p said:

    This just makes no sense at all...

    Really

    I said this because I have seen lot's of worries and advices about Why you should not Run an email server and at the moment, am temporarily using Zoho email but I wish to handle things myself.

    Even Froxlor has an Option for using external SMTP for sending admin emails.

    How about we extend that so it does same for all customer's email?

    Also if it's not possible with FROXLOR, any idea of any script that has such or similar feature ?

    I have plans  tomorrow to download a Fresh copy of FROXLOR from Github and see it the NGINX Try_files issue has been fixed.

     

  15. 6 hours ago, d00p said:

    If you dont want froxlor to handle Mail, you can deactivate it on a per customer or per domain base. But then you are completely on your own regarding Configs.

    See, I still want FROXLOR to handle emails But i do not want to be the one to host the emails with my IP.
    I want to use services like Mailchimp, SendGrid, etc in sending and receiving the emails.

    There should be a setting in FROXLOR where admin can enter his SendGrid SMTP credentials so it would be used in sending nad receiving all emails on the server.

    This will improve deliverability  and  prevent my IP from being black listed and also reduce the amount of messages being marked as SPAM

  16. 4 hours ago, d00p said:

    I don't understand half of what you are writing...sorry.

    Froxlor postfix configs will require the mail-account to be logged in to send email. For everything else you need to adjust your configs manually

    Sorry let me be more clearer .

    Normally for Customers email to work (sending & Receiving), the server admin has to install and configure POSTFIX and Dovecote and emails would be sent via the local server using the Server IP address, etc.
     

    Now am asking if it's possible to send emails using external SMTP like SendGrid, Mailchimp, etc.

    Something like there should be a space where you enter your SMTP credentials and they would be used instead.

    I can see that Froxlor itself has an option to use external SMTP  in sending admin/notification emails. 

    Am asking of this so we can send and receive emails without hosting the emails ourselves to avoid email issues.

    Hope I have been more clear Sir?

×
×
  • Create New...