Jump to content
Froxlor Forum

rickstinson

Members
  • Content Count

    18
  • Joined

  • Last visited

  • Days Won

    1

rickstinson last won the day on September 20

rickstinson had the most liked content!

Community Reputation

1 Neutral

About rickstinson

  • Rank
    Froxie
  1. Danke, hat so funktioniert! Falls jemand noch Warnungsmails bei Quotaüberschreitung benötigt, hier mein Setup: vi /etc/dovecot/conf.d/90-quota.conf plugin { quota_warning = storage=95%% quota-warning 95 %u } service quota-warning { executable = script /usr/local/bin/quota-warning.sh user = vmail unix_listener quota-warning { user = vmail } } plugin { quota = maildir:User quota } Das eigentliche Mail wird über dieses Script versandt (chmod 755): vi /usr/local/bin/quota-warning.sh #!/bin/sh PERCENT=$1 USER=$2 cat << EOF | /usr/lib/dovecot/dovecot-lda -d $USER -o "plugin/quota=maildir:User quota:noenforcing" From: support@XXXXX To: $USER Date: `date +"%a, %d %b %Y %H:%M:%S %z"` Subject: Ihr Postfach ist fast voll! Content-Type: text/html; charset=UTF-8 Content-Transfer-Encoding: 8bit Ihr Postfach $USER ist aktuell zu $PERCENT% belegt. Bitte archivieren oder entfernen Sie alte, nicht mehr benötige Nachrichten. Andernfalls könnte es vorkommen, dass Sie keine neuen Nachrichten mehr empfangen können! Bei Fragen stehen wir Ihnen unter XXXXX oder unter support@XXXX zur Verfuegung. Ihr Hosting Team EOF
  2. Hallo, so, nachdem ich aus der Dovecot Doku nicht schlau geworden bin, probiere ich es mal hier ? Froxlor läuft bei uns mit Dovecot wunderbar, auch die Quotas funktionieren entsprechend (werden im Webmail/Thunderbird angezeigt, wenn Mailbox voll werden keine Mails mehr angenommen). Passt. Was nicht funktioniert ist, dass ein User eine Warn E-Mail ab 80% bzw. 95% bekommt. In /etc/dovecot/conf.d/90-quota.conf habe ich mal die Quotas festgelegt: plugin { quota_warning = storage=95%% quota-warning 95 %u quota_warning2 = storage=80%% quota-warning 80 %u } service quota-warning { executable = script /usr/local/bin/quota-warning.sh user = dovecot unix_listener quota-warning { user = vmail } } Das oben genannte Shellscript funktioniert auch per manuellen aufruf, da bekommt der per Paramenter angegebene User eine Mail Wenn ich richtig liege, müsste man jetzt noch das Quota Backend festlegen, und genau hier stehe ich an. Dovecot holt sich die Quota ja aus der SQLDB von Froxlor, wie konfiguriere ich das nun richtig? plugin { #quota = dirsize:User quota #quota = maildir:User quota #quota = dict:User quota::proxy::quota #quota = fs:User quota } Danke!! Patrick
  3. so, endlich durchgeführt, hat super funktioniert, danke!!!
  4. Hallo, bis dato hat die Quota auf der root Partition (/) einwandfrei funktioniert, froxlor hat brav die Limits gesetzt. Ich habe jetzt die Kundendaten (/var/customers) auf eine neue Partition verschoben (/media/sdb1 und mittelns softlink auf /var/customers gelinkt). Funkt alles, also mal perfekt. Habe dann bei Froxlor vorgestern in den Einstellungen den Ort der Quotas unter: "Partition, auf welcher die Kundendaten liegen" auf /dev/sdb1 gesetzt. Auf der neuen Partition sind die Quotas aktiviert und "/usr/sbin/repquota -np /dev/sdb1" zeigt mir auch die User und die Belegung an: *** Report für Benutzer Quotas auf Gerät /dev/sdb1 Blockgnadenfrist: 7days; Inodegnadenfrist: 7days Block Limits Dateilimits Benutzer belegt weich hart Gnade belegt weich hart Gnade ---------------------------------------------------------------------- [...] #10025 -- 767376 0 0 0 35942 0 0 0 #10058 -- 12524 0 0 0 1171 0 0 0 #10091 -- 2608 0 0 0 236 0 0 0 #10026 -- 150004 0 0 0 5630 0 0 0 [...] Allerdings ohne irgendwelche gesetzten Limits. Im Vergleich dazu die originale Quotas von "/", hier stehen bei weich und hart die Qutoa drinnen. Benutzer belegt weich hart Gnade belegt weich hart Gnade ---------------------------------------------------------------------- [...] #10025 -- 52 2560000 2560000 0 25 0 0 0 #10058 -- 12 256000 256000 0 5 0 0 0 [...] Wie bringe ich Froxlor bei die Quotas festzulegen? Vielen Dank! Patrick
  5. Umpf, danke - auf das hätte ich selbst auch kommen können
  6. Hallo, sorry, ich muss das nochmals kurz ausgraben. Habe jetzt letztes Monat bei "E-Mail- & Dateivorlagen" die Mailvorlage für "Hinweismail für Kunden, wenn sie die angegegebenen Prozent" rausgelöscht. Dennoch haben jetzt wieder viele diese E-Mail bekommen: "Sie haben bereits 10605.29 MB von Ihren insgesamt 3000 MB Speicherplatz verbraucht. Dies sind mehr als 90%. " Wie kann ich denn diese E-Mails abschalten? Dachte die Vorlage zu löschen reicht, aber jetzt nimmt er klarerweise die Standardvorlage
  7. Wenn du SASL über Dovecot authentifizierst, so ists auch in der konfigurationvorlage für postfix/dovecot bei froxlor hinterlegt, kannst du die Option abschalten. Beim abschalten der Option wird im übrigen eh nichts gelöscht, die klartextpasswörter musst du händisch aus der tabelle löschen. Ich habs bei mir so getestet: - Option abschalten - neues Postfach anlegen (das wird dann ohne klartextpasswort angelegt) - Testen ob man E-Mails versenden kann.
  8. Hallo, mir ist aufgefallen, dass in der mail_users Tabelle die Passwörter der Benutzer einerseits in Klartext(password) und andererseits in gehashed (password_enc). Dovecot läuft ja mit password_enc, das passt ja soweit, aber pure/pro FTP + libnss-mysql rufen das plaintext password aus der froxlor Datenbank aus. So nehme ich an, derzeit kommen wir nicht darum rum passwörter in plaintext in der Datenbank zu speichern, oder? Ist da für die Zukunkft eine Änderung geplant,... in Sachen DSGVO und Datensicherheit sind Plaintext Passwörter in einer Datenbank schon knapp fahrlässig ? LG Patrick
  9. damit ist die Warn E-Mail eigentlich für Hugo, da sobald ein Kunde mehr E-Mail Kontingent als Webspace verbraucht, die Warn E-Mail versandt wird ? habe jetzt mal die Mailvorlage gelöscht. Damit sollten die Kunden zumindest nicht mehr mit Warnungen zugespammt werden ?
  10. Danke für die ausführliche Nachricht! Ich weiß eh, im Dashboard stimmt es dann. Aber warum sendet Froxlor dann eine Warnmeldung per E-Mail, dass der Speicherplatz voll ist ? Vor allem dürften die die Variablen für {DISKUSED} und {DISKAVAILABLE} falsch gesetzt sein, oder meine Installation hat da einen Haken "Sie haben bereits {DISKUSED} MB von Ihren insgesamt {DISKAVAILABLE} MB " Im Report berechnet er anscheinend es so: {DISKUSED} = web + mail + mysql {DISKAVAILABLE} = nur web Und damit kommt dann so eine Mail wie: "Sie haben bereits 3939 MB von Ihren insgesamt 2500 MB Speicherplatz verbraucht."
  11. Hallo, sorry für die späte Antwort! Hatte null Zeit, dann wieder drauf vergessen. Jetzt am 1. kam wieder die Mail mit den Warnmeldungen an alle Kunden. In der Mail steht zB folgendes: "Sie haben bereits 3939 MB von Ihren insgesamt 2500 MB Speicherplatz verbraucht." In diesen konkreten Fall hat der Kunde 2500 MB Webspace, und davon nur 10 MB benutzt. -> Da dürfte ja keine Warnung kommen. Der Kunde hat aber, und da liegt der Hund begraben: 5000 MB an E-Mail Speicherplatz, und davon 3939 zugewiesen. Die 3939,36 zugewiesener E-Mail Speicher dürfte für die Webspace Berechnung verwendet werden... Da hats was mit der Berechnung, da ist irgendwo eine Variable falsch gesetzt... Zwei Screenshots auch nur zur Untermauerung. Weißt, was ich mein? LG Patrick
  12. Hallo, seit neuesten, ich denke seit den letzten 3-4 Wochen bekommen unsere Kunden immer wieder Warn E-Mails dass der Webspace voll ist, obwohl das gar nicht stimmt, zB: "Sie haben bereits 3619.9 MB von Ihren insgesamt 2500 MB Speicherplatz verbraucht." In diesem Fall: 1% Webspace (MiB) 9.68 genutzt | 2500 verfügbar 100% E-Mail-Kontingent (MiB) 4000 genutzt 4000 verfügbar Irgendwas wird da auf einmal komplett falsch berechnet. Auf der Kiste läuft "Ubuntu 16.04.5 LTS". PHP für Froxlor: PHP 7.1.19-1+ubuntu16.04.1+deb.sury.org+1 Kann man sich das erklären, ev. irgendwelche Systemupdate von Ubuntu (PHP, Perl, etc). Der Rest scheint problemlos zu funktionieren. LG Patrick
  13. danke, auf das h?tte ich aber auch kommen k?nnen. das problem scheint beim mailtransport zu sein, dovecot scheint bei zustellung der mails nicht mal ansatzweise in den logs auf (im ggsatz zu pop3/imap). da werd ich mich ejtzt spielen und gleich mal auf die aktuelle froxlor upgraden =)
  14. Hallo, ich habe mich hier im Forum zwar schon schlau gemacht und den einen oder anderen Tipp gefunden, aber ich bekomme sieve nicht zum laufen... 1.) Wie ist es nun mit dem Autoresponder bei Froxlor? Bei Syscp lief das ja irgendwie ?ber Cron, ist dies nun auch ?ber Sieve realisiert? -- denn der funktioniert auch nicht, eben getestest.. 2.) Mein Sieve Problem. Habe Sieve soweit (hoffentlich richtig eingerichtet, und dabei folgende howtos/threads gefunden): http://forum.froxlor.org/index.php/topic/12578-solved-spam-im-spamordner-verschieben http://forum.froxlor.org/index.php/topic/12604-autoresponder/ Leider springt mir sieve immer noch nicht an und ich wei? nicht wo ich loggen / nachsehen k?nnte. Der Server selbst ist ein Ubuntu 14.04 und l?uft seit letzten Jahr eigentlich sehr stabil mit Froxlor. Die Konfiguration von Postfix/Dovecot wurde aus den Froxlor Konfigurationsbeispielen genommen. /etc/dovecot/conf.d/15-lda.conf: protocol lda { #mail_plugins = $mail_plugins mail_plugins = $mail_plugins quota sieve } /etc/dovecot/conf.d/90-sieve.conf plugin { sieve = /var/customers/mail/sieve/%d/%n/.dovecot.sieve sieve_dir = /var/customers/mail/sieve/%d/%n } Hier hatte ich auch noch was gefunden: 01-mail-stack-delivery.conf # LDA configuration protocol lda { postmaster_address = postmaster mail_plugins = sieve quota quota_full_tempfail = yes deliver_log_format = msgid=%m: %$ rejection_reason = Your message to <%t> was automatically rejected:%n%r } # Plugins configuration plugin { sieve=/var/customers/mail/sieve/%d/%n/.dovecot.sieve sieve_dir=/var/customers/mail/sieve/%d/%n quota = maildir } Ordner f?r sieve anlegen + rechte vergeben mkdir /var/customers/mail/sieve chown vmail.vmail /var/customers/mail/sieve Hier meine beispiel adresse: test@test.at das sieve script sollte dann ja hier liegen: /var/customers/mail/sieve/test.at/test das sieve script: .dovecot.sieve schaut so aus: require "fileinto"; if header :contains "subject" "test" { fileinto "Spam"; } das ganze wurde dann mit sievec kompiliert. Fertig. Geht nicht. Kann hier vl noch Postfix irgendwie reinpfuschen(mail deliver..?)? Meine Postfix Config sollte allerdings ok sein.
×
×
  • Create New...