Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

jogr

[solved] froxlor on gentoo

Recommended Posts

Hi out there,

 

I've tried to install froxlor via emerge on gentoo, following the install instruction described on the wiki http://wiki.froxlor....stall-gentoo-en (via no layman / custom local overlay path). Everything seems to work fine until I got to the point:

emerge -DNu froxlor

There I got

~ # emerge -DNu froxlor
Calculating dependencies / * Digest verification failed:
* /usr/local/overlays/froxlor/www-apps/froxlor/froxlor-9999.ebuild
* Reason: Filesize does not match recorded size
* Got: 51166
* Expected: 50943                                                                                                                                                                                   		... done!

>>> Verifying ebuild manifests

!!! Digest verification failed:
!!! /usr/local/overlays/froxlor/www-apps/froxlor/froxlor-9999.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 51166
!!! Expected: 50943

I used the following USE - Flags:

~ # cat /etc/portage/package.use | grep froxlor
www-apps/froxlor            	aps autoresponder bind dovecot ftpquota log mailquota ssl tickets awstats realtime

Share this post


Link to post
Share on other sites

Argh, yes, that's my fault, i fixed some minor issues in the 9999 ebuild, gimme a second and re-add the repository afterwards

 

EDIT: Damn, Dessa is not available at the moment so you have to do it manually (for now):

 

cd /var/lib/layman/froxlor/www-apps/froxlor/
ebuild froxlor-9999.ebuild manifest
emerge froxlor

 

EDIT 2: Please don't use the "realtime" feature, it's strongly discouraged

Share this post


Link to post
Share on other sites

It seems, that there will be no changes

root@myhost /var/lib/layman/froxlor/www-apps/froxlor # rm /usr/portage/metadata/timestamp.chk
root@myhost /var/lib/layman/froxlor/www-apps/froxlor # svn co http://svn.froxlor.org/branches/extras/dist/gentoo/froxlor/ /usr/local/overlays/froxlor
Checked out revision 1301.
root@myhost /var/lib/layman/froxlor/www-apps/froxlor # emerge --sync --quiet
root@myhost /var/lib/layman/froxlor/www-apps/froxlor # cd /var/lib/layman/froxlor/www-apps/froxlor/
root@myhost /var/lib/layman/froxlor/www-apps/froxlor # ebuild froxlor-9999.ebuild manifest
Appending /var/lib/layman/froxlor to PORTDIR_OVERLAY...
>>> Creating Manifest for /var/lib/layman/froxlor/www-apps/froxlor
root@myhost /var/lib/layman/froxlor/www-apps/froxlor # emerge -DNu froxlor
Calculating dependencies \ * Digest verification failed:
* /usr/local/overlays/froxlor/www-apps/froxlor/froxlor-9999.ebuild
* Reason: Filesize does not match recorded size
* Got: 51166
* Expected: 50943                                                                                                                                                                                   		... done!

>>> Verifying ebuild manifests

!!! Digest verification failed:
!!! /usr/local/overlays/froxlor/www-apps/froxlor/froxlor-9999.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 51166
!!! Expected: 50943
root@myhost /var/lib/layman/froxlor/www-apps/froxlor #

Share this post


Link to post
Share on other sites

Worked for me:

 

cd /var/lib/layman/froxlor/www-apps/froxlor/
rm Manifest
ebuild froxlor-9999.ebuild manifest
>>> Creating Manifest for /var/lib/layman/froxlor/www-apps/froxlor
emerge froxlor

Share this post


Link to post
Share on other sites

I've got it.

The point was, that I've used the "wrong overlay". I suggest, the way you posted was for using layman, I've choosen to follow the no - layman way in your wiki, so my overlay was located in /usr/local/overlays/froxlor

cd  /usr/local/overlays/froxlor
rm Manifest
ebuild froxlor-9999.ebuild manifest
emerge -DNu froxlor

 

solves the problem

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...