Jump to content
Froxlor Forum

Hi Team, Updating to .10.38.3. Causes Error

Solomon Collins

Recommended Posts

Dear froxlor-team,

the following error has been reported by a user:

42000 SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 767 bytes

File: lib/Froxlor/Database/Database.php:597

#0 [internal function]: PDO->query('CREATE TABLE `p...')
#1 lib/Froxlor/Database/Database.php(597): call_user_func_array(Array, Array)
#2 install/updates/froxlor/update_2.x.inc.php(67): Froxlor\Database\Database::__callStatic('query', Array)
#3 install/updatesql.php(56): include_once('/var/www/html/f...')
#4 admin_updates.php(53): include_once('/var/www/html/f...')
#5 {main}


User-Area: admin
Froxlor-version: 2.0.13
DB-version: 202302030

Database: 5.5.5-10.1.48-MariaDB-0+deb9u2End of report


Any Ideas?



Link to comment
Share on other sites

No, it installed the current latest version which is 2.0.13

Debian 9 is pretty old as well as your mariadb server.

You might want to try the following mysql-server options:


#t uf8mb4 long key index

innodb_large_prefix = 1

innodb_file_format = barracuda

Innodb_file_format_max = barracuda

innodb_file_per_table = 1

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...