Jump to content
Froxlor Forum
  • 0

proftpd login with long usernames not possible [solved]



I cloud not log on to a newly created FTP account containing a domain name. The resulting username was > 30 chars.

Proftpd logged:

mod_sql/4.3: unrecoverable backend error: (1406) Data too long for column 'name' at row 1
mod_sql/4.3: check the SQLLogFile for more details

Turning on the SQLLogFile option, I found out that the user/password query was working just fine, but the following INSERT INTO ftp_quotatallies would fail.

The name colum in ftp_quotatallies was VARCHAR(30) in that instance and I changed it to VARCHAR(255).

I do not know if this would affect new froxlor installs. Might be an old bug, since this froxlor instance has been running for a long time, regularly updated.

Solved it for me, might help others 🙂

All the best,



Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...