Jump to content
Froxlor Forum
  • 0

DKIM mwessage not signed


steve_adams
 Share

Question

I've followed instructions from several different threads in these support forms and configured dkim on my server. The DKIM DNS entries are in place and the keys are coming back validated. However, I cannot get postfix to sign the emails with the keys!?

Here's my /etc/postfix/main.cf section:

# Milter configuration
milter_default_action = accept
milter_protocol = 6
smtpd_milters = local:opendkim/opendkim.sock
non_smtpd_milters = local:opendkim/opendkim.sock

 

I'm running this on Debian Buster with mail_version = 3.4.14

Where and how should I adjust the postfix config files to inject the froxlor generated DKIM keys in /etc/postfix/dkim?

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Postfix does not "inject" the keys...that's why you need opendkim. Did you configure opendkim accordingly? Any log entries of that service? Any log entry at all regarding dkim?! 

Link to comment
Share on other sites

  • 0

Yes, I configured opendkim and have located the /etc/postfix/KeyTable file as the file to correctly change the path to the key files generated by Froxlor. The issue now remains that the formatting of the path in the KeyTable doesn't readily jive Froxlor's selector._domainkey.domain.dom style. Effectively, Froxlor formulates the domain_id into the selector.

I'm wondering if it might make more sense to use Rspamd since their path formatting relies on $domain and $selector variables rather than a uniform key formula. Or, perhaps try to store the path names in a database?

Yes, I can see connection in the log files, but not to the correct path where the Froxlor generated keys exist.

Link to comment
Share on other sites

  • 0

has anyone put together a version of /lib/Froxlor/Dns/Dns.php or DnsBase.php that alters the construction of $selector or $domain that would enable a reformatting of the keys in /etc/postfix/dkim to an OpenDkim suitable KeyTable formula?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...