Jump to content
Froxlor Forum
  • 0

Debian Lenny Install issue



Ok, so I've tried two ways to install on a clean Lenny installation. I tried manually installing by installing the required packages and downloading the tar file. I have also tried installing via apt using the debian.froxlor repository. Everything goes fine until it gets to the point where I should be able to go to http://<ip address>/froxlor/


I go to that URL and I am told I need to Configure Froxlor First. Ok (so far so good). Click on the link to go to /install/install.php and Apache refuses to parse that .php file. It prompts me to download the php file instead of parsing it server-side. I tried dropping a generic phpinfo() php file in the /install folder to make sure it executes. It worked fine.


I know I am missing something obvious here. Anyone else had this issue?

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

Did you configured the PHP Module for Apache correct and is the module activated?


Yes. Very strange, indeed. I could drop a file that would echo phpinfo() in any of the folders and it would execute fine, but the install.php would always try to download in the browser. I removed everything, re-installed apache/php5, and then did another apt-get install froxlor and it all works now. No idea what the problem was, but it seems to be all good now.

Link to comment
Share on other sites

baby-debian might need a "apache stop" and "apache start"....loving debian for this sh*t


I tried restarting apache while I was messing around trying to get it going. I think it may have been an issue with the default image my VPS provider uses for Lenny. I've noticed a few screwy things. Permissions on /tmp were wrong that prevented MySQL from running properly. Took me a bit to figure that one out.


Regardless, it is going now. I saw on the Twitter feed that there's a version of Froxlor that supports nginx available for testing. Looking forward to that one. Heck, if it is available to test I am willing to do so. Nothing mission critical on my server.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...