Jump to content
Froxlor Forum
  • 0
lanbo

custom extension= not being propagated with php-fpm

Question

I have a custom PHP Configuration for most of my domains.

I can set the typical stuff such as:

upload_max_filesize = 32M
 

I used to set also some extensions such as

extension=xxxx.so

Well, when I run phpinfo() on a process on apache for a particular domain, I see that upload_max_filesize is correctly set to any value that I choose.

But the extension is not set.

I finally had to add the "extension=xxx.so" in:

/etc/php/7.2/fpm/php.ini

 

Is that an expected behaviour with php-fpm?

With FCGID it worked just fine.

I tried everything. Setting the full path, etc. The logs did not show anything.

The extension works when I set it directly here /etc/php/7.2/fpm/php.ini

 

The problem is that the extension then is available for all the domains. It is not a big problem.

Just wanted to let you know in case it is a bug.

 

Thanks

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1
9 minutes ago, lanbo said:

You mean this directive can be blocked somehow?

As you can see in the screenshot above, for FPM we need to know what directive is in which category (php_value, php_flag, php_admin_value, php_admin_flag) and therefore we cannot use ANY possible directive by default. If you are missing any, just add them to the corresponding list

Share this post


Link to post
Share on other sites
  • 0

Check the settings whether "extension" is within the allowed ini directives

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, d00p said:

Check the settings whether "extension" is within the allowed ini directives

I'm not sure I understand what I have to check. Which settings?

http://php.net/manual/en/ini.list.php

"extension" is a valid directive. In fact I'm using it in /etc/php/7.2/fpm/php.ini

I think I did not understand your question. You mean this directive can be blocked somehow?

Share this post


Link to post
Share on other sites
  • 0

 

4 hours ago, d00p said:

As you can see in the screenshot above, for FPM we need to know what directive is in which category (php_value, php_flag, php_admin_value, php_admin_flag) and therefore we cannot use ANY possible directive by default. If you are missing any, just add them to the corresponding list

Thanks @d00p!

Did not know that.

I added the extension directive to php_admin_values and it worked great!

I could remove it from /etc/php/7.2/fpm/php.ini. It's cleaner now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×