Jump to content
Froxlor Forum
  • 0

Education Domain System


rashantha
 Share

Question

Hi Everyone,

I am setting Froxlor for a school. We have a main domain school.org which is hosted outside.

I have created froxlor under dev.school.org, DNS is controlled outside of froxlor and dev.school.org works as advertised.

I need to create several subdomains

mailchimp.school.org
receipts.school.org
detention.school.org
council.school.org
wiki.school.org

These will all run in froxlor and will be accessible only in the intranet

Can I assign these subdomains to multiple customers or do they have to be all assigned to 1 customer?

Do I create school.org as domain or can I create subdomain.school.org as the main domain?

I might even want to give access to each student so they can build there own wordpress site so I might have student1.school.org, student2.school.org

Thanks

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0
8 hours ago, rashantha said:

Can I assign these subdomains to multiple customers or do they have to be all assigned to 1 customer?

Can be assigned to multiple customers, when added as admin/reseller

8 hours ago, rashantha said:

Do I create school.org as domain or can I create subdomain.school.org as the main domain?

You can create the subdomain right-away, but if you also add school.org, add it first because you will need to add the others as "main but subdomain to: school.org" in order for the webserver vhosts to be in correct order

8 hours ago, rashantha said:

I might even want to give access to each student so they can build there own wordpress site so I might have student1.school.org, student2.school.org

Same as the first part...create customer, add studentX.school.org domain, have fun :)

Link to comment
Share on other sites

  • 0

I was having some weird issues with FTP and sub.school.org was going to Forbidden you dont have access to this server page. So I decided to delete the 1 user and the domains and start fresh.

On creating the 1st User should i uncheck create standard subdomain. The froxlor server is called dev.school.org. I am assuming if this is checked it's going to create a subdomain council.dev.school.org (if so it's not needed).

Sorry for the tool n00b question.

 

image.thumb.png.0b589911935d03c938a989aa74bf3b98.png

Link to comment
Share on other sites

  • 0

The default standard-subdomain is [username].[froxlor-system-hostname], you can adjust the domain-part in the settings so it becomes [username].[std-subdomain-domain-from-settings]

The FTP issue should not be related to any domain, as long as it points to the server, the login should work

Link to comment
Share on other sites

  • 0

So here is what I did. hostname dev.school.org

1. Created 1st User - council

2. Created domain school.org assigned it to council

3. Created subdomain council under user council. didn't change any paths

4. Created ftp account under council - can not login via council@dev.school.org or council@council.school.org (authentication failed)

5. index.html is in /var/customers/webs/council but if you go to council.school.org you get a 403 forbidden

ports to dev.school.org open 22, 80

what is the path to check vhost file? I didn't change any settings. maybe it will give me a clue.

dev.school.org/froxlor works, i can log in as admin as well as user council

Link to comment
Share on other sites

  • 0
28 minutes ago, d00p said:
 

The default standard-subdomain is [username].[froxlor-system-hostname], you can adjust the domain-part in the settings so it becomes [username].[std-subdomain-domain-from-settings]

 

i tried all 3 council.dev.school.org, dev.school.org, council.school.org

Forbidden

You don't have permission to access / on this server.

Link to comment
Share on other sites

  • 0

Here's a silly question do I have to run this first...

image.png.c1fc6d2841c3fc50843211d62810646f.png

[root@dev lib]# chown root:0 /etc/apache2/sites-enabled/
chmod 0600 /etc/apache2/sites-enabled/
mkdir -p /var/customers/webs/
mkdir -p /var/customers/logs/
mkdir -p /var/customers/tmp
chmod 1777 /var/customers/tmp
systemctl reload-or-restart httpd.servicechown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
[root@dev lib]# chmod 0600 /etc/apache2/sites-enabled/
chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
[root@dev lib]# chown root:0 /etc/apache2/sites-enabled/
chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
[root@dev lib]# chmod 0600 /etc/apache2/sites-enabled/
chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
[root@dev lib]# mkdir -p /var/customers/webs/
[root@dev lib]# mkdir -p /var/customers/logs/
[root@dev lib]# mkdir -p /var/customers/tmp
[root@dev lib]# chmod 1777 /var/customers/tmp
[root@dev lib]# systemctl reload-or-restart httpd.service
 

 

Link to comment
Share on other sites

  • 0
19 hours ago, rashantha said:
 

So am I getting these errors because I tried to run configuration after creating the user.


systemctl reload-or-restart httpd.servicechown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
[root@dev lib]# chmod 0600 /etc/apache2/sites-enabled/
chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
[root@dev lib]# chown root:0 /etc/apache2/sites-enabled/
chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
[root@dev lib]# chmod 0600 /etc/apache2/sites-enabled/
chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
[root@dev lib]# mkdir -p /var/customers/webs/
[root@dev lib]# mkdir -p /var/customers/logs/
[root@dev lib]# mkdir -p /var/customers/tmp
[root@dev lib]# chmod 1777 /var/customers/tmp
[root@dev lib]# systemctl reload-or-restart httpd.service
 

 

1

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...