Jump to content
Froxlor Forum
  • 0

opcache php.ini


MGmeiner
 Share

Question

Hallo.

Wenn ich direkt über Froxlor Admin in meine die PHP-Konfig (php.ini) folgendes definiere

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

und fpm neustarte.

service php7.1-fpm restart

Bekomme ich in meiner Cloud folgende Fehler.

Der PHP-OPcache ist nicht richtig konfiguriert. Für eine bessere Leistung empfiehlt es sich folgende Einstellungen in der php.ini vorzunehmen: opcache.enable=1 opcache.enable_cli=1 opcache.interned_strings_buffer=8 opcache.max_accelerated_files=10000 opcache.memory_consumption=128 opcache.save_comments=1 opcache.revalidate_freq=1 Bitte überprüfen Sie noch einmal die Installationsanleitungen ↗ und kontrollieren Sie das Protokoll auf mögliche Fehler oder Warnungen.

Wenn ich das ganze aber in /etc/php/7.1/fpm/php.ini  eintrage funktioniert es.

Anbei noch meine ganze php.ini

allow_call_time_pass_reference = Off
allow_url_fopen = On
asp_tags = Off
disable_classes =
disable_functions = curl_multi_exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,shell_exec,show_source,system
display_errors = Off
display_startup_errors = Off
enable_dl = Off
error_reporting = E_ALL & ~E_NOTICE
expose_php = Off
file_uploads = On
cgi.force_redirect = 1
gpc_order = "GPC"
html_errors = Off
ignore_repeated_errors = Off
ignore_repeated_source = Off
include_path = ".:{PEAR_DIR}"
log_errors = On
log_errors_max_len = 1024
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
max_execution_time = 3600
max_input_time = 3600
memory_limit = 1024M
{OPEN_BASEDIR_C}open_basedir = {OPEN_BASEDIR}:/dev/urandom
output_buffering = Off
post_max_size = 16400M
precision = 14
register_argc_argv = Off
register_globals = Off
report_memleaks = On
sendmail_path = "/usr/sbin/sendmail -t -i -f {CUSTOMER_EMAIL}"
session.auto_start = 0
session.bug_compat_42 = 0
session.bug_compat_warn = 1
session.cache_expire = 180
session.cache_limiter = nocache
session.cookie_domain =
session.cookie_lifetime = 0
session.cookie_path = /
session.entropy_file = /dev/urandom
session.entropy_length = 16
session.gc_divisor = 1000
session.gc_maxlifetime = 1440
session.gc_probability = 1
session.name = PHPSESSID
session.referer_check =
session.save_handler = files
session.save_path = "{TMP_DIR}"
session.serialize_handler = php
session.use_cookies = 1
session.use_trans_sid = 0
short_open_tag = On
suhosin.mail.protect = 1
suhosin.simulation = Off
track_errors = Off
upload_max_filesize = 16G
upload_tmp_dir = "{TMP_DIR}"
variables_order = "GPCS"
;mail.add_x_header = On
;mail.log = "/var/log/phpmail.log"

opcache.restrict_api = "{DOCUMENT_ROOT}"

extension = apc.so

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1



Mache ich das was falsch? :D:)

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

wenn du FPM nutzt musste mal in die von froxlor erstellen pool-configs schauen evtl stehen die anweisungen dort nicht drin, d.h. du musst die noch in den globalen Einstellungen hinterlegen, denn FPM pool configs hinterlegen die anweisungen mit php_value / php_admin_value und php_flag / php_admin_flag - Froxlor kann nicht wissen, welche Anweisung in welche Kategorie fällt, daher musst du das in den Einstellungen angeben

Link to comment
Share on other sites

  • 0

Also in der /etc/php/7.1/fpm/pool.d/DOMAIN.com.conf 

Steht es so drinnen

php_admin_flag[opcache.enable] = 1
php_admin_value[opcache.interned_strings_buffer] = 8
php_admin_value[opcache.max_accelerated_files] = 10000
php_admin_value[opcache.memory_consumption] = 128
php_admin_flag[opcache.save_comments] = 1
php_admin_value[opcache.revalidate_freq] = 1

 

Link to comment
Share on other sites

  • 0

Nein, diese wird in der NextCloud unter Einstellungen angezeigt.
Aber sobald ich es direkt in der /etc/php/7.1/fpm/php.ini eintrage kommt die Fehlermeldung nicht mehr.

Und wenn ich es über Froxlor eintrage hat es keine Auswirkungen.

Habe schon apache2 + php-fpm neu gestartet.

Bildschirmfoto 2018-03-28 um 17.04.43.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...