Jump to content
Froxlor Forum
  • 0

Apache Service startet nicht mehr


MGmeiner
 Share

Question

Hallo.

Ich habe mir gerade einen neuen Root-Server gegönnt :)
und habe nun ein Problem, ich habe SSL aktiviert und habe wie bei meinem anderen Server die Einstellungen gewählt.

Nun kann ich auf keine Seite (Froxlor oder Testseite / Kunde) zugreifen.

 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug
[information] cron_tasks: Searching for tasks to do
[information] apache::createIpPort: creating ip/port settings for  188.XX.XX.XX:80
[notice] 188.XX.XX.XX:80 :: namevirtualhost-statement no longer needed for apache-2.4
[debug] 188.XX.XX.XX:80 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  188.XX.XX.XX:443
[debug] 188.XX.XX.XX:443 :: inserted listen-statement
[debug] 188.XX.XX.XX:443 :: inserted vhostcontainer
[information] apache::createVirtualHosts: creating vhost container for domain 2, customer MGmeiner
[information] apache::createVirtualHosts: creating vhost container for domain 1, customer MGmeiner
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::reload: running service php7.2-fpm restart
[information] apache::reload: fpm config directory "/etc/php5/fpm/pool.d/" is empty. Creating dummy.
[information] apache::reload: running /etc/init.d/php5-fpm restart
[information] apache::reload: reloading apache
Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
[notice] Checking system's last guid

Wenn ich dann 

journalctl -xn
Feb 23 09:26:25 SERVERNAME systemd[1]: Stopping The PHP 7.2 FastCGI Process Manager...
-- Subject: Unit php7.2-fpm.service has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit php7.2-fpm.service has begun shutting down.
Feb 23 09:26:25 SERVERNAME systemd[1]: Starting The PHP 7.2 FastCGI Process Manager...
-- Subject: Unit php7.2-fpm.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit php7.2-fpm.service has begun starting up.
Feb 23 09:26:25 SERVERNAME systemd[1]: Started The PHP 7.2 FastCGI Process Manager.
-- Subject: Unit php7.2-fpm.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit php7.2-fpm.service has finished starting up.
-- 
-- The start-up result is done.
Feb 23 09:26:25 SERVERNAME systemd[1]: Stopping The PHP FastCGI Process Manager...
-- Subject: Unit php5-fpm.service has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit php5-fpm.service has begun shutting down.
Feb 23 09:26:25 SERVERNAME systemd[1]: Starting The PHP FastCGI Process Manager...
-- Subject: Unit php5-fpm.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit php5-fpm.service has begun starting up.
Feb 23 09:26:25 SERVERNAME systemd[1]: Started The PHP FastCGI Process Manager.
-- Subject: Unit php5-fpm.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit php5-fpm.service has finished starting up.
-- 
-- The start-up result is done.

Feb 23 09:26:25 SERVERNAME systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.

Wo finde ich heraus wo es hängt? Oder übersehe ich hier etwas?

In der Apache Log steht

/var/log/apache2/error.log 

[Fri Feb 23 09:12:12.313874 2018] [suexec:notice] [pid 22182] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Fri Feb 23 09:12:12.335296 2018] [:notice] [pid 22186] FastCGI: process manager initialized (pid 22186)
[Fri Feb 23 09:12:12.368974 2018] [mpm_prefork:notice] [pid 22183] AH00163: Apache/2.4.10 (Debian) mod_fastcgi/mod_fastcgi-SNAP-0910052141 OpenSSL/1.0.1t configured -- resuming normal operations
[Fri Feb 23 09:12:12.369028 2018] [core:notice] [pid 22183] AH00094: Command line: '/usr/sbin/apache2'
[Fri Feb 23 09:12:38.965355 2018] [mpm_prefork:notice] [pid 22183] AH00171: Graceful restart requested, doing restart
(98)Address already in use: AH00072: make_sock: could not bind to address 188.XX.XX.XX:443
[Fri Feb 23 09:12:39.075757 2018] [mpm_prefork:alert] [pid 22183] no listening sockets available, shutting down
[Fri Feb 23 09:12:39.075767 2018] [:emerg] [pid 22183] AH00019: Unable to open logs, exiting

lg Matthias

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
15 minutes ago, MGmeiner said:

(98)Address already in use: AH00072: make_sock: could not bind to address 188.68.42.74:443

Läuft wohl noch was anderes auf Port 443...hast du vllt in froxlor bei der ssl-ip/port ausversehen das "Listen" auf "ja" gestellt, sodass apache nun versucht zweimal auf den port zu binden? Lösche am besten mal die ssl-vhosts in sites-enabled, dann sollte der apache restarten und du kannst nachgucken

Link to comment
Share on other sites

  • 0
Feb 23 09:26:25 SERVERNAME systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.

Mal gegoogelt? Der Dienst ist inaktiv und somit kannst du den nicht (re)starten. Hast du vllt von einem anderen Webserver auf Apache gewechselt oder ähnliches? Abhilfe schafft jedenfalls:

systemctl enable apache2

 

Link to comment
Share on other sites

  • 0

Ich habe lange gegooglet :D aber immer in zusammenhang mit SSL, weil davor ging alles.
Ich habe zu keinem anderen Webserver gewechselt Apache läuft seit Anfang an.

Wenn ich systemctl enable apache2 eingebe erhalte ich

Synchronizing state for apache2.service with sysvinit using update-rc.d...
Executing /usr/sbin/update-rc.d apache2 defaults
Executing /usr/sbin/update-rc.d apache2 enable

Mit dem gleichen Ergebnis wie Oben.

 

lg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...