Jump to content
Froxlor Forum

Tealk

Members
  • Content Count

    177
  • Joined

  • Last visited

Everything posted by Tealk

  1. Also seit gerade eben funktioniert es wieder, ich finde aber auch nichts in einer log das ein cron gelaufen wäre. Das verwirrt mich jetzt schon sehr, das müsste doch eig. mit dem libnss-extrausers zusammen hängen wen es um die Berechtigung geht?
  2. Hallo, ich habe seit 20 minuten das Problem das eine 404 Meldung bei meinen Seiten bekomme, die Log schreibt: 2020/03/10 15:10:56 [crit] 936#936: *286 open() "/var/customers/webs/Anzah/anzahcraft.de/index.php" failed (13: Permission denied), client: 17.58.96.83, server: anzahcraft.de, request: "GET /forums/allgemeines.87/ HTTP/1.1", host: "anzahcraft.de" Ich habe schon alle configs kontrolliert, nginx sagt auch alle configs seien in Ordnung. Froxlor habe ich auch schon alle configs neu schreiben lassen und den Server habe ich sogar einmal neu gestartet. Der Fehler bleibt aber
  3. Kein Ding, wollte es nur der Vollständigkeit halber anmerken, falls das jemand liest.
  4. Super hat geklappt. Der Befehl zum löschen ist aber anscheinend ohne -d root/.acme.sh/acme.sh remove [domain] und bei ecc Zertifikaten muss man am ende noch -ecc anhängen root/.acme.sh/acme.sh remove [domain] -ecc
  5. Hallo, ich habe heute folgenden Beitrag gefunden und bin mit einigen Domains betroffen, wie kann ich die Zertifikate Zwangs erneuern? https://community.letsencrypt.org/t/revoking-certain-certificates-on-march-4/114864 Weil soweit ich das verstanden habe macht das ja acme.sh Script.
  6. gibt es bei letsencrypt die sperre nicht mehr? Weil die ganzen Zertifikate sind ja nagelneu.
  7. ja das habe ich bei allen Domains gemacht die den fehler aufgewiesen haben habe gerade 30 mal diese blöde tabelle befüllt. Bei einer domain stimmt es aber dennoch nicht zusammen. Ich habe keine ahnung was dieses blöde acme.sh script da gemacht hat aber anscheinend Riesen bockmist.
  8. die renew time sollte doch vor dem expires sein, reicht es wenn ich NextRenewTimeStr entsprechend anpasse?
  9. ok dann bin ich echt überfragt was da schief gelaufen ist, weil ca die hälfte der domains sind betroffen der rest ist ok.
  10. Wo ich gerade die DB durch gehe, viele Einträge sind nur einen Monat verschoben, könnte es sein das irgendwo bei der Berechnung da was falsch gelaufen ist? Ok die files .cer und .key sind unterschiedlich, versteh das ganze grad wirklich nicht.
  11. ich kann auch nur sagen das das mit dem Update auf 0.10.12 (DB: 201912313) aufgetreten ist. Davor lief es ja problemlos. Und ich hab eine menge Domain Zertifikate deren Update über das ganze Jahr verteilt ist, daher wäre das sicher recht schnell aufgefallen.
  12. hmm, glaub nicht das das die beste Möglichkeit ist. Ich hab auch mal die syslog nach acme.sh durchsucht, dorft finde ich nur die froxlor Fehlermeldung. Also ich finde wirklich nichts was auf das ausführen der datei hindeutet.
  13. Würde "froxlor_master_cronjob.php --force --debug" die Einträge neu machen wen man die aus der db löscht?
  14. Also eig. niemand weil sonst keiner zugangsdaten hat. Und wenn sich einer unberechtigt zugang verschafft, hat der glaub ich andere Ziele als mir zertifikate zu erstellen. ty, das einfügen hat schon mal geklappt, aber muss ich das dann gleich für alle machen? Weil ich ja für alle Domains die skip Meldung bekomme?
  15. aber woher kommt das dann? Weil wie gesagt es gibt keinen cron oder irgend einen Hinweis das das separat aufgerufen wird. Was kommt denn in das feld chainfile? ssl_cert_file=rollenspiel.social.cer ssl_key_file=rollenspiel.social.key ssl_ca_file=ca.cer ssl_cert_chainfile= ssl_csr_file=rollenspiel.social.csr ssl_fullchain_file=fullchain.cer
  16. also ich finde im System dafür keinen cronjob, also sollte das nur über froxlor laufen. Und wie kann ich das dann importieren?
  17. Da sagt das Cert aber etwas anderes: Und auch Froxlor:
  18. Da stimme ich dir zu, ein Fehler in der acme.sh? Kann man noch irgendwie sehen warum der skipt?
  19. Ok jetzt hab ich nur noch einen Eintrag, der ist aber korrekt das der morgen ausläuft: [debug] https://github.com/Neilpang/acme.sh v2.8.4 [Fri 17 Jan 2020 10:28:05 AM CET] Renew: 'rollenspiel.social' [Fri 17 Jan 2020 10:28:05 AM CET] Skip, Next renewal time is: Mon 17 Feb 2020 09:10:24 PM UTC [Fri 17 Jan 2020 10:28:05 AM CET] Add '--force' to force to renew. [error] Could not get Let's Encrypt certificate for rollenspiel.social: https://github.com/Neilpang/acme.sh v2.8.4 [Fri 17 Jan 2020 10:28:05 AM CET] Renew: 'rollenspiel.social' [Fri 17 Jan 2020 10:28:05 AM CET] Skip, Next renewal time
  20. Ich wollte nur sichergehen. Ok hab das jetzt umgestellt und bekomm dennoch 2 Domains angezeigt das der das Zert Updaten will: renew wäre am 06.02.2020 15:00:18, die 30 Tage habe ich testweise mal auf 5 gestellt und dennoch: v2.8.4 [Fri 17 Jan 2020 09:59:37 AM CET] Renew: 'froxlor.DOMAIN1' [Fri 17 Jan 2020 09:59:37 AM CET] Skip, Next renewal time is: Sat 07 Mar 2020 02:10:24 PM UTC [Fri 17 Jan 2020 09:59:37 AM CET] Add '--force' to force to renew. [error] Could not get Let's Encrypt certificate for froxlor.DOMAIN1: https://github.com/Neilpang/acme.sh v2.8.4 [Fri 17 Jan 2020
  21. Also für anzahcraft.de steht in expirationdate "2020-02-06 21:17:11" in der Tabelle, das wären noch 19 Tage. Eine renew spalte habe ich nicht, falls die da sein sollte ist was in der DB verbugt.
  22. Anbei die Log: [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] Updating certificate for froxlor.DOMAIN1 [information] Checking for LetsEncrypt client upgrades before renewing certificates: [Fri 17 Jan 2020 07:55:42 AM CET] Already uptodate! [Fri 17 Jan 2020 07:55:42 AM CET] Upgrade success! [Fri 17 Jan 2020 07:55:42 AM CET] Removing cron job [debug] https://github.com/Neilpang/acme.sh v2.8.4 [Fri 17 Jan 2020 07:55:42 AM CET]
  23. DNS Einträge sind seit Ewigkeiten unverändert, habe ich kontrolliert, wildcard eintrag für Subdomains die auf den Froxlor Server gehen. Und aufregen würde ich mich nur weil ich seit Tagen keine Lösung für das Problem gefunden habe... Wenn ich nicht alles doppelt und dreifach kontrolliert hätte würde ich mich auch gar nicht melden. Habe 6 Domains drauf liegen, von unterschiedlichsten Anbietern, alle weisen das selbe Problem auf.
  24. Hi, ich habe seit dem 0.10.12 (DB: 201912313) Update das Problem das Froxlor alle 5 Minuten die Webserver Konfiguration neu erstellen will und das stört den Betrieb doch langsam. Das ist das einzige was ich in der Log finde: 15.01.20 12:45:06 error USER Could not get Let's Encrypt certificate for rollenspiel.social: [Wed 15 Jan 2020 12:45:06 PM CET] Renew: 'rollenspiel.social' [Wed 15 Jan 2020 12:45:06 PM CET] Skip, Next renewal time is: Mon 17 Feb 2020 09:10:24 PM UTC [Wed 15 Jan 2020 12:45:06 PM CET] Add '--force' to force to renew. 15.01.20 12:50:05 error USER Could not
×
×
  • Create New...