Jump to content
Froxlor Forum

Leaderboard


Popular Content

Showing content with the highest reputation since 07/09/19 in Posts

  1. 1 point
    I saw the Github notification. I didn't have the opportunity to test. Anyway, that fix worked.
  2. 1 point
    For one of my friend's company this _could_ be interesting, if you have proper backups / depending on how those are handled. This is the biggest thing that keeps us from moving to other solutions, currently we use duplicity to backup encrypted on some cloud service(s) and moving elsewhere would mean usually a lot of drawbacks on the backups / backup retention time etc. But just see it as note, maybe many other customers have other problems / priorities and this won't be one with them maybe. Anyways: Good luck and success with your new project!
  3. 1 point
    Hi zusammen, in Froxlor habe ich SSL aktiviert, ein Zertifikat zu einer Domain erstellt und der Domain den Port 443 zugewiesen. Jetzt startet der apache Server nicht mehr mit dem Fehler: apachectl[852]: (98)Address already in use: AH00072: make_sock: could not bind to address IP:443 Ich hab schon im Forum gesucht, einen Hinweis gefunden, dass ein "listing" Setting gesetzt sein könnte. Bewusst habe ich das nicht aktiviert. Ist jemand hier, der helfen kann? Kann natürlich gern mit Logfiles unterstützen Danke Euch und beste Grüße Tardar =============== edit: Kann gelöscht werden, konnte mir doch selbst helfen
  4. 1 point
    Thanks @d00p it is working now 😀👍
  5. 1 point
    Really appreciate your feedback. a2enmod ssl, yes. root@server6:/home/ubuntu# a2enmod ssl Considering dependency setenvif for ssl: Module setenvif already enabled Considering dependency mime for ssl: Module mime already enabled Considering dependency socache_shmcb for ssl: Module socache_shmcb already enabled Module ssl already enabled root@server6:/home/ubuntu# I am pretty certain it has something to do with the Oracle Cloud server setup. Something with the Virtual Nentwork adapter, the proxies in between etc. Not an expert on this and only a novice froxlor user so a bit over my head. Maybe one day somebody will pass by this forum entry and might have the solution for it. For now, it seems like not a good idea to use oracle cloud service for a LAMPF stack. I really like to thank you, d00p. Amazed at the level of support that you are offering via this forum. Hope the new adventure froxlor.com works our for you and your partners.
  6. 1 point
    Sound great! Good luck + best wishes for your new project!
  7. 1 point
    Hallo d00p. Das war ein sehr wertvoller Hinweis - irgendwie war der name server aktiviert. Ich habe ihn abgeschaltet und nun klappt es auch wieder mit dem Cronjob. Danke.
  8. 1 point
  9. 1 point
    So I started over, patiently following all of the instructions. It's working brilliantly. Thank you so much for Froxlor. Great product.
  10. 1 point
    Hallo, Postfix ist ein MTA und nicht über eine URL erreichbar. Gruss cardman
  11. 1 point
    Dieser punktgenaue, fixe Support gehört bezahlt - zumindest kann man sich da anderswo ein Scheibchen abschneiden. Die Fehlermeldung ist damit weg. Danke.
  12. 1 point
    Hi @d00p, sry das ich mich so spät melde. Du bist ein Traum, hat natürlich direkt geklappt. Mit Ondemand dürften dann auch durch die idle time andere Fehler bei mir verschwinden. Vielen Dank für deine Antwort 🙂
  13. 1 point
    Ja, das habe ich alles im Kopf und sammle gerade die Punkte zusammen die mir noch einfallen. Wollte mich nur in den Code einarbeiten und schauen wie schnell ich da zum Ergebnis komme. Gute Besserung!
  14. 1 point
  15. 1 point
    Moin, der OP hier. Sorry, dass ich mich die ganze Zeit nicht gemeldet habe - gab/ gibt leider schwerwiegende Gründe. Hat mit Krhs und Koma zu tun. Ist sonst nicht meine Art, mich nicht zu melden. Zur Sache: Ich hatte mir für's Erste mit dem viel weiter oben beschriebenen Workaround (www-data an Gruppen in /etc/groups) beholfen. Den von mir selbst reingesetzten Link auf einen älteren Post hatte ich angesehen, geprüft, brachte mich aber nicht weiter. Inzwischen wurden 2 Froxlor-Updates reingedrückt und siehe da, beim heutigen Prüfen stand auf einmal "www-data" mit hinter jedem Eintrag in /var/lib/extrausers/groups : jens:x:10002:jens,froxlorlocal,froxlorlocal,www-data Da ich nun wegen der privaten Schwierigkeiten tatsächlich sonst in der Zwischenzeit nichts geändert hatte, bin ich ein wenig irritiert, freue mich aber natürlich, dass es nun läuft. Ich versuche trotzdem, das Ganze noch nachzuvollziehen. Inzwischen ist in der Konfiguration auch der anfangs fehlende Eintrag drin: "system.httpuser": "www-data", "system.httpgroup": "www-data", Vermutlich macht der das aus. Nur, wie gesagt, k.A., wo der herkommt ... 😕 Grüße, Jens
  16. 1 point
    Hi there, I finally could update to the latest Froxlor version with the testing repository. Thanks!
  17. 1 point
    Das war DER Tipp! Jetzt funktioniert alles, wie gewollt. Vielen Dank!
  18. 1 point
    Ja, danke! Das richtige Zertifikat wird nun auch verbunden von der richtigen Domain. Ich habe außerdem auf meinen Homepages noch die Lösung für einen Fehler gefunden: Es wurde angezeigt, dass "Ihr Verbindung ist nicht sicher und mit dieser Webseite geteilte Informationen können von anderen eingesehen werden" Das hängt damit zusammen, dass ein paar Grafiken noch per HTTP statt HTTPS eingebunden waren. Endlich alles geklärt und fertig 🙂 Juhuuuuuuuuuuuu
  19. 1 point
  20. 1 point
    Thanks you very mucht for your work! I've already updates 4 hours ago witout any issue. BR Christian
  21. 1 point
    Danke, hat so funktioniert! Falls jemand noch Warnungsmails bei Quotaüberschreitung benötigt, hier mein Setup: vi /etc/dovecot/conf.d/90-quota.conf plugin { quota_warning = storage=95%% quota-warning 95 %u } service quota-warning { executable = script /usr/local/bin/quota-warning.sh user = vmail unix_listener quota-warning { user = vmail } } plugin { quota = maildir:User quota } Das eigentliche Mail wird über dieses Script versandt (chmod 755): vi /usr/local/bin/quota-warning.sh #!/bin/sh PERCENT=$1 USER=$2 cat << EOF | /usr/lib/dovecot/dovecot-lda -d $USER -o "plugin/quota=maildir:User quota:noenforcing" From: support@XXXXX To: $USER Date: `date +"%a, %d %b %Y %H:%M:%S %z"` Subject: Ihr Postfach ist fast voll! Content-Type: text/html; charset=UTF-8 Content-Transfer-Encoding: 8bit Ihr Postfach $USER ist aktuell zu $PERCENT% belegt. Bitte archivieren oder entfernen Sie alte, nicht mehr benötige Nachrichten. Andernfalls könnte es vorkommen, dass Sie keine neuen Nachrichten mehr empfangen können! Bei Fragen stehen wir Ihnen unter XXXXX oder unter support@XXXX zur Verfuegung. Ihr Hosting Team EOF
  22. 1 point
    I've struggled with this issue myself now for a couple of days. My goal was to activate Apache + mpm_event + php7.3-fpm. For now, i playing around with a WordPress installation and it runs fast as hell (considering WordPress with OPCache and RedisCache-Server, without any WordPress caching plugin). TTFB is around 170ms, I am satisfied. Finally I solved it ? (thankfully without fiddling in conf-Files) by disabling the Apache-conf for php7.3-fpm (in my case php7.3): a2disconf php7.3-fpm (removes /etc/apache2/conf-enabled/php7.3-fpm.conf) I searched for the string "php7.3-fpm.sock" in files like this: grep -iRl [text-string-to-search] [search-in-this-folder] grep -iRl 'php7.3-fpm.sock' /etc/ I found out this string is in /etc/apache2/conf-enabled/php7.3-fpm.conf. The file (or a symlink) php7.3-fpm.config MUST NOT be in the directory /etc/apache2/conf-enabled!! Other steps I made to get Apache + mpm_event + php7.3-fpm to work: a2dismod php7.3: the Apache php-module is not needed and anyway incompatible with mpm_event a2dismod php7.3 a2dismod mpm_prefork a2enmod mpm_event service apache2 restart Now check if mpm_event is running: apachectl -V The output should contain "Server MPM: event". Also check via phpinfo() if under "Server API" the value "FPM/FastCGI" is written. Other things I found out, it is not directly related to php-fpm, but I've struggled with issues at the same time: /var/customers/tmp/froxlor.panel/ has do be owned by froxlorlocal: chown froxlorlocal:froxlorlocal /var/customers/tmp/froxlor.panel /var/www/php-fpm/froxlor.panel/ has do be owned by froxlorlocal: chown froxlorlocal:froxlorlocal /var/www/php-fpm/froxlor.panel Check your Webserver-Settings: Settings -> Webserver-Settings: The username webserver and the groupname webserver has to be "www-data". Hope this helps someone. If I wrote anything wrong, please just leave a reply, i'm also grateful for other hints on this topic.
  23. -1 points
    Problem 1: Alle PHP-spezifischen Einstellungen sind über die gesamte Oberfläche verstreut. (Usability) Problem 2: Der Binary-Pfad unterscheidet sich nicht bei den bei den vHosts Froxlor und Default. Ergo kann man als normal denkender Mensch erwarten, dass beide vHosts auch gleichermaßen die selbe PHP Version (7.3) nutzen müssten. Eine Dropdown-Lösung mit Versions-Auswahl wäre wesentlich intuitiver gewesen. Problem 3: Definiere "gewisse basics". Du selbst drückst Dich leider auch nicht besonders verständlich aus und erwartest möglicherweise zu viel von Froxlor-/Webserver-Neulingen. Ich nutze das Tool nur weil es mir mein Hoster untergeshcoben hat und keine Confixx/Plex-Lizenz mehr bezahlt. Problem 4: Wofür ist FCGID und libnss-extrausers etc??? Das hast Du nicht erklärt. Wozu sollte ich das überhaupt brauchen? Ich will doch nur EINE einzige PHP Version (7.3, stets die neuste) nutzen. Nicht zig Versionen parallel (bis hin zu Version 5).Und so wie Froxlor selbst anzeigt, läuft PHP 7.3 ja bereits. Kann ich das nicht einfach für alle Webseiten auf dem vServer festlegen? Siehe Punkt 4. // Eine Version für alle Webseiten Danke
×
×
  • Create New...