Jump to content
Froxlor Forum
  • 0

[solved] SMTP-Auth klappt nicht mit lagen Login-Namen


wittich

Question

Hallo zusammen,

 

habe das Problem, dass bei einer meiner Email-Adressen, die ?ber eine lange Domain l?uft, der Login des SMTP scheitert. Ich habe schon versucht das Problem einzugrenzen, jedoch bisher ohne Erfolg. In der /var/log/mail.log finde ich folgendes:

Apr 20 23:54:14 mail postfix/smtpd[22895]: warning: SASL authentication failure: Password verification failed
Apr 20 23:54:14 mail postfix/smtpd[22895]: warning: e180.adsl.xxx.de[85.000.000.13]: SASL PLAIN authentication failed: authentication failure
Apr 20 23:54:18 mail postfix/smtpd[22895]: warning: e180.adsl.xxx.de[85.000.000.13]: SASL LOGIN authentication failed: authentication failure
Apr 20 23:54:23 mail postfix/smtpd[22895]: disconnect from e180.adsl.xxx.de[85.000.000.13]

 

Ein Blick in die /var/log/auth.log zeigt bei dem Versuch eine Mail zu verschicken folgenden Eintrag:

Apr 21 00:31:21 mail postfix/smtpd[26228]: sql auxprop plugin using mysql engine
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin Parse the username wittich@soooo-lange-ist-mein-domainname.de
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin try and connect to a host
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin trying to open db 'froxlor' on host '127.0.0.1'
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin Parse the username wittich@soooo-lange-ist-mein-domainname.de
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin try and connect to a host
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin trying to open db 'froxlor' on host '127.0.0.1'
Apr 21 00:31:21 mail postfix/smtpd[26228]: begin transaction
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin create statement from userPassword wittich soooo-lange-ist-mein-domainname.de
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin doing query SELECT password FROM mail_users WHERE username='wittich@soooo-lange-ist-mein-domainname.de' OR email='wittich@soooo-lange-ist-mein-domainname.de';
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin create statement from cmusaslsecretPLAIN wittich soooo-lange-ist-mein-domainname.de
Apr 21 00:31:21 mail postfix/smtpd[26228]: sql plugin doing query SELECT password FROM mail_users WHERE username='wittich@soooo-lange-ist-mein-domainname.de' OR email='wittich@soooo-lange-ist-mein-domainname.de';
Apr 21 00:31:21 mail postfix/smtpd[26228]: commit transaction
[...]

Dann versucht er 3 mal sich zu autorisieren... immer ohne Erfolg.

 

Hat jemand noch eine Idee wo ich ansetzten k?nnte um den Fehler zu beseitigen?

 

Gru? Valentin

Link to post
Share on other sites

7 answers to this question

Recommended Posts

Okay hab jetzt das Debug-Level mal erh?ht in der /etc/postfix/sasl/smtpd.conf

log_level: 3

 

Beim ?berwachen der /var/log/mail.log (tail -f /var/log/mail.log) wurde dann unter anderem folgende Zeile ausgegeben:

Apr 25 13:38:09 mail postfix/smtpd[17650]: warning: SASL authentication failure: Password verification failed

Das Brachte mich dann auf die Idee noch mal das Passwort in der SQL-Tabelle anzuschauen und tats?chlich ist mir da ein simpler Fehler unterlaufen, da hing noch ein Leerzeichen am Passwort...

 

Also, Problem gel?st!

 

@xocii: Danke f?r deine Partizipation! :)

 

Gru? Valentin

Link to post
Share on other sites

Hier ein cat der /etc/postfix/main.cf:

 

## General Postfix configuration

# should be the default domain from your provider eg. "server100.provider.tld"

mydomain = wittich123.de

 

# should be different from $mydomain eg. "mail.$mydomain"

myhostname = mail.wittich123.de

 

mydestination = $myhostname,

$mydomain,

localhost.$myhostname,

localhost.$mydomain,

localhost

mynetworks = 127.0.0.0/8

inet_interfaces = all

append_dot_mydomain = no

biff = no

 

# Postfix performance settings

default_destination_concurrency_limit = 20

local_destination_concurrency_limit = 2

 

# SMTPD Settings

default_rbl_reply = $rbl_code RBLTRAP: You can't send us a E-mail today! // $rbl_class [$rbl_what] blocked using $rbl_domain${rbl_reason?; $rbl_reason}

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)

smtpd_helo_required = yes

smtpd_recipient_restrictions = permit_mynetworks,

permit_sasl_authenticated,

reject_unauth_destination,

reject_sender_login_mismatch,

reject_non_fqdn_hostname,

reject_non_fqdn_sender,

reject_unauth_destination,

reject_unauth_pipelining,

reject_invalid_hostname,

reject_rbl_client sbl-xbl.spamhaus.org,

reject_rbl_client ix.dnsbl.manitu.net,

reject_non_fqdn_recipient

check_recipient_mx_access cidr:/etc/postfix/mx_access

smtpd_sender_restrictions = permit_mynetworks,

reject_rhsbl_client rhsbl.sorbs.net,

reject_rhsbl_sender rhsbl.sorbs.net,

reject_rbl_client sbl.spamhaus.org,

#reject_rbl_client dialup.blacklist.jippg.org,

#reject_rbl_client opm.blitzed.org,

#reject_rbl_client cbl.abuseat.org,

reject_rbl_client bl.blocklist.de,

reject_sender_login_mismatch,

permit_sasl_authenticated,

reject_unknown_helo_hostname,

reject_unknown_recipient_domain,

reject_unknown_sender_domain

smtpd_client_restrictions = permit_mynetworks,

permit_sasl_authenticated,

reject_unknown_client_hostname

# Maximum size of Message in bytes (50MB)

message_size_limit = 52428800

 

## SASL Auth Settings

smtpd_sasl_auth_enable = yes

smtpd_sasl_local_domain = $myhostname

broken_sasl_auth_clients = yes

 

# Virtual delivery settings

virtual_mailbox_base = /var/customers/mail/

virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf

virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf

virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf

smtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_permissions.cf

virtual_uid_maps = static:2000

virtual_gid_maps = static:2000

 

# Local delivery settings

local_transport = local

alias_maps = $alias_database

 

# Default Mailbox size, is set to 0 which means unlimited!

mailbox_size_limit = 0

virtual_mailbox_limit = 0

 

## TLS settings

##

# TLS for outgoing mails from the server to another server

smtp_tls_security_level = may

smtp_tls_note_starttls_offer = yes

# TLS for email client

smtpd_tls_security_level = may

smtpd_tls_cert_file = /etc/ssl/server/wittich123.pem

smtpd_tls_key_file = $smtpd_tls_cert_file

#smtpd_tls_CAfile = /etc/ssl/certs/ca-certificates.crt

smtpd_tls_CAfile = /etc/apache2/ssl/wittich123.crt

smtpd_tls_loglevel = 1

smtpd_tls_received_header = yes

 

debugger_command =

PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin

ddd $daemon_directory/$process_name $process_id & sleep 5

 

 

milter_default_action = accept

milter_protocol = 2

smtpd_milters = inet:localhost:8891

non_smtpd_milters = inet:localhost:8891

 

 

Alle anderen Config's sind eigentlich unver?ndert...

 

Gru? Valentin

 

PS: Bei allen anderen Email-Adressen (also ?ber andere und vor allem k?rzere Domain's) hab ich kein Problem...

Link to post
Share on other sites

Mach dir von der Konfig ein Backup, und erneuere diese mal und sag was passiert.

 

Fehlermeldung bleiben die gleichen... und wie gesagt nur bei der einen langen Mail-Adresse... alle anderen SMTP-Accounts funktionieren einwandfrei.. daher ja meine Vermutung, dass das mit der L?nge zu tun haben muss.. hab mir auch schon den SQL-Tabelleneintrag angeschaut... sieht auch in Ordnung aus, dort sind Adressen bis zu einer L?nge von 255 Zeichen gestattet.

 

Meiner Meinung nach muss das irgendwie mit dem SQL-Plugin des Postfix/SMTPD zu tun haben... kann ich das Plugin irgendwie debuggen

 

Gru? V.

 

 

// Edit:

Habe mal gerade den Versand ?ber das Webmail probiert... mit Erfolg... hier klappt das versenden per SMTP :wacko:

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...