Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
lindi200000

bekomm keine Verbindung auf Postfix

Question

Hallo,

ich nochmal ...

 

Habe alles eigentlich supi eingerichtet, jedoch bekomme ich absolut keine Verbindung auf Postfix (Port 25).

Ich habe eine Telnet verbindung von extern und selbst vom selben Server aus probiert, kann aber absolut nicht verbinden.

Die Log Datei bringt aber auch incht wirklich was, was helfen kann.

 

Hier paar daten:

Debian Lenny

Postfix mit dovecot

 

mail.info:

Jan  5 20:38:27 debian postfix/master[13408]: daemon started -- version 2.5.5, configuration /etc/postfix
Jan  5 20:38:36 debian postfix/postfix-script[13412]: the Postfix mail system is running: PID: 13408

 

main.cf

## General Postfix configuration
# should be the default domain from your provider eg. "server100.provider.tld"
mydomain = tld.de

# should be different from $mydomain eg. "mail.$mydomain"
myhostname = mail.tld.de

mydestination = $myhostname,
   $mydomain,
   localhost.$myhostname,
   localhost.$mydomain,
   localhost
mynetworks = 127.0.0.0/8
inet_interfaces = all
append_dot_mydomain = no
biff = no

# Postfix performance settings
default_destination_concurrency_limit = 20
local_destination_concurrency_limit = 2

# SMTPD Settings
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_helo_required = yes
smtpd_recipient_restrictions = permit_mynetworks,
   permit_sasl_authenticated,
   reject_unauth_destination,
   reject_unauth_pipelining,
   reject_non_fqdn_recipient
   check_recipient_mx_access cidr:/etc/postfix/mx_access
smtpd_sender_restrictions = permit_mynetworks,
   reject_sender_login_mismatch,
   permit_sasl_authenticated,
   reject_unknown_helo_hostname,
   reject_unknown_recipient_domain,
   reject_unknown_sender_domain
smtpd_client_restrictions = permit_mynetworks,
   permit_sasl_authenticated,
   reject_unknown_client_hostname
# Maximum size of Message in bytes (50MB)
message_size_limit = 5242880000000

## SASL Auth Settings
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes
## Dovecot Settings for deliver, SASL Auth and virtual transport
smtpd_sasl_type = dovecot
mailbox_command = /usr/lib/dovecot/deliver
virtual_transport = dovecot
dovecot_destination_recipient_limit = 1
smtpd_sasl_path = private/auth

# Virtual delivery settings
virtual_mailbox_base = /var/customers/mail/
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf
smtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_permissions.cf
virtual_uid_maps = static:2000
virtual_gid_maps = static:2000

# Local delivery settings
local_transport = local
alias_maps = $alias_database

# Default Mailbox size, is set to 0 which means unlimited!
mailbox_size_limit = 0
virtual_mailbox_limit = 0

### TLS settings
###
## TLS for outgoing mails from the server to another server
#smtp_tls_security_level = may
#smtp_tls_note_starttls_offer = yes
## TLS for email client
#smtpd_tls_security_level = may
#smtpd_tls_cert_file = /etc/ssl/server/ues-force.de.pem
#smtpd_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
#smtpd_tls_loglevel = 1
#smtpd_tls_received_header = yes

debugger_command =
   PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
   ddd $daemon_directory/$process_name $process_id & sleep 5

 

ps aux | grep postfix

root     13408  0.0  0.1  31000  2124 ?        Ss   20:38   0:00 /usr/lib/postfix/master

 

irgendwo muss da ja der Hacken sein, nur finde ich ihn nicht.

 

netstat -a bringt nix

 

Hoffe ihr k?nnt mir nen Tip geben.

 

Gru? Lindi

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

So, ich bin jetzt um ieniges weiter, das anmelden scheint zu funktionieren, aber sobald ich eine z.b. Outlook testmail senden m?chte, kommt folgender Fehler:

 

452 4.3.1 Insufficient system storage; proto=ESMTP helo=<xxxPC>
Jan  5 21:49:09 debian postfix/smtpd[14020]: warning: not enough free space in mail queue: 44680699904 bytes < 1.5*message size limit

 

ich habe aber noch 47GB frei auf var.

Share this post


Link to post
Share on other sites

So, ich bin jetzt um ieniges weiter, das anmelden scheint zu funktionieren, aber sobald ich eine z.b. Outlook testmail senden m?chte, kommt folgender Fehler:

 

452 4.3.1 Insufficient system storage; proto=ESMTP helo=<xxxPC>
Jan  5 21:49:09 debian postfix/smtpd[14020]: warning: not enough free space in mail queue: 44680699904 bytes < 1.5*message size limit

 

ich habe aber noch 47GB frei auf var.

Die Fehlermeldung besagt, dass Du f?r die mailque 44680699904 bytes an Platz hast, aber Du brauchst 7864320000000 bytes.

Die Frage ist jetzt, wo liegen die Mailboxen und ist auf den evt. auf /usr zu wenig Platz (wegen mailbox_command)?

Share this post


Link to post
Share on other sites

zu wenig platz glaube ich einfach nicht. Hier einmal mein Platzverbrauch:

 

Dateisystem          Gr??e Benut  Verf Ben% Eingeh?ngt auf
/dev/hda1              48G  3,2G   42G   8% /
tmpfs                1006M     0 1006M   0% /lib/init/rw
udev                   10M  628K  9,4M   7% /dev
tmpfs                1006M     0 1006M   0% /dev/shm

 

Das die Partitionierung nicht gut ist weis ich selber, ist aber auch nur ein Testsystem auf einen Vhost. ( Zum gl?ck erstma nur Testsystem ^^)

 

//Edit: ich sollte mal mehr schlafen, das message_size_limit sind bei mir keine 50MB sondern fast 5000GB ^^. arg

Share this post


Link to post
Share on other sites





×
×
  • Create New...