Jump to content
Froxlor Forum

lindi200000

Members
  • Content Count

    52
  • Joined

  • Last visited

Community Reputation

0 Neutral

About lindi200000

  • Rank
    Advanced Froxie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hallo, ich habe mittlerweile ein leicht veraltetes Grundsystem meiner Froxlor Installation (Debian 8), das muss mal ein Update erfahren. Nun wahr meine Wahl, etwa ein reines Dist-Upgrade, wo ich aber befürchte das einiges an Inkompatibilität zustande kommt, oder das ich alles auf mehrere Docker Container aufteile. Die Container Lösung ist mir vom Gedankengang lieber, da ich so die Dienste dynamischer zwischen mehrere Server verschieben kann, ohne ein größeres config Problem zu bekommen. Nun aber die Frage, unterstützt Froxlor Multiserver? Wenn ja, gibt es vielleicht irgendw
  2. ich sehs gerade, das ganze habe ich vor einiger Zeit eingerichtet. das Howto weis ich nicht mehr. Ich denke das beste ist, das ganze nochmal mit dem Original dkim einstellungen aus Froxlor heraus zu konfigurieren. Gibt es dafür ein Howto was ich verwenden kann? So das am Ende die Einstellungen aus dem DomainKey-Einstellungen im Panel funktionieren?
  3. Sry, bisschen was vergessen in der main.cf wurde folgendes hinzugefügt: milter_protocol = 6 milter_default_action = accept smtpd_milters = inet:localhost:8891 non_smtpd_milters = inet:localhost:8891 in der opendkim.conf steht für die Keys folgendes drin: SigningTable dsn:mysql://froxlor:xxxxxxx@localhost/froxlor/table=panel_dkim_domains?keycol=domain?datacol=id KeyTable dsn:mysql://froxlor:xxxxxx@localhost/froxlor/table=panel_domains?keycol=id?datacol=domain,concat(dkim_`,dkim_id),dkim_privkey (xxxxx) ist das passende SQL Passwort Das müsste glaube alles sein.
  4. Hallo, ich habe ein Problem, das manche Mails bei mir nicht ankommen. in der Maillog sehe ich bei den entsprechenden Mails folgenden Fehler: milter-reject: END-OF-MESSAGE from ***[***]: 4.7.1 Service unavailable sudo netstat -nalp | grep dkim gibt mir folgendes aus: tcp 0 0 127.0.0.1:8891 0.0.0.0:* LISTEN 804/dkim-filter tcp 0 0 127.0.0.1:8891 127.0.0.1:56170 VERBUNDEN 804/dkim-filter udp 0 0 0.0.0.0:59872 0.0.0.0:* 804/dkim-filter Der Service läuft al
  5. - Domain erstellt mit www Alias - Verzeichnisschutz für den Pfad eingerichtet wo die Domain hinzeigt VHost wird nicht richtig aktualisiert. nach dem deaktivieren ging des Verzeichnisschutz geht alles. Dei Domain wurde mit Apache 2.2 erstellt, fällt mir gerade ein. Es kann sein das der Schutz, das Upgrade des VHost verhindert hat. Das wäre zumindest der einzigste Unterschied zu dem Rest.
  6. Ich habe für diese Domain eine extra PHP Einstellung. Ist da was was fehlerhaft? short_open_tag = On asp_tags = Off precision = 14 output_buffering = 4096 allow_call_time_pass_reference = Off safe_mode = {SAFE_MODE} safe_mode_gid = Off safe_mode_include_dir = "{PEAR_DIR}" safe_mode_allowed_env_vars = PHP_ safe_mode_protected_env_vars = LD_LIBRARY_PATH {OPEN_BASEDIR_C}open_basedir = "{OPEN_BASEDIR}" disable_functions = passthru,shell_exec,system,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate disable_classes = expose_php = Off max_execution_time = 30 max_input_time = 60 memory_l
  7. Ja der Haken war gesetzt. die anderen 50 VHost Dateien haben ja auch geklappt. Fehler ist glaube ich gefunden. Auf das Verzeichnis wo die VHost Datei zugreift war der Verzeichnisschutz von Froxlor drauf. Als ich den entfernt habe, passt auch die VHost Datei. Bug?
  8. Hallo, ich habe ein Problem mit genau einer VHOST Datei. Seit Apache 2.4 muss im Directory eines VHOST ja folgender Eintrag stehen. Require all granted AllowOverride All Genau dieser Eintrag fehlt aber in einer VHOST Config. Schreibe ich den eintrag manuell rein, dann funktioniert meine Webseite. Jedoch bei einen Froxlor reload wird diese Config wieder überschrieben. Ich habe die VHOST Datei schon gelöscht und komplett neu schreiben lassen, aber dann fehlen die 2 Zeilen von oben wieder. Eine Idee wieso es genau da fehlt? Eine Idee wie ich das in Ordnung bekomme? Gru
  9. Also ich habe nun mal eine normale Datei erstellt, die kann ich mit der /.well-known URL aufrufen. In den Errorlogs ist nix los, weder in der normalen Apache Log, noch bei den Kunden. Die Fehlermeldung hat sich nicht geändert. welche PHP Einstellungen greifen da genau? Die von der Domain, für das dass SSL Zertifikat genutzt wird oder? Was mich wundert, ist die Einstellung der Vhost datei für SSL. passt das so? SSLCertificateFile /etc/apache2/apache2.pem SSLCertificateKeyFile /etc/apache2/apache2.key SSLCACertificateFile /etc/apache2/apache2.crt SSLCertificateChainFile /etc/apach
  10. Hallo, das aktuelle update ist eingespielt. Die Zeile zum bearbeiten ist aber immer noch in der 166. Aber selbst mit der Anpassung haben, hat sich nix geändert.
  11. Habs grad im Release teil gelesen, das es für die RC Version kein deb gibt. Das erklärt wieso ich eine andere Version drauf habe.
  12. Über deb http://debian.froxlor.org jessie main hab ich die Version 0.9.36-1+wheezy1 Warum auch immer Wheezy (liegt das an meinem Systemupgrade?). apt-get update && apt-get upgrade bringt nix neues.
  13. Dann kommt folgendes: [error] Could not get Let's Encrypt certificate for ossi-connection.de: Please check http%3A%2F%2Fossi-connection.de%2F.well-known%2Facme-challenge%2FlsBmBncHYHfiGN5mtv8iLFesCSBYh0YhBV-TObUZ4f8 - token not available; PHP error: {"type":2,"message":"file_get_contents(http%3A%2F%2Fossi-connection.de%2F.well-known%2Facme-challenge%2FlsBmBncHYHfiGN5mtv8iLFesCSBYh0YhBV-TObUZ4f8): failed to open stream: No such file or directory","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":171} Die Änderung habe ich aber in der Zeile 166 gemacht. In der Zeile
  14. Ich habe gerade nochmal alles kontrolliert. Die Datei /etc/apache2/conf-enabled/acme.conf exestiert inkl. entsprechenden Inhalt. Letsencrypt ist aktiviert im Backend. allow_url_fopen = On ist Global gesetzt (PHP-Info im Backend) und auch auf der Domain wo Letsencrypt angewendet werden soll. ein Debug bringt leider weiterhin den Fehler [debug] Updating ossi-connection.de [debug] Adding SAN entry: ossi-connection.de [debug] Adding SAN entry: www.ossi-connection.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Acc
  15. Ok, das hatte ich alles schon. Bei einer Einstellung bin ich mir jedoch nicht ganz sicher. Der globale Alias zeigt auf /var/www/froxlor/.well-known/acme-challenge In den SSL Einstellungen bei Froxlor steht unter Verzeichnis für Let's Encrypt challenges: /var/www/froxlor Muss da der selbe Pfad wie bei den Alias rein, oder reicht das Froxlor Verzeichniss?
×
×
  • Create New...